Question about Phoenix Gold Xenon-600.1 Car Audio Amplifier

1 Answer

Phoenix gold xenon 600.1 power problem

I have a problem wiht my PG xenon 600.1 amp. It turns itself on and off as it pleases. It even came on when the remote wire wasnt even plugged in! I dont know much bout amps so i was wondering if this is a problem that can be fixed and where can i send it to get fixed.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Sometimes problems like this are caused by tiny strands of wire in the amp. These can cause catastrophic amplifier failure. If you pull the cover off of the amp, you should be able to see the strands (if they're present). If that's not the problem, you should send the amp back to PG for repair. Before you pull the cover, completely disconnect power from the amplifier.

Posted on Oct 09, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound from subs


You need power to the amp. If the light on the amp is not on then your amp is the problem. Get power to it.

Nov 10, 2013 | Phoenix Gold Xenon-400.1 Car Audio...

1 Answer

Can i use a 300 watt amp for 2, 800 watt woofers


yes, but you would not get the same performance as you would if you gave them the suggested power. I have found that it is always better to use a more powerful amp than your subs are rated for (as long as it is clean, high quality, low distortion power). I have had the best luck with name brand amps (kicker,rockford fosgate,phoenix gold,etc...). I hope this will be helpful to you.

Jul 30, 2012 | Phoenix Gold Xenon X10D4 - 10" D4...

1 Answer

I have amono 600.1 amp


if its mono there is nothing to bridge

Jul 12, 2009 | Phoenix Gold XENON 600.1 600 Watt...

1 Answer

My PG Xenon 600 watt amp will not power my subwoofers


hello it sounds like your problem may be in the remote/power wire that goes from the back of your radio deck to the amplifier. the amp should have a wire connection that says remote,p.con, or antenna. and its usually the smallest wire connector located by the power and ground wire. this wire goes to the solid blue wire coming out of the deck. you can conect the wires together any way you want. i usualy shave off a little pice of the wire cover and wrap the wire coming from the amp around the bare wire then cover it in electical tape or cut the blue wire from the deck at a fit length and use a wire nut and put the two cut ends in and also the wire coming from the amp. also make sure the amplifire dose not have power to it just to be safe. wouldent want to fry anything.

There is also the left and right wires(ususaly red and white) that go on the back of the deck to the amp.

also chek the volume on the amplifire

Apr 12, 2009 | Phoenix Gold XENON 600.1 600 Watt...

1 Answer

Crossover


i have lost my manual to the phoenix gold 600.1 xenon amp. i want to set it up by the book can you help me ?

Apr 25, 2008 | Phoenix Gold Xenon-600.1 Car Audio...

1 Answer

Pheonix Gold Xenon 600.1 power problem.


Do your speakers move in/out smoothly if you push on them?

Have you tried disconnecting the speaker wires from the amp to see if it would remain on?

Apr 11, 2008 | Phoenix Gold Xenon-600.1 Car Audio...

4 Answers

Led light keeps flashing on my phoenix gold amp


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty . Remember to disconnect all power including ground for about to 1/2 hour to discharge capacitors. You might get lucky and get a reset. .A thumbs up would be greatly appreciated if this answer is helpful to you. led-light-keeps-flashing-phoenix-gold-zb4bomd1rt4qms0dqd12kkt2-3-0.jpg

Aug 07, 2007 | Phoenix Gold Xenon-600.1 Car Audio...

Not finding what you are looking for?
Phoenix Gold Xenon-600.1 Car Audio Amplifier Logo

Related Topics:

175 people viewed this question

Ask a Question

Usually answered in minutes!

Top Phoenix Gold Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Mark Skinner

Level 2 Expert

77 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

229 Answers

Are you a Phoenix Gold Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...