Question about Alpine Air XL-15 Air Purifier

1 Answer

Troubleshooting it came with 3 plates do you use all of them at one time if so the middle one will not go in there is purple wires stopping it

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Alpine Air Master
  • 33,359 Answers

This could be due to a factory wiring error and you may have to make some adjustments to allow installation of the plate.

Posted on Nov 21, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I cant get the 3rd plate to go in to place purple wires r keeping it from going all the way


Third plate? Not on an XL-15. There should only be two slots. Send pic so I can help further.

Nov 20, 2013 | Alpine Air XL-15 Air Purifier

1 Answer

I HAVE THE FRESH AIRE MODEL JUST REPLACED rci CELL CLEANED FILTER AND CLEANED THE OZONE PLATE. THE FAN KEEPS TURNING ON AND OFF?? STARTS RIGHT BACK UP ON ITS OWN AND THROWS NO EROR MESSAGES??


The fan may be "surging" because something was not replaced securely after the RCI cell replacement.
1) First check the plug, making sure it is inserted FIRMLY into the back of the machine. Also check the outlet, making sure the plug is inserted firmly and the plug is not one that also has a major power-using appliance like a refrigerator or furnace drawing from it.
If this does not solve the problem, use the owner's manual or one that you can access via www,vollara.com , unplug and disassemble the machine and check all connections.
2) Make sure the plate (4" square white object with mesh center) is inserted correctly into the guides, both top and bottom, and is not inserted forcefully too far. It should just seat firmly. Make sure the metal contact "fingers" press firmly on the plate. (Tweak them to achieve good contact.)
If the plate was inserted incorrectly, correcting this should solve the problem. If there was no problem with the plate, or if this does not solve the problem, remove it and...
3) Make sure that the RCI cell is inserted correctly, turning the cell (like a fluorescent light bulb) until both ends are seated firmly.
Reassemble the machine. Also visually inspect all connecting wires to make sure none are loose, corroded, missing, broken, etc.
4) If everything is assembled correctly, the problem should be resolved.
If all of these troubleshooting steps fail, you'll need to contact Vollara (new name for EcoQuest) Customer service at 800-989-2299. Use #16618 for the referral number if you are no longer in contact with the authorized distributor who sold you the machine.

Jan 18, 2011 | Ecoquest Air Purifiers

1 Answer

My freshair 2.0 turns on and right back off. the screen lights up and then goes out.


The most common reason for surging or changing power levels is a loose connection somewhere.

1) Make sure the plug in the back is inserted firmly and the wall socket is live. The wall socket should not be powering a high-use appliance such as a furnace or refrigerator.
2) Make sure the plate is inserted firmly and correctly in the top and bottom "tracks" inside the machine. The metal contact fingers should be pressing firmly and evenly on both sides of the plate, in the metal screen area.
3) Inspect the interior of the machine, looking for loose wires, corroded clips, any broken wires or connections. (You or a handy friend may be able to repair the loose wires or clips; it's a pretty basic fix.)
If none of these troubleshooting steps solve the problem, the problem may be in the computerized system. For that, you'll need to get in touch with Vollara (formerly EcoQuest) customer service. 800-989-2299.

Jan 11, 2011 | Ecoquest Fresh Air Air Purifier

1 Answer

Dear Expert, I do hear scary sound like a electric spark once in a while, and then stop. Should I turn off the switch? Thank you.


Arcing (snapping) seems too frequent

1. If the electronic cell(s) are wet from washing, turn the air cleaner off for two to

three hours.

2. Check the cell(s) for broken ionizer wires or bent plates. Repair if necessary.
3. Wash cell(s) and prefilter(s) if dirty.

Sep 28, 2010 | Honeywell Enviracaire Elite F300E-1019 Air...

1 Answer

I have a Trion Max 5 1400. when the air is flowing past, I turn on the power switch and both lights come on, then go right off. We have had the unit for awhile, and have had the power module repaired...


Read the owner's manual for troubleshooting, it has a lot of information.
https://www.trioniaq.com/getfile2.aspx?fileid=9024
http://www.trionparts.com/trion-max-5-1400-air-cleaner-parts.html

Check the ionization wires are there, one may be broken and touching the ground plates.

Also check to see if the wires have a growth touching the ground plates. If so, clean the grids and wires; let it dry. Water and electricity don't play nice.

Jan 20, 2010 | Air Purifiers

1 Answer

What order to the 3 wires go on the on/off swith. ther is a purple, black and orange wire


found my note with the info i needed. neveremind and thanks for your help.

Oct 01, 2009 | Alpine Air Eagle 2500 Air Purifier

1 Answer

Ecoquest fresh air repair


Regardless of unit the purifier plates may need replacement. How are the plates cleaned? Could it be that there is a residue from the cleaning agent present after cleaning? With new plates there is a little oil on the plates to prevent oxidation when in storage or transit. A little rubbing alcohol would do the trick.
Make sure the plates are dry before putting them back into the unit.

If the plates are seated right and clean you should see a faint purple glow on the plates when the unit is on purify.

Let me know if that's the case.

Eric

Dec 18, 2008 | Ecoquest Fresh Air Air Purifier

1 Answer

XL-15S, NO OZONE


Hello fleamrk,

Several possiblities here. Not static sound means the plasma discharge plates aren't energized.

1) Missing, cracked or defective discharge plate (you say you cleaned the filter - did you mean the lint screen in back, or the glass or white ceramic plate inside)? No plate, no ozone (O3) production.

2) Bad connection in the high voltage leads*.

3) Bad electrical components*.

*I'm not an electrician, and recommend that only qualified personnel troubleshoot high voltage electronic, both for safety, and for preventing further damage to circuitry. Visible problems, such as corroded or broken terminals that can be swapped when it's de-energized (unplugged) is one thing; having to dig deeper into the electronics is something that I expect to rapidly end up costing more than it's worth.

Sep 29, 2008 | Ecoquest Living Air Classic Air Purifier

1 Answer

Pure-Ion not working?


Didja wash the plates? It takes a little maintenance, and there are a lot of things that could make it stop working (Magnum, anti-aircraft fire, someone tripped over the cord, power quality in Karachi is lousy, there's pudding in the works...) but washing the plates with dishsoap and water, (then drying them before trying to start again) ought to fix most things that could be wrong.

Sometimes a fiber (a gift from a guest, maybe) is protruding into the works that needs to be removed, but those are the main reasons.

Jun 20, 2008 | Brookstone Pure-Ion UV Air Purifier

3 Answers

Oreck XL air purifier problems


You probably have an open circuit in the high voltage circuit. Most likely cause is a broken or disconnected wire. The high voltage wires are very small diameter stainless steel and are connected to alternating aluminum plates by a crimp connection at the ends of the plated. If you insert an object like a brush or wood tongue depressor/popsickle stick in to scrub the plates during cleaning you run the risk of pulling the wires lose or worst case, breaking them. If you just pulled some loose they can be repaired ( I know because I have done it) but you have to partially disassemble the cleaner cartridge to get to the end of the plate(s) with the disconnected wire(s), open the tab that grips the wire, insert the wire in the tab, re-crimp it, and then re-assemble the cleaning unit. I would rate it as moderately difficult. Be careful in bending all the tabs as they are aluminum and will break if bent too much or too many times. Good luck.

Jan 26, 2008 | Oreck XL Professional Air Purifier

Not finding what you are looking for?
Alpine Air XL-15 Air Purifier Logo

Related Topics:

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Air Air Purifiers Experts

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1667 Answers

yadayada
yadayada

Level 3 Expert

75117 Answers

Jeff Osterhout
Jeff Osterhout

Level 2 Expert

73 Answers

Are you an Alpine Air Air Purifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...