Question about Worldwide 1996 Ford E250 Econoline 5.8L Alternator

1 Answer

Oil pressure gauge went out but van runs fine?

Oil pressure gauge started flickering then went out. didn't seem to lose pressure, ran on the hwy for 15 min after went out then idle in driveway 15 more. am I sure I didn't lose pressure, just a sensor?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 70 Answers

Just a sensor, or gague

Posted on Nov 21, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Gmc sonoma has no power but a good battery


This sounds like a bad ground. check all the heavy gauge cables attached to the frame. If one is loose, it will arc under a load, but lose its continuity.

Nov 10, 2013 | GMC Sonoma Cars & Trucks

1 Answer

I just purchased a 2000 GMC Savana 3500 with the 5.7 litter engine with 92000 miles on it. The temp gauge shows that the engine is running between 100 - 160 degrees, seems too cold. The oil pressure gauge...


you probably have your finger on the problem. have oil pressure test .when engine hot minimum 12psi.and change the thermostat.Don't cost much

Sep 16, 2013 | 2000 GMC Savana

1 Answer

2001 crown victoria lost oil pressure and just cut off now when i start the car after five mins the car start ticking really loud


i have a 2001 crown victoria was driving down hwy car made loud noise and shut off had it towed home got it started and has NO power almost couldnt get i in drive way, had been making a slite noise before that and bucking
for about 4 months in the last 3 weeks noise was getting louder. Was told could be timing chain how likely is this and how do i check it.

Sep 30, 2012 | 2001 Ford Crown Victoria

1 Answer

Ok, 2003 GMC Safari AWD 245,000 km. Drove 100km


sounds like an ignition switch glitch or ignition harness problem can be either depending on the amount of wear and tear with turning on and off of the ignition tumbler or possible chafing or inconsistent short in harness to ignition switch check the ground line up through harness first and check the wiring harness condition

Jan 03, 2011 | 2003 GMC Safari

1 Answer

O2 lincoln ls check engine light & fuel gauge went to empty the next day it wouldny start replaced fuel pump & fuel gauge ran fine drove about 40 miles the next day started it up check engine light...


You have two pumps,I guess you know that ,if you already did one. Did you check fuel pressure at the rail and check out the electronic pressure regulator? What codes are coming up and do they stay set?

Feb 05, 2010 | 2002 Lincoln LS

2 Answers

Possible oil pump problem


You need to determine if the engine has lost oil pressure (assuming the oil level is good) You need to place a mechanical gauge where the oil sending unit is that goes to your gauge. If this gauge reads low, you have an oil pump problem. Keep in mind that gauges and sending units can go bad. But the loosing power doesn't sound good. Start here to determine what is up.

Aug 20, 2009 | 1995 Chevrolet Camaro

1 Answer

2002 2.5l no oil pressure on gauge. Runs fine...no


You better put a manual gauge on your engine and make sure you have oil pressure. Could just be a faulty gauge or sending unit but I sure as heck would be checking it with a manual gauge.

Aug 01, 2009 | 2002 Jeep Wrangler

2 Answers

OIl pressure light flickers


change the oil pressure switch or the wrong oil

Jan 18, 2009 | 2001 Chrysler Concorde

1 Answer

Testing fuel pressure


the port is on the fuel rail on top of the motor. it looks like a big air valve that you find on the wheel.

Nov 09, 2008 | 2002 Kia Sedona

Not finding what you are looking for?
Worldwide 1996 Ford E250 Econoline 5.8L Alternator Logo

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Worldwide Electrical Supplies Experts

jhnolson

Level 3 Expert

822 Answers

wadingriver
wadingriver

Level 3 Expert

2069 Answers

ka4iup
ka4iup

Level 3 Expert

3957 Answers

Are you a Worldwide Electrical Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...