Question about Car Audio & Video

1 Answer

Hifonics brutus bxi proHifonics Brutus BXi 1206D amp got it from a friend it turns on but when i connect my speakers its making a crackling sound when the amp is down i test my speakers and its working fine it almost sounds like something is blown

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

YOU WILL NEED TO TAKE IT TO A PROFESSIONAL REPAIR PERSON. SOUNDS LIKE A TRANSISTOR IS CRACKED AND READY TO BLOW.

Posted on Nov 20, 2013

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 631 Answers

SOURCE: no sound in my Hifonics Brutus BXi 1206D amp

Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Posted on Jan 02, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a brutus bxi 1206d 1200 watts, and the amp is coming on fine not protected. But there is no sound output. u can hear a small feedback rumble when connecting the input rca's. But thats it. My...


i would check the speaker cables to see if something came disconnected first maybe wire i touching other terminal shorted out the channels output .

run a new set of rca cable to see if one use are bad . check to see if rca cables pluged into right output of radio . check to see if your remote wire is powering up the amp to turn on the amp ..

will still light up with battery power but will never put output to the speakers with out the remote turn from the radio ... how to check this is to disconnect the cable at the amp and take a short 18 gauge wire and strip both ends and touch the battery terminal at the amp terminal one end the other end where the remote wire is mounted on the amp if do this for a few seconds to see what happens or better yet buy a digital volt meter and check for 12volt a the remote wire when you turn on your radio

Dec 23, 2010 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Is the brutus amp blue led light suppose to stay on when the car is off?


No. The LED should be off when the radio is off (amp turns off as well)

It sounds like you have constant 12volts applied to your remote turn on lead. The amplifier will have 3 connections for power:

1. 12volt constant
2. chassis ground
3. 12volt switched power - this wire should come directly from your head unit. It only sends 12 volts when the radio is on allowing to amp to power up only when the radio is on.

Dec 22, 2010 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Hifonics brutus 2000 watt help??!!??


If an RCA took a dive your amp has most likely seen a very nasty input spike and may never be the same as its circuitry has been damaged.....sorry

Mar 09, 2009 | Hifonics Brutus BXi 1206D Car Audio...

2 Answers

Hifonics amp keeps blowing the main fuse


have u tried using thicker wire from the battery to the amp u need to put a fuse in there thats a minumum 60

Jul 15, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Brutus 1206D


set the lp filter to about 100 to 125 (or lower if want seep boomy only) , put the bass eq no more than 75% but i would recommend no more than 50%, gain is to match the sound not to adjust power with so it is a user preference start all the way down and slowly go up till u hear distortion then turn it back down by about 10 - 15 %, phase shoild typically be at 0 degrees, subsonic depends on if you r using sealed or ported ported turn it all the way down then adjust as needed to get rid of the lower sounds you dont want (muddy sloppy sounding bass) if sealed turn it all the way up to at least 35 hz.

Jun 18, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Brutus 1206D


u need at least another amp and set em at 2 ohm and then just take it to a shop aand ask thee guy to equalize it he shouldnt charge u or at least 10 bucks

Jun 18, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Brutus 1206D


yes it can only at 2 ohms never 1 ohm good luck

May 25, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

High Pitch Whine from Amp (not speaker)


make sure your rca andpower/remote wires are ran on seperate side of your car.it maybe recieving some kind of interference from the alternator. try buying higher shielded wiring too

Apr 20, 2008 | Hifonics Brutus BXi 1206D Car Audio...

4 Answers

No sound in my Hifonics Brutus BXi 1206D amp


Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Jan 01, 2008 | Hifonics Brutus BXi 1206D Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

yadayada
yadayada

Level 3 Expert

75197 Answers

The Knight
The Knight

Level 3 Expert

73698 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...