Question about Hifonics Brutus BX 1505D Car Audio Amplifier

1 Answer

Okay i have a problem hifonics brutus 1500 mono d class amp

Okay to start i bought this amp off one of the guys i work with it was fine when i bought it but then about a month later it stopped working everything still lights up like the (HIFONICS) on the front of the amp it still light up and everything but it has a (red) power light instead of a green one and no sound come from the amp PLEASE HELP!!! i really dont want to send it into hifonics they will charge an arm and a leg to fix it

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers
Re: okay i have a problem hifonics brutus 1500 mono d...

Well your amplifier is obviously going into protect mode,(i used to have this amp and it is awesome) anyway i would go through just to be sure and check all the power connections with a test light, remote wire, positive, and ground. and check the fuse to see if it is still good. you can buy a test light at wal-mart and any automotive store. if you stil have a problem then i would check to see if your running below 1 ohm on this amp. that would cause it to go into protect mode. if all this fails i would just go buy a new one.

Posted on Oct 07, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have 2 Pioneer TS-W3002D4 12 In and a Hifonics Brutus BRZ1200.1D D-Class Mono Block what's the best wiring

you need to wire each sub down to 2ohms then wire them together like the one in this pic witch will give you 1ohm so you will be getting every bit of power that amp has but you should get a bigger amp for thos speakers

Mar 24, 2013 | Car Amplifiers

1 Answer

I bought a hifonics bxi2006d new and doesnt turn on

you should not have any spark from your may want check and make sure your ground is properly installed. Try wiring the amp without the cap and see if that works.

Mar 28, 2010 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Will hilfonics brutus 2010d mono work??

Well with the correct powering system, heaps of paralleled 12 volt Batteries, & a Beefed up Alternator to charge them, I guess so, BUT it is only Mono, so you will need TWO to provide stereo output

Mar 06, 2010 | Hifonics Brutus BX 1605D Car Audio...

1 Answer

I have a 2000 watt hifonics brutus amp worked fine but 1 day it just stopped working..the power light doest light up but the hifonics led lights are still on...whats the problem?

there is a step up converter inside the amp that likes to come loose from the board. This may be your problem. Otherwise Check all the chips for burns or disconnect

Nov 13, 2009 | Hifonics Brutus BX 2005D Car Audio...

1 Answer

I have a HiFonics 1206D amp and it keeps blowing the main fuse

The 60A fuse is WAY too small!!

The amplifier's Fuse is 80A
You will want the MINIMUM battery fuse @ 80A as well.

Since the current draw at the battery is greater because of the resistance of the wire - an 80A - 100A fuse is recommended.

The purpose of this fuse is to protect your BATTERY if something happens along the length of power wire.

What kind of "shop" are you using?? I would find another one!

Thanks for using FixYa - a FixYa rating is appreciated for answering your FREE question.

Jun 28, 2009 | Hifonics Brutus BXi 1206D Car Audio...

4 Answers

No sound in my Hifonics Brutus BXi 1206D amp

Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Jan 01, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Problem with hifonics 1505 class d mono

The positives are connected together and the negatives are connected together. The two pairs of terminals are for convenience. You'd connect one speaker to a pair of positive/negative terminals and you'd connect the other speaker to the remaining pair of positive/negative terminals.

You need to confirm that you have a good signal feeding the amp. If you have another amp in the vehicle, swap the RCA cables between the amps to see if it makes a difference.

You also need to confirm that the speaker are working properly and that there are no broken connections in the wires. If you disconnect the speaker wires from the amp and touch the wires across a D-cell battery (for a fraction of a second), the speaker should pop. if it doesn't, check the wiring to determine why.

Dec 27, 2007 | Hifonics Brutus BX 1505D Car Audio...

Not finding what you are looking for?
Hifonics Brutus BX 1505D Car Audio Amplifier Logo

Related Topics:

1,267 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers


Level 3 Expert

56925 Answers

Robert marquette

Level 2 Expert

102 Answers

Are you a Hifonics Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides