Question about Amplifiers & Preamps

2 Answers

Sony TA-F210 amplifier no sound

Hi i have a sony TA-F210 , with no sound. The power is ok. I opened it and checked some things but didn`t find something wrong yet I am a beginner in electronics. I checked the power on the driver ic`s and it`s not good. its very low 2 volts. The power rectifier and power controller ?c`s are working (7815 and 7915). The relais works also. I don`t know why the driver ic`s get very low voltage. But i`m only a beginner, i am stuck now. Anyone has a solution or tip? Thanks!

Posted by on

2 Answers

Re: sony TA-F210 amplifier no sound

Check R803 and R804!!! They must be 0.33 Ohms. When they are more check the capacitors.

Posted on Apr 27, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 682 Answers
Re: sony TA-F210 amplifier no sound

Bring data sheet of this ic from the net-check supply voltage(vcc or vdd)-check ground.apply audio signal and test if it is present in input pins after that check your signal in output pins.have a visual inspection around the ic for burnt resistors or bad capacitor. if every thing is fine replace the IC.

Posted on Mar 11, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I haves an amplifier SONY TA-F210 to repair. The four "final" transistors are take out and miss. I haves no ideas of witch kind of transistors need. Please I need the list of component (or the...

You can download the manual included schematic diagram from here:,f210.pdf/download.html

When you use the link you get to a page where you have to wait some minutes to be possible the downloading.
Good luck!

Aug 04, 2011 | Sony Amplifiers & Preamps

1 Answer

My digital amplifier S-MASTER,mod HDC-SB300 just 5 seconds after I turn it on swithes off by itself and the standby light keeps flashing and the display stays off and i can do nothing..thanks

may be ur amplifiers any of the output channel have some problem. that's why it goes off after power on, protecting ur speakers. disconnect all the speakers and inputs and then power on it if works check ur speakers and inputs. if not there is fault inside ur amplifier.

Dec 22, 2010 | Sony TA-N9000ES 5-Channel Amplifier

1 Answer

I have just bought a used Sony Integrated amplifier TA- F210 and it didn't come with the owner's manual so I don't know the RMS wattage to enable me connect speakers with the appropriate wattage. Could...

Hi, I brought a Sony TA-F-210 new back in 1990 $ 650 NZ , and has been a very .. very good amp. Earthquake ruined it !! I still have the owners manuel and it says for UK and other countrys DIN, 1 kHz, 8 ohms . 70w + 70w . or . 20Hz-20kHz THD 0.05%, 8 ohms . 50w + 50w Hope this helps. Have been running big old 3 way 8 ohm 50w speakers for all its life and it grunts.. or did !! Nobody belived me I was running only 50w speakers !! I dont know what I will replace it with.. You will enjoy. Might look for another one ! Wayne.. NZ CHCH

Nov 26, 2010 | Amplifiers & Preamps

1 Answer

I accidentally plugged my 110V amplifier to 220V outlet.It has no power anymore.what possible solution for this. Thank you very much. Do I need to replace the rectifier in it's circuit?

Hi and welcome to the site,

Initially, on a completely dead Sony TA-N9000ES, primary suspects to be checked would be:
  • 8A F1 fuse;
  • primary winding of T1 transformer;.
  • fusible resistors R816, R817 and R818.

Good luck and thank you for asking.

Jul 13, 2010 | Sony TA-N9000ES 5-Channel Amplifier

1 Answer

Sony TA-E9000es. No Display, No Sound. Software Ver 1.18. Has Bulletin HIFI1-99-028R1 performed. (Add capacitor, replace resistor)

also replace Q108 @ Q109 on power board. If that does not fix it then also replace PH101 & PH102. Also on Power board.

Jan 14, 2010 | Sony TA-E9000ES Amplifier

2 Answers

Got power but no sound

a number of things can cause this from bad
audio IC amps. to diodes and caps.
even cold solder joints.
maybe this will help some.

Oct 11, 2009 | Sony TA-FE370 2-Channel Amplifier

1 Answer

Sony preamp has no speaker output but headphone jack work fine

If this thing is a pre-amp , it will not drive any speakers.
You'll need a power amp to connect the output of the pre-amp to...then speakers.

PLease rate my help ...Thanks


Mar 22, 2009 | Sony Amplifiers & Preamps

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

1,195 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts


Level 3 Expert

4518 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

66685 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides