Question about Car Amplifiers

2 Answers

Power not turning on no led activity is it possible that the processor is defect? have no servmanual so its very difficult some measurement values would be helpful regards raikkonen

Posted by on

2 Answers

Re: power

Yes it really help me to get my system running thank u my buddy.

Posted on Sep 11, 2008

  • Level 1:

    An expert who has achieved level 1.


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    An expert who has answered 20 questions.

  • Contributor
  • 65 Answers
Re: power

You can short the remote turn on to the +12V and see if the amp comes on that way. If not, either the amp is hooked up wrong, or it's faulty. Let me know and be sure to leave good feedback or I don't get paid.

Posted on Oct 03, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

My nitro bmw 486 cuts out when i turn the volume up alittle bit,subs start crackling and distorting turn volume back down sounds just fine amp doesn't go to protect mode still works 4 guage wire a

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty D.A thumbs up would be greatly appreciated if this answer is helpful to you. nitro-bmw-486-cuts-out-when-turn-volume-lv2kkrmxrai4iihdvw4m3np2-1-0.jpg

Jul 20, 2012 | Nitro BMW-486 Car Audio Amplifier

1 Answer

Power led flashes and amp doesnt work at all

Hello hexi_86, The amp is going into protection mode. If it goes into protection immediately upon power up, either the amp itself is defective or it is getting too high or too low of a voltage or current, or the outputs are shorted. 1) Make sure that the battery voltage, as measured at the amplifier?s +12 volt and ground terminals, is 11 volts or more (your alternator voltage is typically about 13.8 volts). So if you have 11 or less at the amp terminals, your wiring is too small or defective. 2) Check all +12 volt and ground connections. 3) The use of loudspeaker impedances below the recommended minimums will cause the amp to draw excessive current. Check by removing the speaker wires one at a time to locate a shorted wire or defective speaker. 4) Check all speaker connections. 5) Remove RCA inputs and see if the amp powers up properly. A shorted or grounded RCA cable can cause the amp to go into protection. If all these check out, the amp itself is probably shorted internally, most likely the output MOSFET's. In this case it needs professional repair or replacement. Hope this helps.

Sep 19, 2009 | Blaupunkt VA-2100 Car Audio Amplifier

1 Answer

Red protection light wont turn 2 green no matter what so the amp wont work

Hello mcis43fan,

The protection circuit can be activated by shorted or grounded wiring or it can be caused by a defect in the amp itself.

First, disconnect all wires except power, ground and the remote turn-on lead and see if the amp powers up normally. If it still goes into protection, the amp is defective, most likely shorted outputs and needs repair or replacement. If the amp powers up normally, test the other wiring for shorts and grounds. You can reconnect them one at a time to determine which one is causing the problem.

Hope this helps.

Aug 06, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer


The amp is almost certainly repairable... If it's defective.

Have you tried disconnecting the speaker wires from the speaker terminals to see if the amp would power up normally?

Apr 17, 2008 | AudioBahn A1300HCT Car Audio Amplifier

2 Answers

Amp powers on, but stays in protect mode

Shorted output transistors are the most common reason for amplifiers to go into protect. How much do you know about electronics/electronic components?

If you're a newbie, read THIS page.

Would it be possible to send me a set of high quality photos of the amp's internals?

Apr 17, 2008 | MB Quart RAA1000 Car Audio Amplifier

1 Answer

The led of protection is on in my amplifier z1000d

maybe you have defective speaker! try to cut out your speaker from the amplifier then you power on again! if the protection is in again you have defective power output! transistors or mosfet transistors.

Sep 27, 2007 | Hifonics Zeus Z1000D Car Audio Amplifier

3 Answers

AUDIOBAHN a2300hct problems

This indicates a possibility of a power supply issue, you may have to open up the unit and take voltage measurements to determine if the voltages are correct. In order to do this you will need a schematic diagram of the unit. Once you have the schematic you will be abor to tell which voltages are legitimate. I hope this helps

Sep 15, 2007 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

No Sound coming out of amp to subwoofer

check the fuse box and make sure there is no loose connection there. also check the wire that feeds power to that amp. good luck

May 23, 2007 | AudioBahn DUB Mag Audio DUB1002 Car Audio...

1 Answer

Power Problem, LED Lights up and then shuts off

Do you have the switch or activate wire on the new amp. to the right hookup? If you do, then theres a problem with the amp and if your not a tech these can be a difficult thing to trouble shoot. Take back the amp or seek out a pro to test it on a bench. Good Luck

Jul 24, 2006 | American Pro VS1405 Car Audio Amplifier

3 Answers

Won't turn on

Make sure you check to see that the power wire going to the amp dosent have a bad connector on it or the wires is a dedicated for the amp. At the power wire measure for 12.5 to 13volts at the amp while the cars running and then if alls ok there remove the speaker wires and the input wires WHILE THE AMP IS OFF. then turn back on the amp is the light brighter??? if not again turn off the amp and measure the currant draw at the amp without and speakers or input. If its over a few amps the amp needs serviceing. If not then check and make sure all your speakers are good and that ones not shorted as well. Dont forget to check the crossovers too>> You didnt say if they were passive or active types

Mar 21, 2006 | Power Acoustik PS2-820 Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides