Question about Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

3 Answers

Not dispensing water and no suction

My bissell was in storage for 3 years. I got it out to clean carpets today and it won't dispense soap or water or pull anything up

Posted by on

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

I'm assuming the belts are OK.... Your heater is clogged. Unplug the machine and let it sit for 30 minutes. Take the handle apart, there will be a 4 inch by 8 inch metal box inside. This is the heater. Remember I said to let the machine sit for 30 minutes? If you didn't, the heater may be EXTREMELY hot!! Disconnect the two hoses going into it, and clean the metal pieces out (that the hoses connected to) with a needle or very small drill bit. You may want to remove the 6 or 8 screws holeding the heater together and remove the cover to clean it out. Reassemble and fill both tanks with VERY hot water ONLY and run the machine to rinse the entire system.

To prevent future reoccurences... use only Bissell extraction shampoos. Never put anything in the detergent tank except shampoo. (And only water in the water tank) Mixing chemicals with anything else turns the water/detergent mix to sludge. Also, when finished shampooing, put ONLY water in both tanks, and run the machine until one of the tanks run out of solution. Doing this rinses the hose lines out and prevents hardening of the solution in the heater ports.

I've fixed these machine for years. No dispensing is almost always the heater clogged.

Posted on Nov 26, 2007

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

If it seems like the tank does not fit in securely, the round gasket that goes around the valve at the bottom of the tank may have come off and actually be in the hole in the bottom of the vacuum base. It looks like it belongs there but you can pull it out with some needle nosed pliers. After you remove it, put it around the valve on the bottom of the tank, then it will fit into the hole again and everything should seal correctly. Mine was not spraying and would not suction well. figured this out and now it works great again.

Posted on Nov 14, 2007

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Check to be sure all of your seals are intact - 3 years and they may have dried out. Also, disassemble the solution flow indicator (the thing that spins when you're spraying) and clean it out thoroughly. You may also want to flush a good amount of hot water through the part where the soap dispenser goes - dried soap will keep it from dispensing.

Posted on Sep 30, 2007

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Water not dispensing


Check the release valve on bottom of clean water reservoir unscrew if needed, once again if your not sure run hot water in the solution tank through the system to help remove old soap residue and always run hot water through to prevent future problems after cleaning carpet and storing.steve

Jun 06, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

It isnt puting any liquid down


I have a Proheat 2X and had the same problem. I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing.

SO, an alternative to throwing out my unit and buying somethign else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW. Don't know if this will help, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 24, 2010 | Bissell Carpet Cleaner Powerbrush Deep...

1 Answer

The water is not coming out to clean the floor


Your unit uses water, correct? I have a Proheat 2X and it wouldn't dispense water. I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing.

SO, an alternative to throwing out my unit and buying somethign else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW. Don't know if this will help, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 21, 2010 | Bissell 1697-7 Powersteamer Pro Deluxe...

1 Answer

My bissell pro heat 2X has stopped dispensing water from the tank, the suction is working and it seems to be dispensing the detergent, so it is not rinsing or washing with water. I have cheaked to see if...


I have a Proheat 2X and had the same problem. I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing.

SO, an alternative to throwing out my unit and buying something else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW. Don't know if this will help, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 19, 2010 | Vacuums

1 Answer

It won't dispense water or suction it up


I have a Proheat 2X and had the same problem. I don't know if this will work with your unit... but I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing.

SO, an alternative to throwing out my unit and buying something else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW. Don't know if this will help, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 19, 2010 | Bissell Carpet Cleaner Powerbrush Deep...

1 Answer

When I am cleaning carpet, the water spray works


I have a Proheat 2X and had the same problem. I don't know if this will work with your unit... but I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing.

SO, an alternative to throwing out my unit and buying something else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW. Don't know if this will help, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 19, 2010 | Bissell 25A3 Upright Vacuum

2 Answers

Basic instructions and mixture ratio of cleaner and water


I would not leave the solution on the carpet for more than a few minutes! Clean it right away to minimize chances of bleaching out your carpet.

I have a Proheat 2X and and it would not dispense water & cleaning solution. I don't know if this will work with your unit... but I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing. With the dial set to "Tools", I had the same problem.

SO, an alternative to throwing out my unit and buying something else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW on carpet & tool settings. Don't know if this will help you, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 18, 2010 | Bissell 7920 ProHeat Pro-Tech Upright...

4 Answers

Bissell pro heat cleaner


This could be due to dried out soap in the works below the dispenser. Try cleaning the hole, putting plain water in the soap dispenser to clean it out further. You could just put some soap in with the water. Be sure to run lots of rinse water through afterward to clean out the heating unit.

Aug 18, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

1 Answer

Soap dispenser


Probably plugged with soap. Try to clean the hole under the shampoo dispenser. Put plain water in the dispenser and hope it gradually cleans it out.

Jun 14, 2007 | Bissell 1697-7 Powersteamer Pro Deluxe...

Not finding what you are looking for?
Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum Logo

371 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18429 Answers

Brad Brown

Level 3 Expert

18072 Answers

CJ C
CJ C

Level 2 Expert

66 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...