Question about RTO Atwood Water Heater - 6 Gal LP

Open Question

Atwood furnace 7920-11 flashing single code every 3 sec.

Posted by Anonymous on

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
motor1258
  • 6674 Answers

SOURCE: atwood 7920-11 furnace will not light. I am trying

Your electrode acts as flame sense as well. Remove electrode and clean it thoroughly/carefully especially at end where flame would be sensed and retry. Be sure connections on high tension wire is good and clean as well as connector and contacts on circuit board as well. If still same result, replace electrode.

Posted on Oct 12, 2011

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where do I find an owners manual for 1994 cobra seirra 5th wheel ?


THERE SHOULD BE A RESET BUTTON ON THE UNIT,YOU COULD TRY THAT OR GO TO ATWOOD.COM FOR SCHEMATICS,CHECK FOR MODEL #S FOR THAT YEAR .THESE UNITS HAVE NOT CHANGED MUCH IN MANY YEARS .IF IT DOES NOT WANT TO LIGHT ,LOOK IN THE TUBE OF THE UNIT FOR DIRT DOBBERS THAT MAY CONSTRICT THE FLOW OF GAS.THE RESET IS USUALLY BLACK AND NOT VERY VISIBLE,GOOD LUCK,HOPE IT MAY HELP

Dec 13, 2013 | RTO Atwood Water Heater - 6 Gal LP

1 Answer

Atwood 7920-11 furnace will not light. I am trying to light the furnace on my 2006 Jayfeather 19H camper that is an Atwood and looks to be an automated pilot lighting system but I continually get a flame...


Your electrode acts as flame sense as well. Remove electrode and clean it thoroughly/carefully especially at end where flame would be sensed and retry. Be sure connections on high tension wire is good and clean as well as connector and contacts on circuit board as well. If still same result, replace electrode.

Oct 05, 2011 | RTO Atwood Water Heater - 6 Gal LP

1 Answer

I have a gc6aa-10e hot water heater. I only get about 40 sec of hot water. I have raplaced check valve and put new thermostats in the water heater. I really dont know what else i should check. Need help...


Here is website for brochure and support center. http://www.atwoodmobile.com/water-heaters/atwood-water-heaters-brochure.asp

If it's electric it sounds like the elements.

Apr 23, 2011 | RTO Atwood Water Heater - 6 Gal LP

1 Answer

Atwood water heater lights and goes off. i can hit the switch and will light and go off. it has spark ignition. lights fine but goes out in 2 sec.


Remove the wires at both ends of the thermal cut-off that is located in the little plastic sleeve below the pressure relief valve area and it's connected to spade connector on thermostat disc. Once removed, connect the female spade from wire to male spade on thermostat disc, and try to light now. If all's o.k. replace thermal cut-off as it is a safety feature to protect in case of flame up.
If not, get back to me.

Jan 16, 2011 | RTO Atwood Water Heater - 6 Gal LP

1 Answer

My 2007 Fleetwod ##0 FKDS TT has no hot water delivery, (cold is Fine) No water comes from any faucet (3), or shower(2). When hot water is tried a short squirt of water (Les than 1/2 sec ond) comes out and...


Check for faulty (broken/apart inside) and replace check valve on hot side of tank (top line) between line connection and tank. Stem, spring etc, of new one goes in facing into tank.

Jul 18, 2010 | RTO Atwood Water Heater - 6 Gal LP

1 Answer

Atwwod water heater 6 gallon changed thermostate made sure everything is lined up and cleaned out for spiders still will not stay lighted ticks lights then goes out 3 sec


Try taking that little thermo cut-off out of the circuit. It's inside the plastic sleeve. Look close where it attaches, remove it, and connect wire to where it was connected and then try it. Also make sure electrode is clean and aligned to sense the flame from burner. Let me know.

Apr 26, 2010 | RTO Atwood Water Heater - 6 Gal LP

1 Answer

My water heater will not light??


MAKE SURE YOU HAVE A GOOD 12VOLT SUPPLY TO THE BOARD. CLEAN THE BOARD CONTACTS AND CONNECTOR.

Nov 02, 2009 | RTO Atwood Water Heater - 6 Gal LP

Not finding what you are looking for?
RTO Atwood Water Heater - 6 Gal LP Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top RTO Water Heaters Experts

Brad Brown

Level 3 Expert

15639 Answers

Donni Steen

Level 3 Expert

659 Answers

Mike

Level 3 Expert

4340 Answers

Are you a RTO Water Heater Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...