Question about Garden

Open Question

Balboa vs501- the control panel just shows dashes and when you push Jets, temp or lights nothing happens. Please assist. Thank you.

Posted by Anonymous on

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
Ian  Hot Tub
  • 77 Answers

SOURCE: I have a catalina spa with BALBOA CONTROL PANEL

Where are you from?

If you live in the UK give me a call/email as I have worked on lots of Catalina Spas over the years.
http://hottub.synthasite.com

Regards,
Ian.

Posted on Apr 01, 2010

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Spa has a Balboa 500z Top side and control panel. It was running at 104 degrees and then one day it just shut down. The Circ pump won't start up at all and when I first turn on the power, I hear the...


Turn breaker power off. Verify now power to unit with volt meter. Most systems have in line over temp over current to protect circuit board and motor. Also the water level switch must be made to complete interlock condition. Check the heater coil for continuityas it may have opened. Check heater for continuity to each coil set. There is an interlock that is for diagnostics on start up that will prevent unit from starting. Look for any melted wires or components too. Always know and verify breaker settings. Verify your meter with known voltage reading first. Be safe my friend.

Jun 04, 2017 | Balboa Instruments Pool & Spa

1 Answer

Our 880 Marin hot tub is constantly running the jets on 1/2 of the tub as if the circulation pump is running. The icon on the control panel does not show the jets are on. When we push the button to turn...


sounds to me with a power surge you could have a relay on the circuit board not working properly.
You will most likely need to change the circuit board to correct the problem.

US Parts Center

Sep 22, 2013 | Pool & Spa

1 Answer

Balboa VL700S control panel jets 1 not working


Your problem is going to be in the circuit board in the spa control box under the skirt.
You have a bad relay.
Rod
US Parts Center

Jun 25, 2013 | Pool & Spa

2 Answers

I need to no how to wire in my balboa pump into my 1996 beachcomber hot tub.There are some white wires I dont know where they should be going to!


While this is not an easy thing to troubleshoot offsite, if you want to email photos of your pump, wires and control pack, we can possibly assist. send detailed information and detailed photos to info@coastsideservice.com

Mar 21, 2010 | Pool & Spa

1 Answer

Panel reads HHO-----, no temperature display until activate jets, then shows a temperature drop sometimes down to 65 degrees ,then starts heating upwith jets going


"OH" is an overheat error. In normal function, it is used as a safety shut off if the spa water temperature reaches over 110 degrees in the event of a thermostat failure. But more commonly, (if the water temp hasn't gotten too hot) it indicates that the temp sensor(s) have failed. If you have a digital display on the topside controller of your spa, then it is a circuit board controlled spa pack. Most spa builders use the same control pack manufacturer - Balboa Watergroup. The sensor kit usually consists of 2 probes and wires that plug directly onto the circuit board. Depending on the spa, they could both be located onto the heater manifold, or one on the manifold and one mounted to the tub making direct contact with the water via a thru-wall sensor mount. If I knew the spa manufacturer, I could further assist you. If you replace the sensors, and encounter the same problem... then the circuit board is bad, and usually a costly replacement. The sensors are usually listed as a "BA sensor assy" Hope this helps you,

Dec 24, 2009 | Qca Spas Jewel Series Topaz Plus Hot Tub

1 Answer

Ac/heating problem


Same problem for me. Local garage seems to think replacing the control module in the dash will solve the problem. I also have clicking sounds behind where the relay junction box is (under dash). My problem is intermitant so I'm also thinking that replacing a relay or two might also help.

Mar 19, 2009 | 2000 Dodge Grand Caravan

Not finding what you are looking for?
Garden Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Garden Experts

Dennis Key
Dennis Key

Level 3 Expert

2478 Answers

john h

Level 3 Expert

12173 Answers

yadayada
yadayada

Level 3 Expert

76132 Answers

Are you a Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...