Question about Hoover Vacuums

1 Answer

I need help finding out why there is no suction with my hoover. The brushes are spinning and the windtunnel looks active but no suction either on floor or hose.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Hoover Expert
  • 357 Answers

What model ? If there is suction from the end of the hose there could still be none to the floor. You may have a clog between where the hose connects to the nozzle and the intake behind the brushroll.
Turn the machine on and listen for a change in pitch of the motor when you disconnect the hose, verses having it attched to the nozzle.

Posted on Oct 21, 2013

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 4088 Answers

SOURCE: brush spin,good suction at hose, no suction at

Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Posted on Jul 12, 2009

nwj2468
  • 76 Answers

SOURCE: Hoover 6446 900 WindTunnel Bagged Upright has

check for a clog in the brush hose

Posted on Aug 22, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The suction has decreased by about 50%. The brush


Check that there is nothing blocking the hose and that there are no obstructions around any of the filters, clean and replace filters too if possible. If you still find you have less than optimum suction , you may need to replace your motor. But it sounds like there may be a blockage or an air leakage somewhere in the unit.Good luck.

Jun 07, 2010 | Hoover Windtunnel Supreme U5280-900...

1 Answer

While the windtunnel is upright the suction is awesome. When you lower it and engage the brushes is looses suction. It will not pickup anthing on the floor


check the brushroll if it spins freely, replace the belts 38528-034 and 38528-035. and make sure the tensioner for the V belt engages when you release the handle and pull the head back

Dec 30, 2009 | Hoover U8361-900 WindTunnel 2 Bagless...

2 Answers

Hi I have model u64330-900 hoover windtunnel. It


Hello,
It sounds like your vacuums belt is stretched and worn. You'll need to replace it. Below is a link to a website that gives instructions with pictures on how to change the belt. You should be able to get a replacement belt at any department store or vacuum retailer.
I hope this helps you.

http://www.info-vacuum-cleaner.com/hoover-vac-belt.php

Sep 24, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover canister vacuum (windtunnel)- turned it on and it had good suction, then smoke came out and it smells like something is burning. Is it the motor burning up or something else?


Probably the belt..
Turn it over so the bottom is facing up..
Remove the plate that surounds the brush..
Check to se if brush is spinning frely and that the belt is on there poroper

Jul 14, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Brush spin,good suction at hose, no suction at


Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Jul 11, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover Bagless WindTunnel vacuum cleaner.


very easy. you have clog. take the brush off look where the hole is thats where the clog is. it might be in there you might have to take the housing off of the motor

May 08, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Brush roller on windtunnel won't spin


It sounds like you need to replace the actuator arm or the cable to it. Look for Hoover part 43143046 for a start. I've got a similar problem.

Mar 21, 2009 | Vacuums

1 Answer

Hoover WIndtunner 7600 no suction


According to the manual on your machine, you can either have a broken belt, or the switches to the self-propel switch, and brush switch are in the off position. I have included a link to your manual. Please look at pages 13-14 under troubleshooting.

http://www.hoover.com/pdfs/manuals/U6439900.pdf

I hope this helps.

Jan 18, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

91 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18408 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1467 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...