Question about Akai MPC-4000 Plus Production Center (w/80 GB Hard Drive&Onboard Sounds)

2 Answers

Mpc 2000 The screen on my MPC 2000 has gone blank. what can I do to fix this.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers
Re: mpc 2000

Check the contrast knob poor construction can cause the traces on the PCB to break that's what happened to mine! Re soldered and go!!

Posted on Sep 05, 2012

Re: mpc 2000

The screen has probly burned out.. u need to get it replaced

Posted on Oct 14, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

A line in my akai mpc 2000 how to fix it

Do you mean a line in the LCD screen?

If so..

I don't think there's a way to fix it.

A company other than AKAI started selling AFTERMARKET screens.
They were so popular, that they SOLD OUT. I think they're currently in re-production.

Screens on ebay are around $250.00

MPC2000's on ebay are around $300.00

You might get a deal If you can find a broken MPC with a good screen.

Good luck.

Jun 01, 2014 | Audio Cards

1 Answer

When I try to load a program on the mpc 4000, the program won't show up on the main screen seq window. What's could be wrong? Thanks Dame

I have same problem, havent figure iyt out yet since 2month ago when i got my mpc4000. Can anybody help please mail Cheers /Martin in Sweden

Sep 18, 2010 | Akai MPC-4000 Plus Production Center (w/80...

1 Answer

I insert my falsh drive into my mpc 1000 and i

First you must configure your PC to read your mpc 100
flush card. Just insert the software CD driver of your mpc
100 flush card, if you have the CD. Otherwise, you must
have a download from the internet for the software driver.

Nov 08, 2009 | Akai MPC-4000 Plus Production Center (w/80...

1 Answer

Trouble with hooking mpc4k and korg triton pro to mbox

you will want your triton midi-in to go to your mpc midi-outB

then your mpc midi-inA to go to your mbox
your mpc midi-outA to go to your mbox

that should get you good for midi cables....

on the mpc, everytime you want to record a track using instruments from your mpc you will need to set a new track. on the main screen you would go to a new track (where Tr:01-Track-01 is) and change S:DRUM1 to S:MIDI, then to the right of that where it says OFF, turn that to 1A-Device01 ... you will have to make a new track for each instrument you use to help when bouncing tracks to mbox. for instance 1A-Device01 is the 1st track on your triton, 2A-Device02 is your second track and so on. make sure you also make a new track each time for where Tr:01-Track-01 is also for each instrument.

for the mbox i might be a little rusty on this so im going to post a quote from another site....

"in Pro Tools, go to setup - midi - midi studio. this is where you tell pro tools where your midi devices are connected. next, go to setup - midi - midi beat clock. you want to 'enable midi beat clock' and select the devices that are going to be receiving midi beat clock. all devices that you setup under midi studio should be showing. next, set pro tools' tempo for the session if you haven't already. This setup is based on Pro Tools being the MASTER device and the other device(s) SLAVE(S). Make sure that on your hardware/midi interface that the midi output is going to the midi input on the slave devices. On the mpc, press mode, then pad 9 and go to the sync tab. Choose "slave" under "sync in" and the port, 1 or 2, that your mpc will receive midi input. That's it!! When you start Pro Tools' sequencer, the mpc should start too at the same bar/beat location. I've tried slaving Pro Tools to the MPC1000 and Fantom Xa on diff. occasions but I could never get them in sync with Pro Tools. Tried diff. framerates and settings, but still, no luck. So I prefer using Pro Tools as the MASTER sending midi beat clock. Another thing, make sure that whatever you're tracking into Pro Tools doesn't change tempo during the song. If so, you'll have to edit tempo events in the tempo ruler. Hope this helps!!"

let me know if you need any more help.

Feb 16, 2009 | Akai MPC-4000 Plus Production Center (w/80...

1 Answer

Is there any way to get back factory settings

It sounds like you may have a virus! They sometimes wipe out the startup process of the computers operating process

Nov 20, 2008 | Akai MPC-4000 Plus Production Center (w/80...

2 Answers

Akai mpc 4000

Dear fixya thank you for replaying to my e-mail about my mpc 4000 problem, and yes after pulling my hair out and further investigation i did fix the problem. i had no audio comming from one of the main outputs and all i did was change that one faulty audio cable and everything was all good. I took the no good cable, tied it in to a knot and dumped it right into the trash can. Now im back to master beatz...

Feb 16, 2008 | Akai MPC-4000 Plus Production Center (w/80...

2 Answers

Mpc 4000 lcd

Hey, it sounds like the LCD is not receiving any signal from the video output. I would take it somewhere to be opened up for a closer inspection. Again the cause could be something more serious on the internal circuitry. No way of telling till the schemata is tested.

Good luck

Jan 24, 2008 | Akai MPC-4000 Plus Production Center (w/80...

1 Answer

Loading Sounds

I've answered this question twice with no love..........

Oct 31, 2007 | Akai MPC-4000 Plus Production Center (w/80...

Not finding what you are looking for?
Audio Cards Logo

Related Topics:

567 people viewed this question

Ask a Question

Usually answered in minutes!

Top Akai Audio Cards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers


Level 3 Expert

56797 Answers

Mils Bautista
Mils Bautista

Level 1 Expert

49 Answers

Are you an Akai Audio Card Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides