Question about Cadence TXA 1000D High Power Mono Amplifier Car Audio Amplifier

1 Answer

No power showing on my xa124 cadence amplifier was working great for the last year and then it kept shutting dow a few times now it wont come back on have power there cause the cadence sign lites up any ideas

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 117 Answers

You blew it. replace it or sell it for parts.

Posted on Nov 15, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

JL audio amp wont come on


What happened right before it stopped working?

Feb 19, 2014 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

It just stopped working after about 4 years. the amp went in and out a couple of times then it just stopped working.


ok what type of amp are we talking about, what impedence and voice coils are your subs, and have you checked power, ground, fuses, etc... a quality amplifier kicker, jl, mtx, rockford... etc... should, if set up and wired properly, last you a very long time... I actually had a kicker amp since 96 and it still worked great to the day i gave it to my buddy... That's 11 years old with no issues...

Dec 12, 2009 | Jl Audio 300/4 Car Audio Amplifier

1 Answer

The base in my car kept on goin high and low for like 2 weeks and after that it worked good for 2 days and then the amp shuts off it wont come back on anyone can help me please


loose cable, bad amp, who knows what it could be, its time for you to find out if it is a simple problem, check the wiring, fuse, and anytning else that seems pissible

Jun 14, 2009 | Kenwood KAC-X520 Car Audio Amplifier

2 Answers

Blodgett 961-P pizza oven


Go here find what you seek.
BLODGETT
44 Lakeside Avenue, Burlington, VT USA 05401
Toll Free: (800) 331-5842 Phone: (802) 860-3700 Fax: (802) 864-0183
Great Co.

Sep 30, 2008 | Blodgett 911-DOUBLE Gas Oven

1 Answer

Dsp a1000 shutting off


it's not actually a problem my friend. it could be a problem with the output circuitry and your protection mode is activated. there ar ecases that systems shuts off with no appraent reason and those are isolated cases. If that were so on your units, the problem lies in the systems board (CPU) a defect in the backup power supply. also grounding problem of capacitor leaks. if there is no trouble in the power amp section and works well suddenly trips, some modifications can be done. i dont know if that can be solved by your technical experts on how to modify the protection circuit. the principle on protection circuits of yamaha is just one and same. but newer models has got better but sensitive designs. 2095 is about 3years younger than a1000. 2095 is almost all digital when a1000 uses mechanical switches.

Apr 26, 2008 | Yamaha DSP-A1000 5-Channel Amplifier

1 Answer

Hitachi 51F500 Shuts down during summer months


I am finding out that these sets have almost the same problems mostly going back to middle power supply broad ck all connections,then try looking for leaky caps.

Nov 08, 2007 | Hitachi 51F500 51" Rear Projection...

1 Answer

Amp shuts off


check your remote wire and check your power and ground, clean all connections with a contact cleaner/rejuvinator (ridox/deoxit).. many times the thin remote wire will develop breaks or conductivity issues over time, i have replaced many of these just in the last few months.

to make sure this is the problem, remove the remote wire and temporarily jump the power wire to power and remote, the amp will always be on at this point, but it should help you diagnose whether the remote wire is the problem or if it is an amp or cabling issue.

hope this helps,
trin

Nov 07, 2007 | Kenwood KAC-X520 Car Audio Amplifier

1 Answer

Porta wattz 1750 inverter


turn the unit off and then disconnect the negative from the back and turn th unit back on that way the inverter will use all the charge kept inside.
Reconnect the negative and start the unit ...I did that to my unit and for fun I asked tech support for help they told me that I need to buy ne one...After I reset my unit I been using now since for over 2 years...sometime it come back one every few months if I have high voltage coming and I redo this again and it works...save your money

Oct 31, 2007 | Statpower PW-1750 Triple Outlet 1750 Watt...

Not finding what you are looking for?
Cadence TXA 1000D High Power Mono Amplifier Car Audio Amplifier Logo

Related Topics:

46 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadence Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Cadence Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...