Question about Electrolux Guardian Bagged Canister Vacuum

2 Answers

I have a Renassiance C104A and once you plug it into the wall socket, it starts to run and no lights are on the handle....I've replaced the circuit board in the handle and the triac inside the machine....does anyone know what it could be or how to fix it?

Posted by on

  • fggmplus Oct 17, 2013


    Some how the wiring on the reel was crossed; The continuity was checked from the plug to each connection and the problem resolved.

  • fggmplus Oct 18, 2013

    circuit was reported as newly installed....please read my eventual solution

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 161 Answers

Is there possibly a bulb burned out for the light in the handle?

Posted on Oct 17, 2013

Testimonial: "circuit was reported as newly installed....please read my eventual solution"

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Greenhorn:

    A rookie expert who has answered 20 questions on their first day.

  • Expert
  • 225 Answers

There are a lot of things that could cause this problem because the wire runs through the hose. There is a connection on both ends you should check to make sure they are clean.

With the machine running try to "wiggle" the hose connections to see if the head gets power intermittently

Posted on Oct 16, 2013

Testimonial: "circuit was reported as newly installed....please read my eventual solution"

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: Electrolux canister C104A: Unit shuts itself off

I have a similiar problem, but LED light does not flash. I have determined it is a short in the hose wire. THERE ARE NO REPLACEMENT PARTS FOR THIS MODEL OF ELECTROLUX. I'll never buy another Electrolux product.

Posted on Dec 24, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My cord has to be pushed in to socket and giggled to get the vacuum to have power? Any suggestions?


You might want to remove the electric plug from the wall and spread the prongs just a little bit, it sounds like the plug might be loose in the wall socket.....try it in another wall socket and see if the problem continues to exist...generally it you get the same result from similar wall sockets...you may have looseness in the electrical plug...meaning that you might have been unplugging the cord by grabbing the cord and snatching versus unplugging with the plug itself. Hope this helps.

Sep 25, 2013 | Electrolux Guardian Bagged Canister Vacuum

1 Answer

Hello, I awoke this morning to a room full of acrid smell. The timer controlling an electric radiator was extremely hot,and was also heating up the wall socket. The heat has distorted the plastic case...


I am sorry that no one picked up on this sooner-
I came across it, after reading a response from one of th persons I helped--

Good Question: Who to alert?
By now you have probably called an electrician?-- Or at least stopped using both the receptacle, as well as the heater?- right?

Now-- to fix the problem:
It sounds like some poor connections at both the wall plug/socket end, as well as inside the heater-

First the wall socket:
Is the plug nice and tight, as you plug it in, and as you pull it out?-- If not-- the socket needs to be replaced--
Is the plug end of the cord hot in one spot, but not others?-- If so, there are some broken wires right near the plug end of the wire--- It needs to be replaced, too.
Now-- Inside the heater-- you mention the Thermostat area is real hot-- It sounds like either a loose wire, or a worn set of contacts on the thermostat.. (How old is the unit?)

So-- if you can narrow down the places, and repair-replace defective parts, maybe you can restore the heater to a safe, dependable source of heat-- If not-- It sounds like a recyclers needs to take over, and safely return parts to the environment!

Let us know how it all turned out, OK?

Mack B

Jan 26, 2011 | Vacuums

1 Answer

Electrolux canister C104A: Unit shuts itself off and LED in handle next to OFF button flashes.


I have a similiar problem, but LED light does not flash. I have determined it is a short in the hose wire. THERE ARE NO REPLACEMENT PARTS FOR THIS MODEL OF ELECTROLUX. I'll never buy another Electrolux product.

Oct 31, 2010 | Electrolux Guardian Bagged Canister Vacuum

1 Answer

Switches will not turn off unit. model #cv450w


If the switches on the hose will not turn off the vac you have a short in the wiring of the vac pipe system or a defective relay on the circuit board. Plug the vac in again without the hose and disconnect the thin low voltage wiring were it plugs into or screws onto the vac.
If the vac continues to run once disconnected from the low voltage circuit you have a defective relay in the vac itself. Some are circuit board mounted , others freestanding. To avoid a service call you can take the tank off the wall and take it to a pro shop or remove the top hosing if you are confident and check out the relay for a replacement part.
If the vac stops your issue is in the house. Has any painting been done or any inlets removed lately.. check that area first for a short at the inlet. Go back to any and all inlets and remove them one at a time checking the mounting screws and backing plates for loose wiring which is touching either the metal inner wall plate in the wall or a common screw . Test the vac as you go.
If this does not help, you will need to examine the wiring in the house , running along the pipe. Again if anything has been disturbed recently, near the vac, or near any piping that would be your first suspect area.
Post back to advise.

Oct 18, 2009 | Broan-NuTone CV350 Central Vacuum

1 Answer

Electrolux C104A does not turn on. won't start. No light on, no sound. Is there any fuse to be raplace and/or ?


The Renny is a hard machine to diagnose. You could have a broken wire in the cord or in the hose. There is a fuse wire located inside the canister that could be bad.Also, the handle circuit board2.gif could be bad or the triac (another circuit board) located inside the canister could be bad. There is no use for you to open the machine. You could do more damage than good.

Jul 06, 2009 | Electrolux Guardian Bagged Canister Vacuum

3 Answers

Renaissance C104A does not turn on. I plugged it in and it does not work.


The Renny is a hard machine to diagnose. You could have a broken wire in the cord or in the hose. There is a fuse wire located inside the canister that could be bad.Also, the handle circuit board could be bad or the triac (another circuit board) located inside the canister could be bad. There is no use for you to open the machine. You could do more damage than good.

Jul 06, 2009 | Electrolux Guardian Bagged Canister Vacuum

1 Answer

I have a Hayden SuperVac 3600, almost 10 years old. The unit still runs, but now when I switch to the power nozzle, it doesn't have power to turn that. I think this happened once before and maybe they...


The hose has fuseable link inside, generally a 3-7 amp. It is at the wall end underneath the hose cuff. Easy to replace as it crimps in line. If you have a meter you can also test the detachable hose to wall cord for continuity, then check the hose to handle as well.
You can also detach the hose to wall cord from the hose, and plug your power head directly into that cord,, then into the wall thereby eliminating the hose itself.
Hayden makes a serviceable hose. If damaged or the fuse blown it can be serviced by a good tech. If the fuse is blown you need to clean and inspect the power head as this may be the cause

Jun 20, 2009 | Hayden Industries SuperVac 6000 Central...

1 Answer

NuTone CV353 Central Vac does not start when hose is plugged into


Try to plug the hose in sideways. So the top of the hose is rotated 90 degrees. If the unit turns on then there is something wrong with the hose. It might be a short or it could be a bad switch on the handle. If the unit still wont turn on I would think that maybe the low voltage wire got disconnected from the unit or there is a break in the low voltage wire somewhere along the way. Let me know if you plugging the hose in sideways works.

Feb 22, 2009 | Broan-NuTone CV353 Central Vacuum

1 Answer

Model 116.1260


Need the complete model #, 116.1260*****. I assume this is a built-in system? Yes you have to plug the hose into the wall outlet, and there usually is a switch on the hose handle to turn it on.

Jul 23, 2008 | Vacuums

Not finding what you are looking for?
Electrolux Guardian Bagged Canister Vacuum Logo

82 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18390 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...