Question about Fahrenheat FFH1615 Heater

Open Question

I have an edenpure gen 3 model. When you plug it in it does NOTHING! No beeps like it used to do and no lights come on the front panel. Any suggestions what the problem could be, Someone told me it could be the control circuit board. I don't want to buy a replacement board until I determine if in fact that is the problem. is there a way to test it? Any help would be GREATLY appreciated! Thanks

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Eden pure model Gen 3 doesn't turn on ? The red light on front is lite and filter is clean Why not


Edenpure has a troubleshooting guide at this website: MY HEATER WILL NOT TURN ON.
  • Make sure the power source is good. Plug in a lamp to see if it works correctly.
  • Make sure the front power switch/button is set to the "ON" position.
  • Unplug the power for 30 minutes. Plug the power back in and try operating the heater again. This will reset the internal sensors.
  • Some heater models are designed to be operated in temperatures less than 75 degrees Fahrenheit. The heater will not operate when the temperature is too high. Test the heater in a room that is below 75 degrees Fahrenheit.
  • Bring the heater inside to warm up for at least one hour before operating if it has been stored in a freezing or near freezing environment.
  • Make sure the filter is clean.
  • Remember, it will take a few minutes for the heater to warm up. The fan will start to blow after the heater has warmed up.
Heaters FAQ

Dec 07, 2016 | Air Purifiers

Tip

How to fix your PS3 when it's frozen at startup


1.The first thing your going to want to know is your model number. It can be found on the back panel of the PS3 on the serial number label, and it will begin with CECH. Example - Serial: XXXXXXXXXXXX-CECHXXX -


2.Put your PS3 in Standby Mode.
For models: CECHA01, BO1, E01, E01MG, G01, H01, H01MG, K01, LO1, AND P01, it will have a power switch on the back. Flip it off then back on and you will have a solid red indicator light on the front.

For models: CECH-2001A and 2001B, press the power button on the front until the indicator light turns red. If all else fails unplug the power cord and plug it back in.

3.Time to enter Safe Mode.Press and hold your finger over the power button on the front until you hear three beeps and the indicator light goes back to red. Then release the button. (The second you touch it you will hear a beep, that's the first beep. Five seconds later a second beep, another five seconds the third and final beep will sound then the indicator light will return to red.)

4.Press and hold your finger over the power button again until you hear a quick double beep. The release the button. (The second you touch it you will hear a beep, that's the first beep. Five seconds later a second beep, another five seconds you will hear the double beep.)

5.Connect the USB cable to the USB port on the front of your PS3 and the top of your game controller, (between the left and right bumpers). Then Press the PS button in the center of the controller.

6.Select option number 3, (Restore File System). Then select yes to perform step.

7.You will then see this screen. "The hard disk's file system is corrupt and will be restored."

8.First press the PS button to turn the controller back on. Then press the x button and it will restore, it will then restart and your problem is fixed!

on Apr 02, 2010 | Video Game Consoles & Games

1 Answer

Hello just been given a ps3 you plug it in turn it on and nothing comes up on telle you take the lead out the tele and it says power supply lost plug it back in but still nothing. also it wont turn off on...


u could try resetting ur ps3 by holding down the power button on the front panel for 5seconds/u should hear one beep then a second beep/ps3 should revert back to normal av output.

Oct 14, 2013 | Sony Playstation 3 (PS3) Console

1 Answer

I have an eden pure gen 3 model that was purchased in Nov. of "09". I thought it had a 5 year warranty but to my surprise it is only 3 so now it's out of warranty and no one will help me. I was given a...


Did you check the fuse ? If that is ok then normally what goes first is a standby transformer on the front board itself. There is thermal fuse located inside the transformer that goes open circuit. A fairly easy and quick fix.

Oct 14, 2013 | Microwave Ovens

1 Answer

Eden pure beeps 3 times, and then it will not work


Sometimes things can get out of sync. Try unplugging the machine for a few hours to rest the code on the board.

Oct 09, 2013 | EDENPURE USA1000 Infrared Heater

1 Answer

Edenpure xl1000 parts


Replacement bulbs can be gotten from edenpure parts or check EBay for a supplier. Some will ship them no charge. To change them. Remove rear cover, then the cover on the rear of the heater box by 2 screws on the bottom and 1 at the top inside of a "U" Channel. Then lift the rear box cover up off the hanger hooks then back and out. The bulbs will be right in front of you in the 3 holes.

Jan 25, 2013 | EDENPURE USA 1000 Black Portable Heater -...

2 Answers

Need repair manual for eden pure heaters


The Edenpure Gen4 and US-1000 have a set of 3 - 500 watt bulbs that generate the heat. You'll likely need to buy a new set of bulbs every heating season ($60) or pay an Edenpure service center $100-140 to replace them for you. (Almost imossible to get SCI to cover the the bulbs under their so-called warranty)

Unfortunately, despite the hype printed on the box and Suarez Corporation Industries advertising, those bulbs last less than 500 hours of operation in those heaters. Suarez Manufacturing Industries/Pinnacle Systems have no engineering staff nor did they perform any durability testing on the heaters or any heater components.

Thus you, as the consumer, are stuck with continually the bulbs (in the US-1000 and Gen4 at least).

Apr 01, 2012 | Heating & Cooling

1 Answer

My DELL XPS dimension Gen 4 wont boot up. The amber light is steady and no diagnostic lights are lit on the back. The processor fan is going at maximum speed. Before this problem I could not plug in a...


The indications are of a NO POST. This can be caused by:
  1. Failed motherboard
  2. Failed Front IO Panel
  3. Damaged IO Panel Cable
If issues connecting USB connections occurred via the front connection, I'd suspect the IO panel as the issue. If the IO panel doesn't resolve, then motherboard is likely failure point.

Jun 27, 2011 | Dell Dimension XPS Gen 4 PC Desktop

Not finding what you are looking for?
Fahrenheat FFH1615 Heater Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fahrenheat Heating & Cooling Experts

butch welch

Level 2 Expert

147 Answers

paulcarew

Level 3 Expert

2460 Answers

Brad Brown

Level 3 Expert

15557 Answers

Are you a Fahrenheat Heating and Cooling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...