Question about Radio Communications

1 Answer

I have two LXT305(s) and they are about three years old. I ONLY use them during hunting season and when NOT in use the batteries are removed and the units are stored in my gun safe (DRY). One of the units is "hissing" with the RX display flashing on and off (mostly on) no matter what chanel it's on...or power. I put new batteries in it..and have tried EVERYTHING to get it to stop!!!!!!!!

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 97 Answers

The units receiver is "opening" this is either caused by a strong signal nearby or the receiver is failing (many of these radios suffer from bad capacitors) However you might get it to stop by setting a privacy code to "close" the receiver check the documentation to try setting a code this might get you by.

Posted on Oct 17, 2013

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: very bad hiss even when power is turned off and battery is removed

Hey I found The Problem .. The Phantom Power was switched to ON .. on the front of the Z1 Under the Lens.".. A big no no."
When I switched the Phantom Power off.. All clear again !!

Posted on Mar 11, 2008

eradiostore
  • 1654 Answers

SOURCE: I ptt and it immediatley 'roger beeps'

Beeping when you press the PTT button usually indicates a bad or weak battery. Check your batteries and charger. Clean contacts with a pencil eraser.

If you feel this is not the problem, then you have a radio problem. These radios are non-repairable, as parts and schematics were never released for them.

Best regards.

Posted on Dec 13, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Power cuts when i turn key


If you mean everything goes out when you turn the key to the START position, understand this:

* Accessories will turn off during START to remove excess load on battery

* A weak battery will draw down and cause this symptom - the two most likely times of year are when it first gets really warn outside (batteries hate heat) and when it gets really cold outside (Natteries hate cold).

* A defective starter can draw excessive current and cause this symptom.

If your battery is more than three years old, I would suspect it first..

Nov 10, 2013 | Mazda RX-8 Cars & Trucks

1 Answer

Can I use electronic calls and electronic decoys to hunt game species during open seasons?


It is illegal to hunt waterfowl, wild turkeys or deer with electronic or battery powered decoys. It is illegal to use electronic or battery powered calls for waterfowl, wild turkey or deer. Restrictions do not currently exist for other game species.

Jan 17, 2013 | Hunting

1 Answer

I ptt and it immediatley 'roger beeps'


Beeping when you press the PTT button usually indicates a bad or weak battery. Check your batteries and charger. Clean contacts with a pencil eraser.

If you feel this is not the problem, then you have a radio problem. These radios are non-repairable, as parts and schematics were never released for them.

Best regards.

Dec 12, 2012 | Motorola Talkabout® T9500 Two Way Radio

1 Answer

Motorola T6510 runs down battery quickly


these are one-way radios. no service, no spareparts. just trough away and buy new

Sep 04, 2012 | Motorola T6510 XLR Talkabout Two-Way...

2 Answers

Cub Cadet LT 1045 - Not starting, the engine does not turn.


remove the starter...use jumper cables to "run the starter manually...red to big lug, black to body (anywhere is fine) should torque hard at initial run and continue to run smooth...if it buzzes or vibrates, it's bad...replace...

Apr 10, 2010 | Cub Cadet Street Sign- tractor lawn riding...

1 Answer

2002 Big Bear 400. Dies after a few seconds upon startup


sounds to me the valves are not properly adjusted,..like their to tight,...i had run into this in a japanese car once,...check it out and let me know,.....cracklin joe

Jan 10, 2010 | 2002 Yamaha SR 400

1 Answer

Have a hoveround and it is three years old used one fall season and has been stored in a garage but won't start now


If you stored it for a long period of time (three weeks or more) the batteries have worn down and need to be replaced. These type of batteries must be charged at least once a week to maintian life in them.

Nov 14, 2009 | NRS Hoveround MPV 4 - Hovaround Used...

1 Answer

Batteries discharge quickly even if the camera isn't being used. I have three batteries and two are over one year old.


Hi

It is recommended that if batteries are not going to be used for long periods they should be removed from the camera altogether during that time.

If you are referring to rechargeables the ability to retain charge is effected both by the age of the battery and the number of times it has been recharged.

Canon cameras are generally one of the better cameras in terms of being economic on power. It is likely that this problem is battery related and not camera related.

As it is also important not to mix old and new batteries together - I would recommend that you purchase new rechargeables. Three new rechargeables batteries in your Canon should resolve your problem and give the best results.

Thanks for using FixYa.

Oct 02, 2009 | Canon Powershot SD450 / IXUS 55 Digital...

1 Answer

My etrex legend is also inoperative...


Inoperative as it won't turn on, or is there a line through the screen, or it won't recognize satellites?? We need a bit more information about 'inoperative'.
Have you downloaded and installed the latest software from the Garmin site? That might be a start.

Oct 25, 2008 | Garmin eTrex Legend GPS Receiver

1 Answer

T5000 have a lot of static!


I think if you can´t undestand what the other person is sayin, and you think is working fine, the problem could be at the speaker, check if the speaker is clear of dirty or sand or any thing that has not to be there. If you find any dirty or sand on you speaker, try to clean with a brush and giving some little knocks with a piece of steel Good luck

Nov 13, 2006 | Motorola TalkAbout T5000 2-Way Radio

Not finding what you are looking for?
Radio Communications Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top Radio Communications Experts

eradiostore
eradiostore

Level 3 Expert

1654 Answers

Brad Brown

Level 3 Expert

16010 Answers

Mike Charette

Level 3 Expert

1795 Answers

Are you a Radio Communication Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...