Question about Invacare Panther LX-4 Batteries

1 Answer

Panther lx4 runs irregularly .batteries are brand new. ride well for 10 minutes after it starts to slow down then accelerate then slow down etc...

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 118 Answers

Most scooters have only a rheostat to control speed. Over time, the carbon will wear and cause erratic control.

Posted on Oct 16, 2013

  • Charity Johnston
    Charity Johnston Apr 03, 2014

    Is there a way to fix?

  • Dan Hudson Apr 03, 2014

    Only fix is to replace it. Either buy the part from a Pride dealer, or buy the Pot off ebay.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Quits accelerating after 45-55 mph


It might be a blown head gasket!

May 16, 2013 | 2004 Pontiac Aztek

3 Answers

The car will run fine for about 10 minutes then it will stop accelerating???


ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Nov 28, 2012 | 1999 Mercury Cougar

1 Answer

1980 Honda GL 400 quits running while riding


Hi, Joe and the usual suspects are:
1. Severely discharged or a damaged battery should have 12.5 volts or more and be able to pass a proper "LOAD" test if necessary, you may have a preliminary reading of 12.5 volts or more but little or zero amperage the battery is faulty and must be replaced, AGM batteries fail in this scenario more so than lead-acid batteries.
2. Failed alternator/generator and or voltage regulator.
3. Loose or corroded battery terminals and or cables especially the "NEGATIVE" cable, look for loose, corroded, or broken connectors inside the cable harness at "BOTH" ends.
4. Failed main circuit breaker or ignition switch, check for loose connections and continuity.
5. Failed system and or ignition relay, check for continuity.
6. Failed ignition coil, stator, magneto, ignition/electronic module.
7. Failed CKP, CPS, CMP, MAP, TPS, or BAS sensor, corroded, loose or broken wire connector pins/sockets.
8. Throttle cables and or idle speed improperly adjusted hot idle speed should be 950 RPM to 1000 RPM.
9. Faulty neutral, side stand or clutch lever safety switch.
10. Faulty or corroded kill switch.
11. Accelerator pump damaged or not working.
12. Water or dirt in the fuel system, carburetor or filter.
13. Restricted, blocked or kinked fuel line.
14. Fuel tank empty.
15. The gas cap is not venting properly or fuel tank venting system blocked, loosen gas cap and go for a test ride.
16. A failed fuel pump, pressure regulator and or fuel injectors.
17. Vacuum line from intake manifold to petcock broken, cracked, or not attached, carburetor vent line plugged.
18. Needle and seat stuck closed in the float bowl.
19. Petcock clogged or damaged.
20. Lean angle switch is faulty or needs adjustment.
21. Catastrophic engine failure, perform a compression test.
For more information about your issue and valuable "FREE" downloads that you will need for viewing or printing please click on the blue links below. Good luck and have a wonderful day.
1980 CB750 engine dies after riding 10 15 minutes
engine cut out while riding
Honda CB400T Shop Manual
https://www.partsfish.com/page/oem-parts-for-honda
cm400t Owners Handbook pdf

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/gregg_c0ec1df182c7330e

May 02, 2012 | 1980 Honda GL 400

1 Answer

Panther lx4


Check fuse in controller. Check connectors, check the charger to make sure it is putting out 26 to 29 volts. If not check the fuse in the charger. Are the batteries any good? Is the parking brake stuck? Have someone try push the chair backwards initially, then try forward. There may also be inline fuses to the motors, those shoudl be checked for continuity.

If still nothing, try a swapping the controller with a known good one.

Jan 28, 2012 | Invacare Health & Beauty

1 Answer

2001 toyota sienna ce, runs good at idle, takes long time to get up to speed (1 mile to get to 40mph), when at 50 and going up bridge, it will slow down 10-15 mph. if accelerated quickly then it will seem...


I would change the transmission filter.if clogged it will slip and loose power on steep upgrades try that it is inexpensive. If that don't help you may need a new transmission.

Sep 13, 2010 | 2001 Toyota Sienna

2 Answers

P1000 problem loss of power after 10 minutes


P1000 is not really a fault code, if there are no there are no other codes stored then perform the following:

Disconnect the positive terminal on the battery, hold the terminal to the chassis for 2 - 3 seconds, this defuses the ecu and drains stored data thus clearing P1000.

Now wait 10 minutes.

Then reconnect battery.

Start car *without touching gas pedal*

Leave car idling for a good 5 - 10 minutes then jump in and go on a minimum 12 mile drive, you will need to perform a few normal driving conditions, fast, slow, stop, pull away etc so just a normal day to day trip to the town would suffice.

Hopefully this will sort it, if not report back

Regards

Lloyd


Aug 20, 2010 | 2002 Jaguar X-Type

2 Answers

Have an invacare patriot LX4. Unit takes full


Check to see if the scooter is in freewheel mode. To know if the batteries are bad you need to charge them for 10 - 12 hours and then have them tested with a load tester.

Jul 28, 2009 | Invacare Supply Group Invacare Scooter...

1 Answer

Speedo will cut out when driving


Sounds like your "speed sensor" is failing. When it fails it will cause irregular shift patterns and engine idle speeds.

Jun 10, 2009 | 2000 Ford Focus

Not finding what you are looking for?
Invacare Panther LX-4 Batteries Logo

281 people viewed this question

Ask a Question

Usually answered in minutes!

Top Invacare Health & Beauty Experts

wcdoc1953
wcdoc1953

Level 2 Expert

280 Answers

Colin Taylor

Level 2 Expert

347 Answers

gnshome

Level 1 Expert

31 Answers

Are you an Invacare Health and Beauty Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...