Question about Kicker SX400.2 Car Audio Amplifier

1 Answer

Will not pick up power

My amp will not turn on. its been working fine and this morning it wouldnt turn on. i dont have a turn on wire connected i have the "audio" power option on. but the red light wont even turn on

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 89 Answers

Check your fuse panel on the car and check the fuses on the amp

Posted on Apr 24, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Turned off this morning then when went back to sew project it wouldnt sew,no funtionality Everything is lit up. Turned off waited a few sec. Turned on. Nothing Is there a reset button?


Difficult to help without knowing the make & model. Try the Troubleshooting section of the owner's manual. Otherwise, try contacting a local dealer or the manufacturer support number.

...

Sep 26, 2016 | Sewing Machines

2 Answers

Hey i dont know to much about amps, but me and my friend (he knows a decent amount about amps) would plug the power into the amp and the green light would come on. Though when we plug it into the subs, the...


Are you connecting positive to positive and negative to negative from the sub to the amp? If so, try positive to positve (+) in the far left channel and then the negative to negative (-) on the far left channel to. If no luck do the same in the other channel with one sub at a time. Try one sub at a time, Dont try an connect 2 or more subs to one channel as this would cause the amp to go into protect mode (red light you describe). Usually the positive wire has either a line down the wire, writting on it or has a red seperate wire with it when wire end stripped to connect it. Hope this helps and please rate...

Mar 11, 2011 | Bazooka EL1500 Car Audio Amplifier

1 Answer

Our truck worked fine then next morning it wouldnt turn over Just click We have replaced the starter. Replaced the park neutral switch. ignition switch and wires test fine. Crank fuse is fine. ...


you have a earth problem/neg on battery check the battery wires i suspect a dirty connection.get that starter checked again and test the most common problem[ THE BATTERY].adrian,,,,

Aug 09, 2010 | 1992 Oldsmobile Bravada

1 Answer

My amp will not power up


try hotting your remote wire to your batter if it don't come on u will need a new amp

Jun 14, 2010 | Diesel Audio NS-1000 Car Audio Amplifier

1 Answer

Why isnt my woofer working?


Ok, that was some important information there. If you were tightening the 12V power line, small sparks are normal. You should also have a thin wire (often blue) going into a 3rd terminal. This is normally called the remote wire. It's the wire that tells the amp to turn on when your radio turns on. Do you have a remote wire connected? When you start your radio or car, does the amp light up? There should be a power indicator light -does it light up? There may also be a fuse on the side of the amp, pull this out and see if it's blown. If not, put it back in.

May 15, 2009 | Car Audio & Video

1 Answer

CD player wont come on was doing weird things


You have your accessory wire (red wire) and remote ran together and the yellow (constant wire ran separately in the dash?

You need the red wire to so you can use accessory and to turn off your cd player when your vehicle turns off.

You need the yellow wire to keep all your settings stored. base/treble/time clock

Just a little clarification. Your amp turns on with the remote wire (blue) wire, if that is not hooked up you will get no power to the amp.

Here's the in-dash diagram to your vehicle at the bottom of this pdf.

http://www.installdr.com/Harnesses/Ford-Wiring.pdf

You want to focus on N,O, and P

Do you happen to have an after market wiring harness? These can be bought from walmart for your vehicle. You just take the male end connect the colors together and plug end that goes to your cd player into the female end. Very easy to do.

Windshield wiper issue: http://www.allfordmustangs.com/forums/attachments/4-6l-tech/32492d1188791176-2003-mustang-fuse-box-diagram-2003-enginefuseblock01.pdf Check C1002, 1003, and 1004 under your hood.

You could also have one of these fuses out under your hood, that might cause you to lose power to everything.

http://www.allfordmustangs.com/forums/attachments/4-6l-tech/32493d1188791176-2003-mustang-fuse-box-diagram-2003-enginefuseblock02.pdf

Let me know if you need more assistance =)

Feb 01, 2009 | Kenwood KDC-MP238 CD Player

2 Answers

Quick question about the power


The remote turn on terminal on the amp needs to be connected to a switched power source. Typically, it's the remote turn-on/power antenna wire on the head unit. If your head unit doesn't have such a control wire, connect the remote turn-on terminal to a wire that's controlled by the ignition switch.

It's VERY important to fuse all of the wires properly. If you're unsure of the proper fuse for a given wire size, read pages 14 and 16 of the Basic Car Audio Electronics site.

Let me know if you have any other questions.

Oct 21, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

My kenwood amp wont turn on


What kind of "Clips" did you put on? They may be causing too much resistance and preventing the amp from getting the current it needs. Double-check with a voltmeter that you are getting at least 12 volts at the amp power connections and make sure your ground lead is as short as possible and connected to solid metal of the vehicle's chassis.

Aug 10, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My speakers dont sound


If you have an amp in your system, I would check the preamp connections, as well as the +12V power, remote, and ground connections to the amp. It's possible the amp is not turning on or the RCA preamp wires got disconnected.

If there is no amp involved, the connector that connects the speaker wires to the head unit may be loose or some sort of "mute" may have been inadvertently enabled.

Mar 26, 2008 | Car Audio & Video

Not finding what you are looking for?
Kicker SX400.2 Car Audio Amplifier Logo

Related Topics:

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

76673 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...