Question about Balboa Instruments Duplex Digital Panel 2 Pump

Open Question

I just installed a new balboa 500z controller every thing works but the heater it comes on and then shuts off and I have got three codes LF,DR, and HL I tested the heater when it comes on I have 230 vol and then I hear a second relay and power kicks off and thats when the codes come up cic pump has got good flow tried taking the filter out tested all volts every thing tested ok all air is out of loop

Posted by Anonymous on

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: I have the Balboa 500Z pump heater kit. Its hooked

I have a 6 month old Balboa 500Z. I have noticed that the filter system tis running all the time 24/7. I have reset the filter cycle to run for 2 hours { F2 }. It still is running all the time. It dose not seem to make a difference what I set the cycle for it just keeps running

Posted on Jul 19, 2011

SOURCE: I have just refilled by

Priming can be done many different ways depending on thetubs design. Some tub manufactures provide bleed valves located on the plumbingjust beyond the pump and heater unions. Some pumps have a bleed valve locatedon the pump. If there are no bleed valves then you will have to release theunion nuts to allow the air to escape.
You can find answers to common spa or bath problems online at http://www.balboadirect.com/support.aspx
Hope that helps.

Posted on Sep 12, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Spa has a Balboa 500z Top side and control panel. It was running at 104 degrees and then one day it just shut down. The Circ pump won't start up at all and when I first turn on the power, I hear the...


Turn breaker power off. Verify now power to unit with volt meter. Most systems have in line over temp over current to protect circuit board and motor. Also the water level switch must be made to complete interlock condition. Check the heater coil for continuityas it may have opened. Check heater for continuity to each coil set. There is an interlock that is for diagnostics on start up that will prevent unit from starting. Look for any melted wires or components too. Always know and verify breaker settings. Verify your meter with known voltage reading first. Be safe my friend.

Jun 04, 2017 | Balboa Instruments Pool & Spa

1 Answer

No temperature display cant set temperature


Located behind the access panel there is a grey box that is the spa pack. Open that up with the 2 screws on the top of the pack. There is a small glass fuse on the circuit board. One of those fuses is most likely blown. If that is not the culprit you need a new topside control. More than likely it's the fuse.

Mar 04, 2013 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

Spa heateer run by Balboa 500Z control box. Standard mode will not shut off. Lowering temp to 88 still gets temp up to104.what is problem?


Sounds like the temp probe is not working or is disconnected. Temp going high, motor running means that it is calling for more heat which brings both the heater and the pump on until after set temp is reached. Once reached, heater will turn off and a few seconds later the pump will shut down.

Check connections for the temp probe. If connected make sure probe is where it should be. If it is, might try to replace it before considering the control board.

Aug 25, 2012 | Garden

1 Answer

I have a Balboa VS500Z . The circuit board burned up where the heater buses are located . I replaced the board and the heater . Know when I start the Spa it primes at low speed for about a minute . Then...


Hi,

DR code - Inadequate water detected in heater.
HL code - Hi Limit, Spa over heat. In your case the Hi Limit is preventing the element from burning out.

This means there is no water or not enough water flowing through the heater.
Common causes:
Hi Limit sensor failure.
Blocked suction, skimmer.
Are the gate valves all the way open/up?
Pump is not functioning correctly, impeller/wet end failure.
These are the most common, but there are also other causes.

I hope that helps

Feb 20, 2012 | Garden

1 Answer

I have just refilled by hot tub with a balboa 500z pump. After refilling it the pump is working fine but the jets are not. The dr light has come up. Please can someone help me bleed the pump to get it...


Priming can be done many different ways depending on thetubs design. Some tub manufactures provide bleed valves located on the plumbingjust beyond the pump and heater unions. Some pumps have a bleed valve locatedon the pump. If there are no bleed valves then you will have to release theunion nuts to allow the air to escape.
You can find answers to common spa or bath problems online at http://www.balboadirect.com/support.aspx
Hope that helps.

Jun 12, 2011 | Balboa Instruments Duplex Digital Panel 2...

3 Answers

Balboa vs500/501/502 gs500/501/502 I just refilled spa yesterday and now I'm getting error codes HL and dr both indicate low flow issues, The water level was re-filled to where it's always been. Any help...


A lot of times you can get an air lock as the spa fills. All you need to do to fix this is open the drain valve for a few seconds till it runs just water and no air. Or start the pump wile the drain is open. This should fix your problem. Good luck.

Sep 04, 2010 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

I have the Balboa 500Z pump heater kit. Its hooked direct to a mighty iron ( 120v) recirclulating pump. Ever since it was new, I keep getting lack of water vflow errors ( dr, then dy ) I have plenty of...


I have a 6 month old Balboa 500Z. I have noticed that the filter system tis running all the time 24/7. I have reset the filter cycle to run for 2 hours { F2 }. It still is running all the time. It dose not seem to make a difference what I set the cycle for it just keeps running

Dec 06, 2009 | Balboa Instruments Duplex Digital Panel 2...

Not finding what you are looking for?
Balboa Instruments Duplex Digital Panel 2 Pump Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Balboa Instruments Garden Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Paul Stonecypher
Paul Stonecypher

Level 1 Expert

28 Answers

Mister Danger

Level 3 Expert

5631 Answers

Are you a Balboa Instruments Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...