Question about Vacuums

1 Answer

My castex scx 400 sprays water all the time when machine is turned on. the brush starts moving when trigger is pulled and water continues to spray. can anyone tell me what wires are not connected correctly. the reason I did undo wires was to get pump checked.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Vacuums Expert
  • 346 Answers

Take it to a qualified vacuum repair shop. Don't risk burning your house down

Posted on Oct 21, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 2 Answers

SOURCE: Bissell 1697w Powersteamer

I have a similar model and occasionally have problems with water/detergent flow. I find it is generally due to an airlock in the piping caused by forgetting to turn the deregent water control off before removing the detergent container. Follow the manual instructions. Turn the knob to off. Fill both containers. locate them carefully. Make sure filters in the water tank and in the flow meter are clear. Start machine with handle laid flat and knob turned to maximum flow.

Posted on Dec 22, 2006

  • 29 Answers

SOURCE: Bissell carpet cleaner

The water sprayers on your Bissell are probably clogged. I had this problem this morning, myself, with my machine, about 15 months old. They get clogged up with mineral deposits. This is a *fairly* easy thing to fix yourself. Read all the way to the end before trying this fix.

Unplug the Bissell. Remove the water container pieces from the top of the base. You'll probably reveal two red plastic pieces mounted in the Bissell's base, about .75" x .75". These spray water on your brushes when you press the water-and-soap trigger at the top of the Bissell's handle. These water sprayers tend to clog. See the metal spring running up the hose, behind each red water sprayer? As you squeeze the red plastic sides of one red water sprayer, use a screwdriver or other tool under the spring to wedge up the hose, to release the sprayer from its mount in the base. Stick a finger in the hole of the base of the Bissell where the sprayer was mounted and run it around the edges there including on the underside of the base to clean out any gunk you can find. Clean any gunk you can off the red water sprayer with an old toothbrush.

Now you need to remove the water sprayer from the hose. You need a pair of pliers. Use the pliers to squeeze the brass colored clip that is keeping the red water sprayed mounted to the end of the small hose there. Move the clip down the hose so it compresses the spring and is no longer on the red plastic water sprayer. Now you can twist and pull the red water sprayer out of the end of the hose. You'll need a little hand strength to do this. Just be careful not to break the water sprayer by using a tool. They're not particularly delicate, but breaking one would render your Bissell useless until it was replaced, so use a little care.

When you've removed a red water sprayer from the hose, put the outer end of the red water sprayer in your mouth and seal your lips around it, and try blowing through it. You can't blow air through it, right? It's clogged. Open up a paper clip and push it back-and-forth through the small hole in the end of the water sprayer back towards its middle. You'll probably push out a line of white mineral deposits. Clean them off the water sprayer with the old toothbrush, and try blowing through the water sprayer again. If air passes through clearly, you've fixed it. Now you have to put it back together. Push the water sprayer back on the end of the hose. Use the pliers to reposition the brass clip on the end of the hose over the water sprayer. Push the red water sprayer back into position in the base of the Bissell.

Now do the same for the other red water sprayer.

I had a problem when I fixed this on mine this morning, because when I pulled one water sprayer off, the hose advanced up under the spring and I couldn't reattach the red water sprayer, because it couldn't reach the end of the hose. So try to use the brass clip or some other means (rubber band, tape, another clip) to keep the hose from crawling up inside the spring after you pull the red water sprayer off the hose. If the hose gets up under the spring anyway, despite your best efforts, I fixed this by removing the six screws on top of the Bissell base (the surface of which the water tank mounts on top of), and then pried it up. You can pull out the hose, reattach the red water sprayers to the hoses, position the hose *very carefully* inside the base (there are mounts under there they need to fit into, so you don't break anything), push the red water sprayers through the mount holes and mount them, and then reattach the screws to the base.

There's something else you may need to do that can help get the water flowing. This one's easier. The Bissell uses pumps, which need to be primed. Sometimes an air pocket inside the machine keeps water from flowing. To prime the pumps, separate the two water tank pieces. Fill the base as usual and mount it on the Bissell without the top water tank piece. Plug the Bissell in and **turn it on**. (The Bissell must be running to do this.) Kneeling on the floor in front of the Bissell, reach up and press the soap and water release trigger at the top of the Bissell's handle and hold it in as if you wanted water to go through. On top of the water tank is a plastic grommet hole about 1 inch in diameter, through which you pour water to fill the tank. Seal that hole with the flat of your hand. You'll feel a bit of suction. Lift your hand up and down a few times. Release the trigger and repeat a few times. Now that you've cleaned out your water sprayers and primed the Bissell's internal pumps, I'm hoping water will GUSH through your Bissell once again.

As you probably have learned the hard way, as I did, it's VERY important to do a lot of cleaning of the Bissell after each use, more than the manual tells you to do. Clean the bottom of the unit. Empty all the water. Thoroughly rinse out both water container pieces. Unscrew the three clear plastic pieces, one in front, two on the sides, that surround the brushes, and rinse them thoroughly in water. Clean off the brushes and all the lint and gunk around and above the brushes. (A water spray bottle and toothbrush are helpful here.) Tip the machine and blow all the water out of the hole in the base. Release the red clip springs on the red water sprayers and blow on them. Doing this will slow the failure of the Bissell. It's a great little machine for the money, but it does have a learning curve and need more pampering than a vacuum cleaner, doesn't it??

Good luck!

Posted on May 29, 2009

  • 1 Answer

SOURCE: Bissell carpet cleaner won't spray water on floor setting

I have the same problem, can someone help.

Thanks

Posted on Jul 30, 2009

  • 1 Answer

SOURCE: Bissell ProHeat Carpet Steam Cleaner stopped spraying.

The problem was a clogged heating unit which is located in the lower handle. There are two clear hoses going up the inside of the left leg of the lower handle that go to the heater and to the in-line water switch all within the lower handle. I unplugged the metal heating unit water lines and electrical connections (label the connections as you take them apart if you have a hard time remembering things...there were seven connection in all be it water and/or electrical). Removed the heat unit out and then removed the 6 screws holding the heater cover. Inside was a white powdery pasty debris (lime deposit ?) and the water path was clearly blocked in four different places. I cleansed the water trough with a little water and soft toothbrush and several toothpicks then reassembled. If you need new washers go to Orchard or ACE hardware. Take the old rubber washers(they are red) with you for comparison. I didn't need new washers...I just gently cleansed them. I immediately ran clear water through the machine and actually cleaned the carpet with a water rinse only. Will go back and finish the carpet the right way tomorrow. I had only used my machine three times before this happend over a three year period. A friend told me to always rinse it two maybe three times with clear water after using it and before storage. This took me exactly 42 minutes to disassembly and reassemble. Cost savings is several hundred dollars since I have a 5 bdrm house and would need a professional cleaner to do the small dirty traffic lanes all around the house.

Posted on Sep 19, 2009

  • 4 Answers

SOURCE: Bissell carpet cleaner

I have owned three Bissell cleaners and experienced clogged hoses each and every use. Do not put carpet cleaning solution in these machines. They are not designed correctly. If you have a tough spot, just use some liquid dishwasher detergent and a scrub brush. It will get almost anything out! Try it! Then, use the Bissell with hot water only to clean up any detergent residue.
Have a great day! Bissell Sucks!

Posted on Aug 31, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Castex Scx 400


It sounds like the valve that actuates the flow of water is stuck open. Whether or not you could fix it depends on how the handle is configured. If the handle triggers something internally then it needs to be disassembled and the valve given some oil.

Mar 06, 2016 | Vacuums

1 Answer

Hoover brush and wash instruction manual


Hi there! To prepare for cleaning, put the solution and water in the top tank. While cleaning, all the dirty water gets sucked into the bottom tank. To clean squeeze trigger to release cleaning solution and slowly push carpet cleaner forward, this equals one wet stroke. Continue to squeeze trigger and slowly pull carpet cleaner back toward you (second wet stroke). Release trigger and slowly push carpet cleaner forward over area just sprayed with solution (dry stroke). Then slowly pull carpet cleaner back toward you without squeezing trigger (dry stroke). To avoid saturating the carpet don't do more than 4 wet strokes over one area. Always end with dry strokes. Here is a link to view the instruction manual if needed.
http://hoover.com/file/604/

Hope this was helpful!

Jun 19, 2014 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

Solution will not spray on carpet unless you use tools or spot spray also brushes are not turning


proheat 9300

Remove the water tank. You will see 2 red tabbed plastic spray tubes.(where the spray comes out if not clogged) Pinch the clips to remove from the machine. Then you will need to pinch the hose clips to remove the red tabs from the hose. Clean out those red spray nozzles. Next step: have a towel ready and fill the solution tank with water. Put the solution (not water) tank on to where the water tank would go. Place the machine selection knob to rinse/wet only. Now with towel under the hoses that you removed the red tabs. Turn on the machine and pull the trigger to activate the water. You should see water flow out of the hoses that had the red tabs on them. If not, release and pull again the trigger several times. If only 1 hose has water coming out of it then block the one that works and try the process above again to de clog the one that isn't working. Good luck.

Dec 07, 2011 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

Hey there, a friend of mine has a bissell pro heat 2x turbo, that is spraying no water on the floor setting, the pump works i assume, as the machine vibrates when the trigger is pulled, how would i...


Check the following with liquid in both tanks.


- Check to see if the machine will spray through the hose with the setting on tools. If it does, the pump is fine. Continue troubleshooting.

- Check for debris on spray tips. Clean them with a soft brush (on old tooth brush works well). The spray tips may be lifted out for easier access.

- Ensure the tank lid is properly attached to the bottom of the tank. To attach this properly, remove the Water Tank from the machine. Hook the front window onto the lip of the bottom container and then allow the window with lid to cover the complete tank. Secure the latch on the back of the bottom tank to the back of the tank lid. THE TANK LID CANNOT BE ATTACHED PROPERLY IF THE BOTTOM TANK IS ALREADY INSTALLED IN THE MACHINE.
- Check the bottom of the Water Tank and the Formula Tank to make sure each has a red auto-load gasket attached. Make sure the Water Tank and the Formula Tank are seated properly. Depress the x on this gasket to ensure this depresses and release back out. Liquid from the tank should dispense.

- Remove the handle completely and re-attach. Once the handle is re-attached, re-attempt to spray.


If the machine continues to not spray, check the following:


REMOVE THE COLLECTION TANK:
• Make sure the unit is set to water rinse
• Remove the smart mix bottle and fill it with water only
• Place the smart mix bottle into the collection tank reservoir
• Run the unit and try to spray. If the machine sprays, you will be able to see the water level decreasing in the smart mix bottle and you will need to replace the bottom tank. It is possibly warped.

Nov 22, 2010 | Bissell Vacuums

1 Answer

I have a Bissell Proheat 2x cleaner which has worked perfectly on every occasion. Today I filled the machine as usual with water and formula and switched on, the motor ran, the lights were on and the...


Please check the following with liquid in both tanks.


- Check to see if the machine will spray through the hose with the setting on tools. If it does, the pump is fine. Continue troubleshooting.

- Check for debris on spray tips. Clean them with a soft brush (on old tooth brush works well). The spray tips may be lifted out for easier access.

- Ensure the tank lid is properly attached to the bottom of the tank. To attach this properly, remove the Water Tank from the machine. Hook the front window onto the lip of the bottom container and then allow the window with lid to cover the complete tank. Secure the latch on the back of the bottom tank to the back of the tank lid. THE TANK LID CANNOT BE ATTACHED PROPERLY IF THE BOTTOM TANK IS ALREADY INSTALLED IN THE MACHINE.
- Check the bottom of the Water Tank and the Formula Tank to make sure each has a red auto-load gasket attached. Make sure the Water Tank and the Formula Tank are seated properly. Depress the x on this gasket to ensure this depresses and release back out. Liquid from the tank should dispense.

- Remove the handle completely and re-attach. Once the handle is re-attached, re-attempt to spray.


If the machine continues to not spray, check the following:


REMOVE THE COLLECTION TANK:
• Make sure the unit is set to water rinse
• Remove the smart mix bottle and fill it with water only
• Place the smart mix bottle into the collection tank reservoir
• Run the unit and try to spray. If the machine sprays, you will be able to see the water level decreasing in the smart mix bottle and you will need to replace the bottom tank. It is possibly warped.

If these suggestions do not resolve the issue contact BISSELL Consumer Services.

1-800-237-7691
Mon-Fri: 8am to 10pm ET
Sat: 9am to 8pm ET

Sep 27, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

2 Answers

No water sprays when I press lever on handle


proheat 9300

assuming the water works for the tools

Remove the water tank. You will see 2 red tabbed plastic spray tubes.(where the spray comes out if not clogged) Pinch the clips to remove from the machine. Then you will need to pinch the hose clips to remove the red tabs from the hose. Clean out those red spray nozzles. Next step: have a towel ready and fill the solution tank with water. Put the solution (not water) tank on to where the water tank would go. Place the machine selection knob to rinse/wet only. Now with towel under the hoses that you removed the red tabs. Turn on the machine and pull the trigger to activate the water. You should see water flow out of the hoses that had the red tabs on them. If not, release and pull again the trigger several times. If only 1 hose has water coming out of it then block the one that works and try the process above again to de clog the one that isn't working. Good luck.

Apr 13, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

Brushes Stopped Working Again, What causes this to happen?


Hi,

There are several things that can cause the brushes to stop spinning on a Hoover SteamVac. Usually when we see this problem come in, the brushes are usually just stuck to do carpet fibers, or pet hairs that get stuck inside of the brush block. A very easy way to clean these brushes is to take them out of the SteamVac (see the link below that is a full diagnosis of brushes not spinning on a Hoover SteamVac), and use a garden hose that has a spray nozzle on the end, and just spray each and every brush. If you start at the top of each brush, and spray water around the entire brush, each brush should spin pretty quickly from just the power of the water hose.

A lot of the times it's just stuff that got caught inside the brush block that stops them from spinning, I would say 7 out of 10 times this will fix the problem.

It also could be that the brush block is broken, or even the turbine inside of the SteamVac that drivers the brushes could be broken as well.

Here's a link to a Fixya repair solution that I did which will help you diagnosis what is exactly causing the brushes to not spin. If you examine the pole on the block, as well as the square shaped female receptacle, and that receptacle is spinning, then your brushes are just clogged up with debris.

If you need to purchase a new brush block, and you have the model that you listed this repair under, Hoover F7220900, here's a direct link to the brush block on our site:
Hoover SteamVac Brush Block, Part # 48437029.


Here's the diagnosis of the brushes:

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture I have circled one of the clips in red) Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 70% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic has not broken.

If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this female receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

I hope this helps you with your problem. If not, please feel free to request a repair clarification and I'd be happy to walk you through the diagnosing. I also can provide you with a blown up parts schematic to your machine, please just get the model number off the back of the machine and provide, and provide me with the full model number. I would be happy to provide any technical support you need, just request a clarification on the repair.



Chris Jones
d6c0881.jpg232c8b0.jpgadc2d4f.jpgb64e530.jpg

Apr 07, 2010 | Hoover F7220900 SteamVac V2 Upright Vacuum

1 Answer

The machine turns on and the indicator seems to be spinning but the water is not moving.


Operating the trigger does not dispense water into the spinning brushes - is that the problem?

If so, remove the clean water tank and look in the opening behind the black grommet that seal the water tank. Operate the trigger and look to ensure that the valve is operating (moves downward when trigger is pulled). If it does not move, the trigger shaft is stuck or broken and will need to be repaired.

Nov 21, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Hoover Steamvac Upholstery Cleaner will not spray water.


In my case when I pulled the trigger on the upholstery hose I barely got a drizzle of water. After looking at the parts online I realized the valve assembly on the spray end of the hose consisted of a black valve housing, with an inner spring and a white plunger part that sprays the water. The white plunger should move noticeably when the trigger is pulled. Since all 3 part of that valve assembly were replaceable I decided to try and take it apart. First I removed the 2 silver screws on the cover of trigger end of the hose and lifted out the valve assemble. The white plunger part was basically frozen in the black valve assembly. Tried pulling the white plunger out by hand wouldn't budge. So I use a pair of plier and pulled the white part out. Sure enough the whole inside was caked with what appeared to be old dried cleaner. I rinsed the spring and the white plunger. There were o-rings on the white plunger, I did not remove them but used an old tooth brush to clean out around them then reassembled. The white plunger now freeing slides a noticeable distance when the trigger is depressed and getting a large V shaped spray pattern. Lesson learned, I will now make sure I run plenty of plain water through the hose to rinse all the cleaner out after using it .

Jan 12, 2009 | Hoover F5832-910 SteamVac Supreme Vacuum

2 Answers

Bissell 1697w Powersteamer


I have a similar model and occasionally have problems with water/detergent flow. I find it is generally due to an airlock in the piping caused by forgetting to turn the deregent water control off before removing the detergent container. Follow the manual instructions. Turn the knob to off. Fill both containers. locate them carefully. Make sure filters in the water tank and in the flow meter are clear. Start machine with handle laid flat and knob turned to maximum flow.

Dec 22, 2006 | Bissell 1697-7 Powersteamer Pro Deluxe...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

119 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...