Question about 1994-1995 Mercedes Benz E320 E 320 Chrome Roof Trim Moldings 2pc 94 95

2 Answers

I have a mercedes e320 1995, suddenly i am having a problem that could be describes as below: 1- when i press to accelerate the car feels like shaking a little and doesn't accelerate unless i press at the bottom 2- when stopping at red sign or traffic the car starts to shake and the rpm goes lower and then higher and the oil pressure drops to low values until i drive the car again (car doesn't turn off) 3- at morning, (when cold) i feel the shake is stronger ................. I went for a garage, my coils are new, my bougies(ignitors) are new , i have replaced the fuel filter, and i replace the transmission filter and oil .............. still the problem persist and now the car sometimes have an explosion sound from the back any idea

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 430 Answers

Try cleaning the Mass Air flow sensor on the intake air filter hose dont use carb cleaner but use a electrical circuit cleaner. also check condition of air filter and intake hoses

Posted on May 03, 2014

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 22 Answers

Check your fuel pressure regulator, back fires are indicators of unburnt fuel and shaking could be fuel starvation. Yes, a bad fuel pressure regulator will not REGULATE the fuel properly.

If it was only shaking then it could be a clogged fuel filter.

Posted on Oct 15, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Mercades e420 won't accelerate when it's in park and you try and Rev it it just idiels and when you put it in gear and use the gas it won't work still what is the problem everything else works


Mercedes-Benz won t accelerate Questions & Answers - Fixya

www.fixya.com > Forum > Tags > won t accelerate
Mercedes-Benz won t accelerate related problems. ... to overtake vehicle, there is a sudden loss of brake. need to park side of road to ... Question about 1995 E420 ... By entering the Fixya site you declare that you have read and agreed to its ...

Jan 03, 2016 | Cars & Trucks

1 Answer

I have a 2003 mercedes c230. When the car is slowing down to a stop. Every time it shudders, or does a slight pause or hesitation. These cars have problems with hesitating on acceleration due to a sensor...


Only feels vibration when braking and there is no fault in the engine, the problem is in the brake rotors , Feels vibration in the steering wheel, when applying the brake ?

May 21, 2017 | Mercedes-Benz C-Class Cars & Trucks

2 Answers

I have problem with my Mercedes E350 Automatic 2005 model. It doesn't change gears when the car is cold so it feel like driving in first gear no matter how much I accelerate. When the car heats up I n


When was the last time you had the tranny fluid and filer changed? I hear that they recommend changing it at 60,000. This model has extensive electronic sensors and interface controls on the engine and trans axle (nothing is simple anymore... :( ). Just from what you described, i would think that perhaps there is a relay or sensor connected to the trans axle that is not functioning properly ( especially when cold ). Since you have to restart the engine when warm to get it to work, it makes me think a relay is being re-set when you re-start the car. The car should shift properly whether cold or warm. I hear that you will have problems shifting if the regular 60,000 mile changes are not performed on the trans-axle fluid. If it were me, I would try that if you have not already done so in the last 60,000 miles.

Apr 11, 2013 | Vehicle Parts & Accessories

1 Answer

Loss of brake during sudden acceleration.


Click the link below to troubleshoot this problem: ---
Car loses power while acceleration? http://schematicsdiagram.blogspot.com/2011/12/car-loses-power-while-acceleration.html

----------
Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

-----------
Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

--------------
How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-----------


How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

----------
accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

----------
stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

---------
Engine accelerates when brake is applied?

http://technoanswers.blogspot.in/2012/02/engine-accelerates-when-brake-is.html

-----------

This will help.

Thanks.

Feb 14, 2012 | 2003 Mercedes-Benz E-Class

1 Answer

Mercedes ml320 - hear noise sounding like springs recoil


our shop work on alot of ml320 the noise you are describing is a bushing in the rear suspension,on the torque bar.

Jul 17, 2009 | Mercedes-Benz ML320 Cars & Trucks

1 Answer

Mercedes vito smokes when accelerating


Check the EGR valve.Also check the air filter.

Jul 13, 2009 | Mercedes-Benz ML500 Cars & Trucks

1 Answer

Cruise control how to test


hello,good day,any speed approx. 40 km/h can be stored.accelerate the car with accelerator or the switch to the desired speed and briefly press switch in position 1 or 2,,once the speed is stored,release the accelerator pedal,,,to increase or decrease speed in step of 1 km/h,briefly press switch in position 1 or 2,,stored speed can resumed from approx. 40 km/h,briefly press switch in position 4,(page 80),,ty

May 30, 2009 | 1994 Mercedes-Benz C-Class

1 Answer

320 Ml Mercedes-Benz


Go to advance auto or auto zone and have the do a trouble code read ( it is free).
The plug is located under the drivers side dash to the left of the brake pedal.
Press the esp off button on the dash and see if ithas an effect. on acceleration

Next I would try this it is expensive.
If it feels like it is bogged down when you first start to acceleratewill only creep about 10 to 20mph it may be the mass flow sensor located between the air filter and the throttle body. It has an electrical connection. Sand eats them up and it is a common item about $200.

Mar 08, 2009 | 2007 Mercedes-Benz ML320 CDI

Not finding what you are looking for?
1994-1995 Mercedes Benz E320 E 320 Chrome Roof Trim Moldings 2pc 94 95 Logo

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Trimworks Vehicle Parts & Accessories Experts

Timllfixit

Level 3 Expert

2210 Answers

 AEpittsburgh
AEpittsburgh

Level 2 Expert

51 Answers

ivan whisker
ivan whisker

Level 3 Expert

1013 Answers

Are you a Trimworks Vehicle Part and Accessory Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...