Question about Vacuums

1 Answer

I have a Hoover Windtunnel model U5462. Plugged in, turned on, it popped and then no power at all. Not circuit breaker in house. Does the unit have a fuse or something similar?

No power at all is there a fuse that could be blown

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 281 Answers

Does it have a headlight and does it work? if so then unplug the vacuum and turn the brushroller by hand a few times.then plug it back in,if it works then your motor might be bad.you can try to spray a little wd40 into the switch then.work the switch back and forth a few times first to get the lubricant worked in to the switch .try to turn it on now.see if you have any cuts in the cord.also see if the cord is pulled out of the vacuum .if so you might have a wire unplugged inside the base of the vacuum

Posted on Apr 23, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Replace power cord on Hoover windtunnel vacumm


There are many different models of Hoover Windtunnel so I can't be specific to your model, you will need to determine where the cord enters the unit and how to gain access to the internal wiring. Disconnect the old cord and attach the new cord using the proper connectors.

Apr 02, 2017 | Hoover Vacuums

1 Answer

My hoover windtunnel upright self-propelled..seems the rollers are turned off. where is switch to turn them on?


The switch to turn the brush roll on and off is on the top cover of the nozzle housing

Jul 22, 2014 | Hoover Vacuums

1 Answer

I cant get my hoover vaccum brush to spin


First be sure the switch/circuit breaker on top of the nozzle is on. The brush also will not turn unless the handle is released and tilted back. This model of Hoover has a gear drive to turn the brushes. This was VERY prone to problems, and Hoover discontinued making replacement parts for it several years ago.

Mar 18, 2011 | Hoover U8147-900 WindTunnel V2 Bagless...

1 Answer

Compartment lid pops open when vacuum turned on


You will wish to call either the retailer you purchased it from, or call Hoover at 1.800.944.9200

Mar 11, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

My Hoover Dual V Windtunnel has suction but the brushes are not turning. How can I troubleshoot?


Take the lower plate off of the unit and check the belt for breakage. also, if it isn't broken, are there any obstructions between the belt and housing?

Jan 29, 2010 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

My Hoover Windtunnel blew the circuit breaker today, and did so again after I reset the breaker and turned off the only other appliance on that circuit. Any advice? Thanks from GrGrandma in Fremont


There could be a problem with the vac, the only way to know is to use an ammeter and test the current draw of the unit. If the vac is ok, the breaker could be failing. Plug the vac into another receptacle on a different breaker and see if it still trips the breaker; if it does, then have the vac checked out

Aug 18, 2009 | Vacuums

1 Answer

Hoover EmPower 4600 keeps blowing circuit breaker. The number of outlets in the house that will allow me to run the vacuum is dropping quickly. It is a 4 year old house and all the circuit breakers are 20...


take it to a friends house and plug it in if it does the same thing then the problem is in the vacuum cleaner.check your cord and see if there are anny cuts in it.you can open the breaker box then plug in the vacuum and watch the breaker box.you might see a spark and narrow down the problem.

Mar 22, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover s3765 windtunnel power head does not run


I have the exact same problem as you have. Have you found a solution since you posted on Mar. 18, 2009? Thank you.

Mar 18, 2009 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

Hoover WindTunnel Canister: Roller brush motor not turning


These motors have a fuse incorporated in the field winding and it sounds like that blew. These motors sometimes overheat at the front bearing and the bearing will melt into the plastic housing. This will cause the fuse to blow. It sounds like that's your problem. You can remove the motor by removing the three screws on the bottom of the powerhead and then check the front bearing for any bubbling or blistering in the plastic housing. The shaft of the motor should turn easily.

Jan 26, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

71 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18407 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...