Question about Car Audio & Video

1 Answer

Hifonics brutus bxi1210d

This amp cut out on me today. they power a pair of 15 inch audiopipe 1000rms a piece subwoofers. the amp lights up and has power, but no power is going through the speaker wires. whats wrong with the amp?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Car Audio & ... Master
  • 35,673 Answers

Your amplifier may shut down if it overheats, if, for example, it is driven too hard or as a result of the speaker load impedance being too low.

Posted on Oct 11, 2013

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: i have 2 15'' CVRs and a 1200w amp

1 OHM...ONE... sheesh now thats a low resistance for anything... If they are only 500 watts and they are in parallel, series well NO.. your amp puts out wayyyy too much for those speakers.. 1200w versus 500 watts by 2... srill NOT enough "Head room" for it to be safe... about half is all you could expect before Pop.. sound is heard.

Posted on Mar 05, 2010

  • 58 Answers

SOURCE: i hooked up 2 kicker

Chances are you have your woofers wired in parallel i would rewire your speakers in series and that should solve all your problems.

Posted on Aug 20, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Brutus elite hifonics BRE1600.1D. Not as powerfull now.


Make sure of voltage going in to Brutus.

Mar 23, 2014 | Car Audio & Video

1 Answer

I have 2 12 inch jl audio w7's with a kicker crossover and a powerbass equalizer 5 bands. i wanted to know if add a hifonics brutus 2100 d class amp to my subs at 1 ohm would it over power my subs. please...


Short answer: NOPE!

The Hifonics Brutus 2100 is stated to produce 2100 watts RMS @ 1ohm load. Most amplifier manufacturers overstate their claims. The 2100 watt output is most likely at 14.4 volts and not the 12.6 volts your car will actually be providing the amp.

But, even if the actual output was 2100 watts that would be 1050 watts to each 12w7. The 12w7's are rated at 1000watts RMS and 2000watts peak. As a MECP certified installer, any system I have done using 12w7's have had a MINIMUM of 1000 watts being provided to each speaker. My personal preference is to run 1500 watts each and keep the gains adjusted lower on the amp. Thus allowing the amp to run cooler and allow the additional headroom for those "show-off" moments!

Dec 22, 2010 | Hifonics Car Audio & Video

1 Answer

I have 2 15'' CVRs and a 1200w amp


1 OHM...ONE... sheesh now thats a low resistance for anything... If they are only 500 watts and they are in parallel, series well NO.. your amp puts out wayyyy too much for those speakers.. 1200w versus 500 watts by 2... srill NOT enough "Head room" for it to be safe... about half is all you could expect before Pop.. sound is heard.

Mar 05, 2010 | Kicker CVR152 CompVR 15 2/4 ohm 1000W...

1 Answer

I have a 2000 watt hifonics brutus amp ...it worked fine but 1 day it just stopped working..the power light doest light up but the hifonics led lights are still on...whats the problem?


there is a step up converter inside the amp that likes to come loose from the board. This may be your problem. Otherwise Check all the chips for burns or disconnect

Nov 13, 2009 | Hifonics Brutus BX 2005D Car Audio...

2 Answers

Hifonics brutus bxi 2008 amp. no power output


MAKE SURE SUBWOOFER OUTPUT ON YOUR RADIO IS ON IF NOT THAT COULD BE BAD INPUTS ON YOUR AMP

Aug 07, 2009 | Hifonics BXI2008D Car Amp

1 Answer

Illuminating the sub


i would assume hooking it to the remote and ground of the amp

Apr 24, 2009 | Hifonics Brutus BX12D4 Car Subwoofer

1 Answer

I am ordering 2 pioneer TSW307D4 or D2 is a 2400 watts amp good?


ok theres a amp called slugger they came out about 7-10 years ago its small but very very powerfull i was picking up my 2 15 inch l7 kickers i drove from my house to vegas with no problem about 4 and a half hrs and didnt turn off ,on the other hand i had my fosgate wich i love t1000 wich turned off on me a couple times

Mar 15, 2009 | Hifonics Brutus BXi 1206D Car Audio...

4 Answers

No sound in my Hifonics Brutus BXi 1206D amp


Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Jan 01, 2008 | Hifonics Brutus BXi 1206D Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4869 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76673 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...