Question about Canon AF EF 100-300mm f/4.5-5.6 USM Lens

Open Question

No AF on Canon 100-300mm f/4.5-5.6

This is the USM version of the lens, but the AF does not appear to be working. I got it second hand and it has not been used for some time, is there some sort of fix for this ?
To summarize what I'm dealing with, when I hit the AF button the camera knows that it is in AF mode and it displays the red rectangle on my screen when I push down the shutter button, but it doesn't focus at all.

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

cammedic
  • 667 Answers

SOURCE: I have a Canon EF 300mm f/2.8L USM Lens

Here is a link to many Canon products in PDF form: Canon Parts Lists


Unfortunately, the only 300mm 2.8 lens listed is the IS version

The procedure is not that complicated, but you need to pay attention to the connections on the circuit board. The mount is removed, and you need to remove the small screws that hold the connector board to the mount ring first.

I cannot do live chat due to I use a Mac, but I will monitor the thread if you have questions,

Kevin

Posted on Mar 24, 2008

Agent Allan
  • 480 Answers

SOURCE: The Auto focus just stop working

Hey Sammymalone,
This lens should have a 1 year manufacturers warranty on it, and if my guess that the USM motor is burned out is true I would have it serviced by an authorized service technician. Before you do this though I would try cleaning the lens contacts to make sure it is communicating with the camera body. I of course am going on the assumption that you have tried other lenses on the camera body to make sure the problem is the lens and not the body. I hope this helps!

Sincerely,
Allan
Go Ahead. Use Us.

Posted on May 29, 2008

  • 17 Answers

SOURCE: Canon 75-300mm USM III, was initially working fine

Try cleaning your lens contacts with a soft cloth or pencil eraser. you should see 7 pins on the camera body and lens.

Posted on Jun 14, 2009

SAGHA
  • 28 Answers

SOURCE: canon 70-300 mm IS USM motor-like sound which

HI I AM SAGHA FROM MUMBAI.ACCORDING TO ME WHAT MOTOR LIKE SOUND YOU HEAR IS OF IMAGE STABILISER MECHANISIM AND IT IS QUITE NORMAL YOU SHUT DOWN YOUR I S & WON'T HEAR ANYTHING ALL THE BEST

Posted on Jul 12, 2009

  • 421 Answers

SOURCE: Canon EF 75-300mm f/4-5.6 III USM Lens

If your AF motor is hunting then the lens probably needs to be looked at. I wouldn't recommend this as something to do at home so you will need to either find a repair shop if it is out of warranty or return it to Canon if it is in warranty.

Posted on Jan 17, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Error 99 and jerky fixation of focus between 17 and approxinately 30 mm works perfectly at zoom lengths beyond this with normal rapid fix of focus and records image normally. the error and failure to...


'Error 99' indicates some problem with the AF contacts. This is a common error in Canon lenses. It could indicate a very simple problem like dirty contacts or a much serious one like the breakage of USM cable.
As a first step, you can try cleaning the lens and body contacts (the metal contacts between the lens and body) using a pencil eraser. Be careful to hold the body facing down so that no dust falls inside. After cleaning both the lens and the body contacts, re-attach the lens and try shooting. If the AF does not work still, you need to take the lens to an authorized service center.
For the jerky focusing ring, you need to get the lens serviced by an authorized service center.

Aug 28, 2010 | Canon EF-S 17-85MM F/4-5.6 IS USM Lens

3 Answers

Cannot auto focus


It sounds like the circuit board flex has gone bad, It folds back and forth when you zoom the lens, And needs to be replaced by a repair shop and readjusted. Tony

May 26, 2010 | Canon 28-135mm f/3.5-5.6 EF IS USM AF Lens

1 Answer

18-55 lens not doing auto-focus


I offer you to buy Canon EF 24-105mm f/4 L IS USM Lens. This gives very good performance for your studio work and specially for portre. It has Image Stabilization and Ultrasonic Motor. Other professional lens are very expensive. It has red ring.
Please check the link below.
http://www.the-digital-picture.com/Reviews/Canon-EF-24-105mm-f-4-L-IS-USM-Lens-Review.aspx

Regards

Apr 13, 2010 | Canon 28-135mm f/3.5-5.6 EF IS USM AF Lens

1 Answer

Canon EF 75-300mm f/4-5.6 III USM Lens Auto focus motor keep working back and forth but lense is not able to stop on focus right. Had eror 01 also sometime with manual focus.


If your AF motor is hunting then the lens probably needs to be looked at. I wouldn't recommend this as something to do at home so you will need to either find a repair shop if it is out of warranty or return it to Canon if it is in warranty.

Jan 17, 2010 | Canon 75-300mm f/4-5.6 III USM EF Lens

1 Answer

00 on the F info (aperture shows 00)


I'll assume the lens is an AF lens? Most of the new Canon bodies require AF contacts. If there isn't the right contacts, it won't work. There are suppose to be AF body mounts that will tell the body that there is an AF lens, then use the old lens in Auto mode.
If it's an AF lens, the internal electronics are toast. You could send it out, but they'll charge you a "look at" fee. That could run into many bucks. Give Canon a call.

Jul 26, 2009 | Canon EF-S 17-55 f/2.8 IS USM Lens

1 Answer

Auto focus does not work on the 135mm


hi i am sagha a camera repairer from mumbai, i have gone through such problems much oftenly,in your case i think it is the internal problem with the flex board inside the lens which is multitwisted on metal plate after prolonged use becomes stiff & brittle and creates hairline cracks on the pcb which in turn breaks the tiny tracks & leads to malfunction at 135 mm.

May 26, 2009 | Canon 28-135mm f/3.5-5.6 EF IS USM AF Lens

1 Answer

Canon 75-300mm USM III, was initially working fine


Try cleaning your lens contacts with a soft cloth or pencil eraser. you should see 7 pins on the camera body and lens.

Apr 29, 2009 | Canon Zoom Telephoto EF 75-300mm f/4.0-5.6...

1 Answer

Canon EF-S 17-85MM F/4-5.6 IS USM prevents features from working on 40D


something sounds strange about this. aperture 00 is an invalid aperture value. stands to reason if that is the case the camera would complain about it. via error code. being that its only six mos. old i would give canon a ring.

Oct 11, 2008 | Canon EF-S 17-85MM F/4-5.6 IS USM Lens

2 Answers

Lens won't allow me to change aperture & several other functions on camera


The USM engine may be out of order, or there is a bad contact in the lens.

Oct 11, 2008 | Canon EF-S 17-85MM F/4-5.6 IS USM Lens

Not finding what you are looking for?
Canon AF EF 100-300mm f/4.5-5.6 USM Lens Logo

Related Topics:

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Cameras Experts

kakima

Level 3 Expert

102366 Answers

TC CAMERA REPAIR.Com...

Level 2 Expert

168 Answers

old marine
old marine

Level 3 Expert

1921 Answers

Are you a Canon Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...