Question about Sony KP-51WS520 51" Rear Projection HDTV-Ready Television

1 Answer

Sorry for the duplicate post, but somehow someone's not helpful solution got marked as solved, so I'm going to post again. I have a Sony Wega KP-51WS520. The problem is with the HDMI port. I have several devices connected to a HDMI switch (Tivo, Bluray player, PS3, AppleTV) and then connected to the only HDMI connection (input 7) on the rear. Everything seemed fine last night but then when I turned the TV on, the Tivo gave an error about not being able to receive HDMI or something. It was a Tivo error but was showing on the HDMI input. Then the AppleTV would work and display correctly, but when trying to play Netflix videos, there would be an error about not supporting HDCP or something like that (sorry, I didn't take exact notes and not near the TV now). The Bluray player was just black. I didn't even try the PS3. I tried changing the HDMI cable. Removing the HDMI switch from the situation. Doing a power reset and a hard reset on the TV (power resets on everything). But the problem still occurs. It appears there are 5 blinks on turning the TV on. I called a local TV repair place and they think it would need a new board and cost at least $250 to get started. Any thoughts or help? It still shows some video and audio through the HDMI input but is just acting buggy. Seems like it might be a setting but can't say for sure. The HDMI plug on the back of the TV does seem loose. I've tried moving the connection around when I plug it in, doing power resets and still get the problem. Doing a bit more testing, I can get the Tivo to show video but no audio. A box appears that says "HDMI conection not permitted. Press SELECT for more information." And audio and sound off the AppleTV if it doesn't have content protection. But if I try something like Netflix I get the error "This content requires HDCP for playback. Either your HDMI cable isn't properly connected, or your HDMI connection doesn't support HDCP. Please reconnect the HDMI cable from your Apple TV to your HDTV and try again." So it seems that there is something going on with the HDCP part of the HDMI connection that isn't working on the TV end.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 19 Answers

HDCP is causing the trouble You experience. Try using other video input connection for same set. If it works fine that way, the problem is that the rights protection (HDCP) is acting as "police" to prevent copying or reproduce unauthorized content. If only the HDMI is connected (disconnect all other inputs/outputs) on some sets, could be work fine.

Posted on Oct 12, 2013

  • Bill Easton
    Bill Easton Oct 13, 2013

    Yeah, the other video inputs (1-6) are fine. It's just input 7 that is the HDMI that is having issues. I'll try pulling everything out of all the other inputs and let you know if that seems to fix it. But yeah, seems to definitely be something with the HDCP.

×

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
welcomejee
  • 10594 Answers

SOURCE: KP-51WS520 wont turn on - standby & timer lights on constantlly

You need to check supply volts on main micro IC702 on main board of Sony KP-51WS520 TV.
If you have experience of big TV repair then I would recommend to get service manual of TV from any online store and check above said IC supply volts. TV must give error by blinking light in case any problem in drive circuits and if main micro fried, no error signal will be there.


Posted on Dec 05, 2008

  • 108 Answers

SOURCE: ps3 sony grand wega (4 yrs old)

Press the input button on the tv itself to select the proper input you desire.

Posted on Jan 08, 2009

welcomejee
  • 10594 Answers

SOURCE: No Video/Sound,POwr Gren LiTE Blinks 4Ever, SONY WEGA KDF-55WF655

Hi,
Please check lamp in tv as pop sound seems broken lamp.
Did you replaced lamp in last 2-3 years in tv? If not, then its lamp that got broken and tv needs new lamp.
Lamp replacement procedure is written in user manual and its easy, please buy Sony original lamp for good picture in tv.
Thanks.

Posted on Apr 25, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 36" wega and I can't get rid of the


Press the "Display" button. If it doesn't go off, press it again. If it still stays on, post a comment and I will dig into Sony files. Hope this helps

Jan 14, 2011 | Sony FD Trinitron WEGA KV-36XBR800 36" TV

1 Answer

Sony grand WEGA 60" with tiny blue dots all over


Sorry but you have a BAD light engine Sony is well know for this part to go bad quick, I think your tv is DLP?

Sep 18, 2009 | Sony Grand WEGA KDF-60XS955 60" Rear...

1 Answer

Sony KV36XBR800 standby blinks 4 times


The 4 blinks usually mans that there is no vertical deflection signal. Look for a small flat Ic with about 11 pins that may be marked LA7837 or something similar. Resolder the pins on that first. If that fails to resolve it, replace the IC.

Keep me posted.

Dan

Oct 15, 2008 | Sony FD Trinitron WEGA KV-36XBR800 36" TV

1 Answer

Sony Vega Service Codes


The 7 blinks indicate an over voltage condition. The high voltage section has exceeded 33,000V. This is generally caused by a bad regulator. I don't have a listing for your model, but there should be a multi-pinned IC attachd to a heatsink marked STRxxx located close to where the AC cord comes into the set. Post the actual marking here and I'll get you the part number and cost. That is the regulator that may be the problem.

Dan

Jul 15, 2008 | Sony FD Trinitron WEGA KV-32HS510 32" TV

1 Answer

Sony 36 in.tv fdtrinitronwega xbr


This is a duplicate posting. I responded in the initial one. Please see that response.
Dan

Jun 02, 2008 | Sony FD Trinitron WEGA KV-36HS510 36" TV

1 Answer

Sony tv kv-32fv300


you probably aren't checking this posting out anymore, but maybe someone else will see this and it can help them.

i was having the same problem, did a search and found this solution. worked like a charm!! go here:
http://www.floggingenglish.com/2008/07/22/diy-tv-repair-fixing-screen-flicker-on-a-sony-hd-wega/

Nov 24, 2007 | Sony FD Trinitron WEGA KV-32FV300 32" TV

2 Answers

Sony KF-50WE610


the color drive is going bad check with the sony service center it might be cover and repaired free.  my set went blue and the service tech is checking if it is covered.  good luck.

Sep 30, 2007 | Sony Grand WEGA KF50WE610 50" Rear...

2 Answers

Sony tv no pic or sound


Sony error codes usually only go up to 7. If the LED blinks 11 times, this usually indicates that either the clock or data line is shorted and this needs to be serviced by someone with experience with Sony sets.

Jun 28, 2007 | Sony FD Trinitron WEGA KV-32FS120 32" TV

Not finding what you are looking for?
Sony KP-51WS520 51" Rear Projection HDTV-Ready Television Logo

238 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

kakima

Level 3 Expert

102366 Answers

The Knight
The Knight

Level 3 Expert

74459 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...