Question about Washing Machines

1 Answer

Kenmore 70 series top loader washer machine smells like its burni

I got a new coupler placed on my KENMORE 70 SERIES WASHER MACHINE MODEL 110 92588210 and now it smells like its burning. Is this normal since the motor was bothered. Please help me.

Posted by on

  • 1 more comment 
  • jlfunny Apr 22, 2009

    Should I have the coupler redone to make sure it was put on correctly or just run the machine a few times to see if the smell will go away? Please help.

    jlfunny

  • steve
    steve May 11, 2010

    JLFUNNY, Are you referring to the direct drive coupling on the motor or the brake/clutch band on the transmission?

  • steve
    steve May 11, 2010

    If the coupler was not installed correctly it is binding the motor.

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 121 Answers

You had the clutch coupling replaced sometimes i have noticed that the smell will last a few loads but no more than that

Posted on Apr 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Model 22748 kenmore 70 series washer. fills but


This assumes that you have a basic Kenmore / Whirlpool top load, direct drive, neutral drain (it doesn't spin until the pump removes most of the water) machine.

First, see the Sears parts site for your washer:

http://www.searspartsdirect.com/partsdirect/getModel!retrieve.pd?modelNumber=110.92274800&pathTaken=partSearch

and you'll see a list of major sub-components with diagrams and parts.

Kenmore / Whirlpool top load, direct drive washers use a "Motor Coupler" between the motor and transmission.

It's used as a fail safe device and consists of three parts.

Two of the parts are the same, plastic units with three prongs that fit on one of the motor output shafts and the other on the transmission input shaft. Between them is a rubber piece with six holes.

The power from the motor is transmitted through the rubber piece to the transmission.

The other shaft on the motor directly drives the pump. This is likely why the machine drains.

If the motor coupler is broken, or worn, the motor may not be able to send full power to the transmission for agitating or spinning.

See the following for how to remove the cabinet, pump, motor and motor mounting plate to inspect and replace the motor coupler.

http://www.american-appliance.com/catalog/newsdesk_info.php?newsPath=16&newsdesk_id=137

If the coupler looks damaged, it's a relatively easy fix.

It is also likely the source of the burning smell.

(Sears price $18.86 but available from most appliance repair shops)

Pry the plastic pieces from the motor and transmission. Some people use a claw hammer but I've found that using a small (6 inch) pry bar works well.

Carefully fit the plastic pieces over the motor and transmission shafts and press them in place (Use a 1/2" of larger socket to put pressure equally around the pieces.

Put the rubber piece on the transmission plastic piece.

Replace the motor mounting plate.

Carefully line up the plastic prongs on the motor based plastic piece to the three un-used holes in the rubber piece. If they don't line up right, the coupler could be damaged.

Mount the motor, don't forget the two screws, put the pump back on the motor and use its' clips.

Put the cabinet back on, don't forget to plug the lid switch back in and re-mount the console.


Apr 22, 2010 | Kenmore Washing Machines

2 Answers

Kenmore 70 series washing machine that has a terrible smokey smell. Now my clothes have that horrible smell. What could the problem be and is it worth fixing.


This assumes that you have a basic Kenmore / Whirlpool top load, direct drive, neutral drain (it doesn't spin until the pump removes most of the water) machine.

First, see the Sears parts site for your washer:
http://www.searspartsdirect.com/partsdirect/index.action

Enter your model number (###.######) and you'll see a list of major sub-components with diagrams and parts.


Top load direct drive whirlpool / kenmore washers use a Motor Coupler between the motor and transmission.

The coupler consists of two plastic pieces with a rubber piece between them.

If the plastic pieces are broken, you may be smelling the rubber piece "burning"

Following is a description of how to access the coupler and check it.

It's a relatively inexpensive piece and is designed as a fail safe between the motor and transmission.

It's very easy to replace if necessary.

http://www.american-appliance.com/catalog/newsdesk_info.php?newsPath=16&newsdesk_id=135

If the coupler looks damaged, it's a relatively easy fix.

Pry the plastic pieces from the motor and transmission. Some people use a claw hammer but I've found that using a small (6 inch) pry bar works well.

Carefully fit the plastic pieces over the motor and transmission shafts and press them in place (Use a 1/2" of larger socket to put pressure equally around the pieces.

Put the rubber piece on the transmission plastic piece.

Replace the motor mounting plate.

Carefully line up the plastic prongs on the motor based plastic piece to the three un-used holes in the rubber piece. If they don't line up right, the coupler could be damaged.

Mount the motor, don't forget the two screws, put the pump back on the motor and use its' clips.

Put the cabinet back on, don't forget to plug the lid switch back in and re-mount the console.

Nov 25, 2009 | Kenmore Washing Machines

1 Answer

Kenmore 70 series top loadwasher does not completely drain water


the smell is raly bad because it doesnt drain all the water out , so it sits there. if all else with the machine works well, this means the water level sensor needs replacing

Jul 19, 2009 | Washing Machines

1 Answer

My Kenmore series 70, top loading, washer has a mold smell.


thaty have this one stuff called affresh its used for frontloaders but you can use it for toploaders too it works great

Mar 24, 2009 | Kenmore 22422 Top Load Washer

1 Answer

During washing the kenmore 70 series washer squeals


Re-check the motor coupler.
If it was not seated flush on both post it will bind and squeal.

Feb 21, 2009 | Kenmore 22422 Top Load Washer

1 Answer

My 70 series Kenmore washer will not spin


REPLACE MOTOR COUPLER/ IT FIXED MY WASHER SAME PROBLEM, DIFFERENT MODEL. HOPE IT HELPS YOU.

Feb 03, 2009 | Kenmore 23822 Top Load Washer

1 Answer

Kenmore 70 series washer will not spin, clothes are too wet


Not a belt, this is only a sound deadening devise on the brake housing. Not really needed. Replace the coupler

Jan 03, 2009 | Kenmore 24032\24036 Top Load Washer

2 Answers

Kenmore 70 series will not drain or spin


It sounds like the lid switch. If it ws the coupler the water would drain. Check to see if the lid switch is clicking when you put the lid down. replace the lid switch. You have a great washer. Fairly cheap fix.

Nov 20, 2008 | Kenmore 20722

1 Answer

Kenmore 70 series model 100.xxxxxxx


Forget about the belt and replace the coupler first. if that doesnt fully fix it then replace the clutch. But just changing the drive coupler should fix it up good as new.

Nov 15, 2008 | Kenmore 24032\24036 Top Load Washer

1 Answer

Kenmore 70 series washer


Does it hum or click? If it clicks your coupler is out or a hum could be a faulted gearcase.

Aug 19, 2008 | Kenmore 22422 Top Load Washer

Not finding what you are looking for?
Washing Machines Logo

Related Topics:

577 people viewed this question

Ask a Question

Usually answered in minutes!

Top Washing Machines Experts

Gerry Harvey
Gerry Harvey

Level 3 Expert

1466 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Brad Brown

Level 3 Expert

15729 Answers

Are you a Washing Machine Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...