Question about Alpine CDA-9885 CD Player

3 Answers

No audio from cd player

Just bought the cd player. i installed it myself. The radio works fine. I turn on the cd player and i get no sound but the deeck is playing the cd. I called the place i bougth it and they said it was install error. i don't understand this. If anyone can give me any advise i would appreciate it.

Posted by on

  • 2 more comments 
  • chris232319 Sep 23, 2007

    the cd player i bought was alpine CD-9885

  • chris232319 Sep 23, 2007

    switching the wires worked. thank you

  • Streeven Apr 06, 2008

    I just bought an Alpine CD-9885 and installed it yesterday. The car is a 99 dodge intrepid and it came with factory radio and everything, just a tape eck and no cd player. i installed the 9885 and the CD player and ipod registers with the 9885 but no audio comes out. what do i do?

  • TedB5370 May 12, 2008

    I have recently installed the CDA-9885 into my 2003 Ford Ranger. I removed the factory stereo system and installed the new Alpine with amp,cd changer and speakers. When I attempt to use the CD player or cd changer I get no sound through the speakers. The radio works just fine,but I really need to get the sound from the cd and cd changer. Can you please offer me some assistance?



3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

That worked GREAT!!!! Thanks for the help. I forgot that my truck had a factory Amp in the kick panel

Posted on Mar 28, 2008


Is there a transport screw on the deck?

Posted on Sep 30, 2007

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

What kind of car did you install this in? Did it have a factory radio in it? If I had to take a guess I would think that there is a factory amp that you may have hooked the blue wire from the alpine deck to. If this is the case when you switch to CD the alpine deck turns off the power to the power antenna lead(blue wire) and thus your factory amp. If this is the case hook the factory amp turn on to the blue and white wire and you should be good to go. The same goes if your have an aftermarket amp driving your speakers.

Posted on Sep 23, 2007

1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

2 Answers

Radio is turned on but no sound, mute is off

The radio has an amplifier? and you are sure there are speakers connected?

Jul 09, 2014 | Alpine CDA-7894 CD Player

1 Answer

2008 Kia Grand Carnival, cd plays but no sound. Audio works fine for radio

Try cleaning the CD player with a cleaning disc, that is the best way to troubleshoot this at a less costly price tag.

Nov 23, 2013 | Car Audio & Video

1 Answer

Audio doesn't work

Send it back if possible ,you've bought a faulty stereo.

Jan 20, 2018 | Sony MEX-BT2500 CD Player

1 Answer

CD will not play. The CDs goes in and out fine and looks like it is playing according to the display. I can change songs, fast forward and reverse through the songs according to the display but nothing...

Do you have the radio hooked up to an amplifier? If so, it sounds like you are using the blue wire (antenna remote turn on) instead of the blue/white wire (amplifier remote turn on) to turn the amp on. The antenna remote wire turns off when leaving tuner mode.

Jun 22, 2011 | Alpine CDA-7863 CD Player

1 Answer

I had an amplifier and sub installed using the factory cd player and it worked fine. then i replaced the cd player and now the sub and amp are not working but the new headunit works fine. the amp is...

if the wire ur talking bout suppose to be connected then ur radio shouldn't *** on ..the wire suppose to connect to the back of the radio where a screw goes, its a ground wire...hop i was of help.

Jul 12, 2009 | Kenwood KDC-MP435U CD Player

1 Answer

Sony cdx-gt300 AM radio malfunctioning

If no AM and everything else is ok , the unit needs to come ouit for repair...keep in mind that these are cheaper to replace than repair.

Mar 11, 2009 | Sony CDX-GT300 CD Player

1 Answer

Radio audio working but no audio from CD. Shows cd playing but no

:) swap your blue with your blue/wht or vice versa.. (behind the radio) this WILL fix your problem..

Jan 27, 2009 | Sony CDX-CA850X CD Player

1 Answer

No sound from speakers

did you check to make sure your vehicle didnt come with a factory amp, if it has one is it turning on? or did you remember to disconnect the negative battery cable while installing your radio, i know thats a dumb question, once i was installing a pioneer a barely crossed a couple wires and fried the radio, the radio itself worked fine and all the features etc, but it never did play sound again. i always disconnect the power now!!

Dec 26, 2008 | Pioneer DEH-P4000UB CD Player

1 Answer

No sound from my CD player

If you are getting sound from the radio as far as listening to the radio station. It might mean that the CD player is bad. Have you tried cleaning the player to see if that works. It could be that the lens is not reading the discs. Does any codes come up or does it say error.

I would check these things out. I think that the sound system is fine. If you can hear on the radio then it is on the radio itself more or likely.

Jul 29, 2008 | Alpine CDE-7858 CD Player

1 Answer

Alpine CDA-7873 (Same as CDA-7876 basically)

the blue line from the radio harness does not have power when the cd or aux are being used and the amp is not turning on-wire the remote line from the amp to the red line and your amp will stay on and you will get sound

Mar 27, 2008 | Alpine CDA-7876RB CD Player

Not finding what you are looking for?
Alpine CDA-9885 CD Player Logo

Related Topics:

272 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4905 Answers


Level 2 Expert

150 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides