Question about Car Audio & Video

Open Question

My Visonik vbx12a 12'' 500 watt sub stopped working the first night i hooked it up i hooked it up with my other 10'' visonik 300 Watt sub. I had baught a hook up so i could hook up one power cord to my batterie and then share the same power cord to both the amps and then i was driving and they both went out and then i got my 10'' to work and the 12'' wouldnt work. The 12'' has a built in amp. I tried hooking up the 10'' amp wires to the 12'' amp and nothing happend but my 10'' worked fine????? wats wrong with my sub???

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: sony 1200 watt amp

What kind of deck to you have? Sometimes there's a setting for the subwoofer output that has to be turned on. How is the deck hooked up to the amp? Be sure of the normal things: -Make sure the sub is connected in side it's box -Make sure the RCA cables didn't come off the deck -Check every connection! Let me know and be sure to leave feedback or I don't get paid.

Posted on Oct 03, 2007

Ad
Lexdiamonzz
  • 203 Answers

SOURCE: my amp works but my sub doesn't...!!!????????????

Whats the condition of your amplifier? New , Used, Old?

 

You might have a blown channel off your amplifier, this may cause little or no sound. You will have some distortion, crackle sound and then maybe nothing at all. What kind of subs are you running to it? Make sure the subs arent blown and check the voice coils to see that they are not torn off the subs , these are the 2 little silver or copper wires that are connected from the speaker connectors to the sub itself.

 

Let me know what happens?

Posted on Oct 21, 2007

sir fixalot
  • 146 Answers

SOURCE: installing visonik bass system

Here is a link to visonik to download manuals.
http://old.visonik.de/en/downloads.php

If you let me know your model number of the sub, vehicle make and model, and brand and model of headunit or CD player you have then i can provide wiring color codes, recommended wire routing locations, etc...

Posted on Jan 03, 2008

  • 61 Answers

SOURCE: not working

Sounds like the voice coils are cooked...try testing each speaker with no wires to them...use a multi-meter on set on ohms/resistance, low scale...should read either 2,4 or 8 ohms, no reading or very high reading means sub is shot.

Posted on Mar 16, 2008

  • 68 Answers

SOURCE: visonik amps turn on into protection mode(where green not red for three days)...switched over the wires to some sony amps and they dont even turn the hell on

the fuze could be blown on the amp or the speakers are to much power for the amp at full power so try to turn the amp to half and not to turn the speakers all the way up,.

Posted on Nov 27, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a visonik 800watt amp and i got it from a friend for free and i hooked it up right and as soon as i turned it on the 2 fuses blew then i replaced them and tryed it again and it stoped again so i...


Its the amp, do not put any more fuses in it
you need to get it checked out by a technician.

Its probably a power supply fault or blown output devices.

Hope this helps
Thanks for using FixYa

Aug 02, 2010 | Visonik V2508 2-Channel Amplifier

1 Answer

How do I hook up my 10 inch visonik sub woofers? they have 2 connections?


this is a dual voice coil sub. either have a 2 channel amp hook up to it. or have your mono amp have to sets of wires going out of it to your 2 connections. i dont suggest it but i have had one connection hooked up at a time played it when it blew hooked up the other connection as a back up. just make sure you have the right watt level for each voice coil.

Apr 14, 2010 | Visonik V10DV6W Car Subwoofer

1 Answer

Does it sound hot cool and bad ***


Hello dylanholick,

Visonik is somewhat low-end car audio and band pass enclosures in general usually produce rather muddy and boomy bass. It will probably sound "bad", but not hot, and not cool.

If you aim is a good self-contained system with amp, sub and enclosure all in one, why not consider an Infinity Basslink, MTX Thunderlink, or perhaps a Bazooka. They're all available at www.crutchfield.com for little more than you'll pay for the Visonik and any of them will definitely sound better.

Hope this helps.

Jul 14, 2009 | Visonik 10" 500-Watt Single Bandpass...

1 Answer

Sub box


it all depend on were you are putting these subs at. the dimesion on the trunk of a honda to a lincoln are vastly different

Jul 09, 2009 | Legacy (LA568) Car Audio Amplifier

1 Answer

Visonik V12D4


i would wire the coils of each sub in series which would yield an 8 ohm resistive load per sub - and then wire the subs in parallel to the amp which would bring the resistance back to 4 ohms for a bridged load which will give you max power handling from the subs and draw the full power of the amp at the same time

Jun 18, 2009 | Earthquake Sound PH800W.2 Car Audio...

1 Answer

Vbx12a blows fuses when you power it up!


Make sure your gain is turned all the way down. Unplug the RCA cables before hand. What does the subwoofer do when the amp powers on?

Feb 08, 2009 | Visonik VB-10PKG Car Audio Amplifier

1 Answer

Ok this problem is killing me...


maybe the speaker is bad

First try one thing, switch the rca jacks around and see if the other speaker stops working this time.

If so the problem is in the rca jack or head unit.

If the same speaker is still not working, the problem will be the speaker, you will have no other options left since you changed amplifiers and checked all wiring.

Let me know if this helps you

Jun 18, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Installing visonik bass system


Here is a link to visonik to download manuals.
http://old.visonik.de/en/downloads.php

If you let me know your model number of the sub, vehicle make and model, and brand and model of headunit or CD player you have then i can provide wiring color codes, recommended wire routing locations, etc...

Jan 03, 2008 | Visonik 10" 500-Watt Single Bandpass...

1 Answer

Not working


Sounds like the voice coils are cooked...try testing each speaker with no wires to them...use a multi-meter on set on ohms/resistance, low scale...should read either 2,4 or 8 ohms, no reading or very high reading means sub is shot.

Dec 21, 2006 | Visonik V128D4 Car Subwoofer

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

135 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4861 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

The Knight
The Knight

Level 3 Expert

74198 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...