Question about Kenwood KAC-8152D Car Audio Amplifier

2 Answers

Amp wont turn on

I have an 1800 watt pyle amplifer. It was working but then i took it out for a couple weeks and was using a smaller 200 watt amp. When i tried to put the pyle back in it wont turn on. Everything works fine and when i put different amps in with the same wires they work. I checked all the fuses on my amp and still nothing. What could be wrong?

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 298 Answers

Have you checked the remote wire is supply power? try jumping the main power wire t the remote wire to see if it turn on. Also check that your ground wire is securely making contact.

Posted on Apr 20, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Plug your amp up like u normally would then take a smaller wire run it from your ground wire to your negative side of your speaker wire on the amp then it should come on

Posted on Nov 29, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Pyle amp cut off and will not turn on


  • Ensure the device's power switch is on
  • Make sure the device has power connected.
  • Contact Pyle -->
    1-888-318-PYLE / 718-535-1800

Oct 20, 2013 | Pyle Pro PTA1000 1000 Watt DJ Amplifier

1 Answer

My pyle 2200 1400 watt 2 channel amp wont get power..... why!!!!!


did you check the remote turn on wire connection at the back of stereo?

Jan 15, 2012 | Pyle Car Audio & Video

2 Answers

Pyle Academy 2300 watt amp not working =(


wrap a striped speaker wire around the back of the rca out put on your cd player and for the record that aint a 2300 watt amp its like a 300 watt amp

Mar 30, 2010 | Pyle PLAM2300 Car Amp

1 Answer

What size amplifier to I need to operate a Pyle Driver Pro 15 inch subwoofer? It is hooked to a 200 Watt amp and there is no sound coming from the speaker?


You may want to check ALL the connections and make sure you are connected properly. You SHOULD surely hear a lot of sound even with such a small wattage amp. Blown speaker? Blown amp? Have them tested. Also the REM or remote line on the amp is a overlooked wire.

Feb 22, 2010 | Pyle Car Audio & Video

1 Answer

SHOULD I GO AHEAD AND BUY A 400 WATT AMP?


All amps aren't created equal. More exspense amps put out "cleaner" power. You need to know what the RMS power rating is for the amp at 8 ohms and 4 ohms. Also, is the speaker an 8 or 4 ohm speaker? How you wire a speaker or speakers (series or paralell) can change the ohms (resistence) which will change the power put out of the amp. Also, I'm assuming you are setting it up in mono?

Jun 22, 2009 | Pyle 2 Channel 4000 Watt High Power MOSFET...

1 Answer

Amp goes into protect mode after volume is turned up


Not enough juice, check the power and ground connections, another possibility is to have dc in the input, try to use in line filter available from radio shack to cut the dc, also test the with one speaker at the time, you could have a bad speaker (shorted) too.

Apr 08, 2009 | Pyle PLA4240 Car Audio Amplifier

1 Answer

Amp only runs on 1 channel til it is bridged tried 2 sets of rcas and still the same problem


Either the source isn't moving signal through stereo/both plugs, or the amp is damaged and will need repaired by an amplifier technician.

Jan 14, 2009 | Pyle 1800-Watt 2-Channel Bridgeable MOSFET...

2 Answers

My pyle amp keeps going into protection when i turn my music up and play it for a min


The most common cause is an unsafe load/speaker impedance. If you have the speakers wired correctly, you may have a short in the wiring. If the wiring is OK, the amp is likely defective

Let me know if you have any other questions.

Oct 13, 2008 | Pyle 1800-Watt 2-Channel Bridgeable MOSFET...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

156 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8211 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...