Question about Creative Labs Gigaworks S750 Computer Speakers

1 Answer

Left front speaker works the rest dont and the sub makes a hum

I got creative gigaworks s750 s700 and i had it hooked up to my dvr and it worked extremly well i moved and now i only get sound from the left front and the rest either makes a hum or it makes no noise at all the sub makes a loud hum please help asap

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 177 Answers

Either you have it configured incorrectly this time around, or the settings are defaulted back to original on your DVR........ adjust your DVR sound properties/settings. and check all wires/connections as well.

Posted on Apr 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Creative Gigaworks S700 i have checked both fuses still no power to control box


Stupid question: does the sound still work? it could be the LED just died after continual use (rare, since they last a long time, but not uncommon).
If not... it could be the controlling circuit board died. In which case, unless you have electronics repair experience, it would be probably more worthwhile to just replace the speakers, as pricey a model as it is.

Mar 23, 2012 | Creative Labs Gigaworks S750 Computer...

1 Answer

I have a Creative Gigaworks S700 (subwoofer) with no power out. LED off. Fuse ok.


first fuse as standard is in the plug to the power adapter. The second fuse is located at the back of the box where the power lead goes into. It is covered so look closely you just need something flat to open it. I have the S750 and that is what im basing this on but if the s700 is the same then you will find this helpful. Sorry did not notice this before.
Hope this helps.

Dec 11, 2009 | Creative Labs Gigaworks S750 Computer...

1 Answer

No Power on the S700, but LED indicator use to blink.


Try disconnecting both of the amp board power supply cable (the green one from psu to amp board)

Jul 08, 2009 | Creative Labs Gigaworks S750 Computer...

1 Answer

Creativr Gigworks S750 Subwoffer intermittent sound


The S750 system is a great sounding one but unfortunatly like many similar systems all the amplifiers and power supplies are housed inside the sub box. This means they suffer badly from heat and vibration problems (they cook themselves or shake themselves apart). I have fixed a few S750 systems in the past but due to their complexity it's not for the faint hearted.

May 26, 2009 | Creative Labs Gigaworks S750 Computer...

2 Answers

All I need is the control pod for the Gigaworks S750


I had an extra one but I sold it. According to creative labs they do not sell any replacement parts for the speaker systems. The best suggestion that I can give is to check craigslist and ebay for the control pods.

Dec 13, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Sub has died overnight


Change the fuse - located at the 220V input. Use a knife ti release it. Then the system will work again.

Oct 08, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Gigaworks s750


Same problem just went out after about 4 years.... weak lifespan for a 500 dollar system

Feb 12, 2008 | Creative Labs Gigaworks S750 Computer...

3 Answers

3 Gigaworks S750 dont work after a central electric power failure


based on my understanding on electronics. maybe the 3 speakers your talking about doesnt resoponds to the frequencies on the music you are playing because a 7.1 souround speakers, each speakers are designed to respond at a certain frequecies.

So try playing movies instead of music and try lowering or not connecting the rest of the speakers and listen closely to the 3 speakers your talking about if you hear any sounds at all...

 

hope it help...

 

send me feedbacks...

Oct 16, 2007 | Creative Labs Gigaworks S750 Computer...

1 Answer

A mess!


pls check your audio cable conection. bye

Sep 11, 2007 | Creative Labs Gigaworks S750 Computer...

Not finding what you are looking for?
Creative Labs Gigaworks S750 Computer Speakers Logo

210 people viewed this question

Ask a Question

Usually answered in minutes!

Top Creative Labs Audio Players & Recorders Experts

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

618 Answers

yadayada
yadayada

Level 3 Expert

74945 Answers

Brad Brown

Level 3 Expert

15441 Answers

Are you a Creative Labs Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...