Question about Directed 1100d Car Audio Amplifier

1 Answer

My protection light comes on then my green light then my red every things wired perfect i need a number that can fix class d amps

It has a green light red lght and it keeps doing this please help me fix it i love this amp

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Make sure your wires arent freyed and touching itll protect if any wires touch so ur system doesnt short check all cables from deck and most of all make sure your ground connection is solid if it rattkes aroud itll fry your amp i had the same prob need n e thing else just holler

Posted on Apr 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why my jl audio 1400d amplifier stays in protective mode?


Check for a speaker wire that come come of , Or a loose grond wire on the amp or where ever you have the ground wire connected two,

Oct 31, 2012 | Jl Audio Car Audio & Video

2 Answers

Tc 8001 red light


on some amps there is a duel light. red and green usually. red means it is in protect mode or you didn't hook up your remote wire. if in protect mode, it could mean a number of things. did you hook it up with speakers and everything?

Mar 01, 2012 | MTX Thunder® TC8001 Car Amp

1 Answer

I have a kicker dx 500.1 amp and a kicker cvr12 sub. When I first hooked up worked perfect for a few minuted. Adjusted settings ont the side and it went out. Now When I power on it the protection light...


check the fuse on the power wire (+) not the ground wire .. i had a kicker 1500.1 on 2 l7 15\'s and when the bass would hit hard the fuse would vibrate and cause the amp to go into safe mode.. after re wireing the whole truck i then found out it was the 150amp fuse holder

Aug 07, 2011 | Kicker Car Audio & Video

1 Answer

The Ground wire is hooked up right but the red light wont go off and stay green so the amp will work. It is very frusterating all the cables are the right size its is a 1000 watt amp. I have two 500 watt...


Sounds to me like the amp is going into protection mode. Try placing one sub on the amp with very little gain. One of the biggest reason why this happens is because the subwoofers are wired wrong. What is the brand and model number for your amp?

Apr 14, 2011 | Car Audio & Video

1 Answer

Xplod XM-554ZR Car Audio Amplifier: powr/protect light comes on red not green...


Hi, disconnect all speakers from unit and try again - if red light still shows then your amp has died.
If the light goes green, then start testing for shorted speaker/wiring. This includes speaker wiring to vehicle shorts - there should be an o/c reading on your meter

May 05, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Havin problem with a1200 class a/b amp it ligts green and red at same time after hooking in remote how doi fixdo i need diagram to fix


Make sure you don't have any shorts on your speaker wires or rca cables. Unplug one at a time, the turn on power until it stays green with no protect light, then you know what input is causing the short. If you remove all speaker wires and rca wires and all you have connected is the ground, power(12volts) and remote and it still lights up red/green(in protect mode) then your problem is the amp.

Mar 09, 2010 | Car Audio & Video

1 Answer

Kicker zx750.1 Amp in Protection Mode (Red LED)


My kicker amp zx1500.1 keep going in protection mode I unhooked the sub speak wires and put the ACR cords back in and it didn't go in protection mode what next

Mar 18, 2009 | Kicker 06ZX750.1 Car Audio Amplifier

1 Answer

Amp on "protect" mode


Hi, what you need to do is unplug all the connections to the amp. The amp goes into protection when the circuitry over heats.\
First decrease all your gains to minimal volume.
Connect your 12+V, remote, and ground.
See if the protection light comes on then.
Next plug in your RCA cables.
Check protection light.
Then plug in your subwoofer cables.
See if you are still in protect mode.
Hopefully everything works alright again.
Just slowly increase the gain to see what the cut-off is. Make sure you aren't dropping the ohmage too low on the amplifier. Check manual for correct wiring and such.

Feb 08, 2009 | Phoenix Digital PD-394 Car Amp

1 Answer

My sony xplod 1000w xm-1652z doesnt work anymore


First off, according to the manual, the protect light should be green. That's normal operation. If it is red, that's a problem.

If it does go red, disconnect all of the wiring to the amp except the +12V and ground. Short the remote connection to the +12V to force the amp on. If the protect light still lights red, the issue is inside the amp and will need repair. If the issue goes away, try reconnecting one wire at a time until the protect light goes red again.

Mar 23, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Both green and red ligt or on my jensen ka3 i dont know what it means i had it working b4 i swaped my subs for some new ones and the amp dosent work now.i dont know if is because of the red light but i...


Generally, the power light is green and the protect light is red. If the protect light is on there could be a short in the wiring or there could be an internal fault in the amp.

Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down (goes into protection), the amp likely has blown output transistors.

Dec 28, 2007 | Jensen KA3 Car Audio Amplifier

Not finding what you are looking for?
Directed 1100d Car Audio Amplifier Logo

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top Directed Car Audio & Video Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Are you a Directed Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...