Question about Canon EOS-50E 35mm SLR Camera

1 Answer

WHEN I LOAD A ROLL OF FILM INTO MY CANON EOS 600, THE FILM DOES NOT ADVANCE AND THE FILM ICON BLINKS.THE SHUTTER WORKS WHEN TESTING WITHOUT FILM INSTALLED.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 531 Answers

Jammed Advance motor. Unfortunately, there is no way to reset it or fix externally. Will need service.

Posted on Apr 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is my canon ae-1 only developing blank film


First thing I would do is sacrifice a roll of film. Load the film as you have been. Then with the back open and tension on the film (do not touch the film over the shutter, advance the film. It may be that you are putting the film on the takeup spool incorrectly. Watch how the film advances on the spool. If it is on the spool incorrectly it will disconnect then not advance. If that does not work it may be a errant takeup spool.

Jul 06, 2012 | Canon EOS-AE-1 35mm SLR Camera

1 Answer

Hi , I have a Canon AE-1 camera and I'm haviving a problem with the film advance lever . It seems to be stuck . It will not advance. Have you ever come across this problem before? Thanks ,John.


Canon AE-1 35mm SLR is a manual focus camera EOS is Canon's designation of auto focus EOS stands for Electro-Optical System. The problem you are experiencing is caused by several little things that throws the camera, wind and cocking leaver out of synchronization or simply come to the end of the roll. There is a frame counter window just to the left of the shutter release behind the shutter speed dial. Also if you have just loaded film in the camera it may not be seated correctly check by releasing the rewind button, wind the film back but not all the way and open the camera to restart the film.

Diagram
tri3mast_249.jpg

Mar 03, 2011 | Canon EOS-AE-1 35mm SLR Camera

1 Answer

Where is the shutter release button on a Canon AE-1? I am trying to load film in the camera, and the shutter crank "thing" is stuck. do i need to release it with a press of a button???


Did you actually mean shutter release or shutter advance? And to load the film,you need to pull the roll winder upwards. While you pull the winder upwards, it would have a tuck voice and then the back cover would open up. Make sure you have wound the entire roll before you open the back.

Jan 23, 2011 | Canon EOS-AE-1 35mm SLR Camera

1 Answer

When taking a picture the film does not advance. It must be shut off and turned back on again. After developing those pictures, the top half of the picture is black indicating that the film is not...


if the film drive cogs are all ok then its the film advance drive gears on the motor drive striped or slipping,,you could test this by opening the camera and genteelly holding the film advance cogs with your finger and pressing the shutter if the film advance cogs stop turning then the drive gears are slipping or striped? this could be caused by the after load censer in the camera not censing the end of film roll and trying to get another frame out of it? like it read a 24ex as a 36ex but the censor faled to stop the motor drive winding on and that striped the gears

Aug 09, 2010 | Canon EOS Rebel K2 35mm SLR Camera

1 Answer

My Pentax SPII shoots blank images


You can check the shutter without film in the camera. Remove the lens and open the film door. You will see the cloth curtains of the shutter in the center. Advance the film lever to **** the shutter and set the speed dial to a slower speed like 1/15. Hold the camera so it is aimed a a light source, (a window will do) and fire the shutter. You should see the light through the shutter for the time duration is is set to. (1/15). If you see the light source, repeat the process going up one speed setting until you reach 1/1000. If you see the shutter open and close as described, then try another roll. After you load the film and close the back door, make note of what the rewind knob is doing as you advance the film. It should spin counter-clockwise each time. That is a easy test to know that the film is traveling in the camera properly. Vary your exposures with the new roll at different speeds and f-stops. You should get exposures, but if not let us know.

Jan 31, 2010 | Olympus Stylus 850SW Digital Camera

1 Answer

Blank Film Developing


It likely did not catch when it was first loaded, and as such never advanced through the camera. Open the back of the camera, with no film in it, then set the shutter speed to 1, advance the film advance lever and take a shot. You should see the shutter curtains open and then close a second later. Then advance the film lever again and watch to see that the sprockets are turning. If they are, then the camera is exposing and the mechanics are working properly to advance the film. Chances are it was just loaded incorrectly.

Dec 09, 2008 | Canon EOS-AE-1 35mm SLR Camera

1 Answer

Canon EOS Rebel K2 constant low battery indicator light


Canon also uses the low battery Icon as a generic error code. Try taking the lens off the camera. If this fixes the problem the lens needs a repair (most likely the aperture unit). If not then the camera needs the repair (either the shutter or dc-dc converter circuit).

Nov 18, 2008 | Canon EOS Rebel K2 with 28-90 lens 35mm...

Not finding what you are looking for?
Canon EOS-50E 35mm SLR Camera Logo

Related Topics:

346 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Photography Experts

kakima

Level 3 Expert

102366 Answers

old marine
old marine

Level 3 Expert

1972 Answers

David Payne
David Payne

Level 3 Expert

14161 Answers

Are you a Canon Photography Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...