Question about Broan-NuTone CV350 Central Vacuum

3 Answers

No sucking power

The unit will not pick op lint,the roller,belt and bag are all gd

Posted by on

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 701 Answers

The belt may look fine but it is probably stretched. You can find any vacuum belt at www.vacbelts.com.

Posted on Oct 10, 2009

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 58 Answers

First off if you have a flat rubber belt that is over a year old its not good. Replace your belt then try the nozzle. If your still not getting much airflow from the tank then check your bags and filters. lastly if your hose is old and worn out its time to replace it.

Posted on Sep 01, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 260 Answers

Check the hose it is clogged very common in this model. Use a clothes hanger to push trapped debris while on. if its real bad you might have to remove hose to clean out.

Posted on Apr 18, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Roller with brushes is not rotating although light is on and sucking sound is there. Is this a belt problem?Detached from floor part, the hand part is working fine. New filter. new bag.


Hi, it's Allie from Crucial Vacuum!

Your Kenmore vacuum brushroll is connected to the motor by two different sized geared belts. Over time, the belt's gears wear down and stretch out losing the grooves and tension that turn the roller. Another cause could be there is debris stuck on the roller and/or bearings. Changing the belts may be the solution to your problem.

Checking your unit's brushroll and clearing it of any tangled hair strands or debris that my be blocking the airway will be helpful. Follow by checking the internal hose for any blockages.

You can purchase direct your replacement, roller brush, filters and belts from Crucial Vacuum with free shipping and an exclusive 10% coupon for Fixya.com readers, use code: FIXYA10

http://www.crucialvacuum.com/kenmore.html

I hope this was helpful. If you would like further assistance, please feel free to give us a call at 877.750.9239. We have helpful and friendly customer care representatives on the line ready to assist you.

Alejandra (Allie) Sepulveda-Rivera
Crucial Vacuum Customer Care
http://www.crucialvacuum.com

Sep 13, 2014 | Kenmore Vacuums

1 Answer

HV9010P ROLLER BRUSH DOESN'T MOVE


That is probably the belt. Open up the bottom screws and take a look. The cat or dog hair usually gets stuck in the ends of the rollers and stops the belt from effectively pushing the roller. You may find that the belt is still on the drive and the roller. If you do just clean out the roller.

Jan 22, 2013 | Black & Decker AV1200 DustBuster Handheld...

2 Answers

I have the ultimate G The belt is on, new bag, vacuum runs but no roller rotation and minimal if any suction????


On the right side of your vacuum head, there is a green belt indicator light. If when the unit is powered on and this light is not lighting up, you have a broken belt, or you didnt properly latch the belt in place.

a) Broken belt- you can use the belt from your shampoo'er if you have one, otherwise your nearest Kirby distributor has them for a couple bucks

b) As for the suction, the Kirby has 2 motors. 1 motor is for the cleaning of the floor, the other motor (where you see the vent on the left side) is for keeping the unit cool to expand the life, which btw average life of a kirby is 20yrs and they all come with a lifetime refurbishing plan. If your not getting any suction check the boot of the bag where it hooks onto the unit for any clogging

Jan 15, 2011 | Kirby Ultimate G Bagged Upright Vacuum

1 Answer

My broan cv30 purchased in 1996 carpet power head unit sucks up dirt and rocks but will not pick string or yarns up from carpeting. I find myself picking it up. It is sucking fine dirt and small...


It's possible you simply need a new belt or roller brush. Place the power nozzle upside-down turn the vacuum on. Ensure the brush turns. If it doesn't, the belt has broken or is too worn to turn it. Replace the belt. Make sure the tension is properly set prior to reassembling the power nozzle.
Next, with the power nozzle upside down, run the flat of your palm across the brush area. If you can barely feel the bristles, it needs replaced. A good brush will loosen the yarn and strings, but needs to be cleaned periodically.
As long as the powerhead motor is running, there is no need to replace it. If it's not running, look for a reset button and press it. There could also be a broken wire, loose connection, or bad switch causing a power head motor to not operate..

Dec 31, 2010 | Broan-NuTone Vacuums

1 Answer

While vacuuming a rug on high (carpet setting) the power suddenly decreased. Now it will only run with low power, not picking up items on carpet


It sounds like you burned the belt. Turn the unit over, remove the cover plate where you see the brushes. On the side of the brush roller is where the belt is located. The belt should be very tight on the roller. Also, you may see little black rubber pieces stuck to the area where the end of the roller is or in the part where the belt runs. Get your owners manual out and read how to change the belt. I'll bet when you ran over the carpet it hung on some of the nap and hung the brush roller up for a second or so. That's all it takes sometimes to fry the belt on some vacumes. Sometimes new vacumes come with a new belt. Look in the bag or box and install it.

Mar 08, 2010 | Eureka 2991AVZ Bagless Upright Cyclonic...

1 Answer

Dirt devil vaccum #088915 won't pick up.


well the first thing i would look for is if the brushes turn turn it over bump the on off switch if it turns the belt is fine but u might have a clog in the bottom if that the case have to pull cover from thhe bottom take the belt and roller brush off and look up insde where the junk sucks up use a wire hanger if u need and after that clean out where the dirt goes in bag or canister........hope this helps

Dec 16, 2008 | Vacuums

1 Answer

Sucked a string up and now the self propel won't work


because you caught up the string, the belt is perhaps broken. turn on and check the roller rotates

Jun 07, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Broan-NuTone Vacuums Experts

Steve

Level 3 Expert

3287 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1456 Answers

JoeVacs

Level 2 Expert

346 Answers

Are you a Broan-NuTone Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...