Question about Car Amplifiers

2 Answers


I Put all the wires to the amp including the ground, remote, power, and the rca cables, the light turns on on the AMP Audiobahn A 18001DT but there isnt no bass coming. The stereo is perfectly working fine along with the car speaker. My old sub and amp was working fine before. I just but a new AMP AND SUB i even tried four different subwoofers but still no bass from the amp.....

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Is the master/slave switch set to master? Have you tried feeding the signal into a different amp to make sure that there is signal reaching the amp?

Posted on Sep 19, 2007


I had the same problem with my amp, turned out that the MOSFET Regulators on the inside were blown.....ordered new mosfets and soldered them in place and everything works fine.

Posted on Oct 13, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Amp constantly blows fuses as soon as power wire is connected. anyway to fix?

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty .
.A thumbs up would be greatly appreciated if this answer is helpful to you


May 22, 2011 | AudioBahn A2002T Car Audio Amplifier

1 Answer

I wanna put it into my car myself but dont know how and was hoping for a lil instruction

you will need a amp install kit witch comes with a 15 ft patch cable power line for amp and a blue line for remote. these wires run from the radio to the amp. The blue wire is called remote it turns the amp on or off depending on the radio state. the patch cable is rca jacks on both ends the back of the radio should have the female part of the rca jacks hanging from it. The other end goes into the amp. and last but not least the heavy red wire will go from the battery to the amp usually there is a fuse holder that you need to put between the battery and the amp. As far as grounding just ground the amps negative to the car chasis some where.

Good Luck Hope this helps

May 04, 2011 | Visonik Dual Bass Box with Amplifier Car...

2 Answers

I Have a audiobahn a1800dt its almost identical to this amp, i played it for a while with no problems, until i hooked up some crappy subs to it and it went into protection mode without comming out of it....

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty . Please check speakers impedance A thumbs up would be greatly appreciated if this answer is helpful to you


Feb 03, 2011 | AudioBahn A18001DQ Car Audio Amplifier

2 Answers

I have an a8000t amp with the protection light on, is the amp broke?

Disconnect the speaker wires then the power and ground completly. Then power up the amp and if the protection light turn on the you have an interanl problem if not then you ohm is problably to low and causing the amp to go into protections.


Nov 09, 2010 | AudioBahn A8000T Car Audio Amplifier

2 Answers

No sound protection light on.

Either blown subs, or bad amp.. Disconnect the subs, and try turning the amp on, if the amp is still in protect then your amp is bad, if the protect light goes off, then your subs are bad, or possibly wired at to low of an impedance, but I don't think that will trigger the protect on an Audiobahn amp.

Aug 21, 2009 | AudioBahn A2002T Car Audio Amplifier

1 Answer

ABR100T Audiobahn Bass remote not working correctly?

i had the same thing happen to me on my 2300hct audiobahn. it turned out to be the remote. but soon after my amp went dead. i than switched to JL no problems since.

but i still use audiobahn immortal 12's.

Apr 11, 2009 | AudioBahn ABR100T Remote Bass Control For...

1 Answer

Amp Issues

1800W peak output at 2 ohms
975W peak output at 4 ohms
600W RMS (continuous) at 2 ohms
325W RMS (continuous) at 4 ohms
Variable LP crossover adjustable 35-250Hz
4 AWG power/ground inputs and RCA pass through
Low-pass filter
Bass boost 0-18dB adjustable remote punch bass EQ
Signal-to-noise ratio: >80dB
Line-level input

It is going into protect mode for a reason.
Disconnect the subs and turn everything on again. If the light comes on, the problem is internal and will need servicing by a technician.

Dec 22, 2008 | Ultra Linear UL-2200D Car Audio Amplifier

2 Answers

Amp in protection mode

Disconnect all speaker wires and signal cables from the amp. If it powers up normally (doesn't go into protection), the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

Nov 11, 2007 | AudioBahn A4401Q Car Audio Amplifier

1 Answer

Audiobahn A 18001DT

the remote of amp. is not a ground it is a pos.+ 12 vlts look the back of your car stereo red the remote and conect to remote of the amp. if no sign remote of the car stereo conect to the 12 vlts of your bat.

Sep 18, 2007 | MTX Thunder 8302 Car Audio Amplifier

1 Answer

Power & protect

my amp says Lo on the digital circle on top of the amp i have a mtx 9500 bridged to the amp and it cuts out at high volumes and suddenly please help

Dec 21, 2006 | AudioBahn A8000V 400W x 1 Car Amplifier...

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

233 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides