Question about MTX Thunder 8302 Car Audio Amplifier

1 Answer

Audiobahn A 18001DT

When i installed the amplifier by putting the ground, remote, and power to the amp,and the rca cable in the input.. the amp turned on, even the lights, but there wasnt no sound coming from the amp to the subwoofer, I tried 3 different subs but still no bass.... PLEASE HELP>>>>>

Posted by on

  • Anonymous Mar 24, 2014

    crossover and amplifier turn on after rca's are pluged in

  • Anonymous Mar 26, 2014

    all of my connections are made and are perfect , I used this amp 2weeks ago in a 96 suburban but when I put my music in my 88 cutlass supreme it wasn't getting no power at all , ground is good , power cable has been switched just to see if it was that and even te remote wire. im just not getting any power . what should I do?

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 67 Answers

The remote of amp. is not a ground it is a pos.+ 12 vlts look the back of your car stereo red the remote and conect to remote of the amp. if no sign remote of the car stereo conect to the 12 vlts of your bat.

Posted on Sep 19, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Audiobahn a1502dp amp only one channel is working. I need both to bridge it and get its full 1ohm potential. Where can I get this fixed? Preferably near kc


Audiobahn A1502DP True Digital Series 2-Channel Amplifier

www.sonicelectronix.com > ... > Car Amplifiers > Class-D Amplifiers

Rating: 4.5 - ‎4 reviews
Audiobahn A1502DP • True Digital Series 2-Channel Amplifier 1 ohm stereo stable 2 ohms bridged • True Digital Circuitry • Dual Cooling Fans • HP/LP ...

new amp, only one channel working?? help! [Archive ...

www.caraudioforum.com > ... > Car Audio: Installation Help

Apr 24, 2006 - 16 posts - ‎5 authors
the next step would be to try reversing the rca cables on the amp. ... unplug one wire, the one sub that is working, gets quieter, although it is still working. as ... It'saudiobahn, of course this could happen straight from the factory.Missing: a1502dp

[PDF]True Digital Full-Range Series - Audiobahn

audiobahn.com/.../Amplifiers/A752DP-A1502DP-A2502DP-A1004DP-...
A752DP/A1502DP/A2502DP ... Audiobahn was established in 1997 with one long-term goal in mind, ... Great products and proper installation are only a small piece of the puzzle when it ... from the smallest terminal, to power wires up to 0 gauge, and 4channel RCA cables. .... exceed the total value of fuses in the amp. 1 1 .

one channel not working [Solved] - Speakers - Audio


Jan 15, 2016 | AudioBahn Car Audio & Video

2 Answers

Amp constantly blows fuses as soon as power wire is connected. anyway to fix?


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty .
.A thumbs up would be greatly appreciated if this answer is helpful to you

amp-constantly-blows-fuses-as-otfyjrky3pc2prtgltcdyqtn-3-0.jpg

May 22, 2011 | AudioBahn A2002T Car Audio Amplifier

2 Answers

I Have a audiobahn a1800dt its almost identical to this amp, i played it for a while with no problems, until i hooked up some crappy subs to it and it went into protection mode without comming out of it....


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty . Please check speakers impedance A thumbs up would be greatly appreciated if this answer is helpful to you

audiobahn-a1800dt-otfyjrky3pc2prtgltcdyqtn-3-0.jpg

Feb 03, 2011 | AudioBahn A18001DQ Car Audio Amplifier

2 Answers

I have an a8000t amp with the protection light on, is the amp broke?


Disconnect the speaker wires then the power and ground completly. Then power up the amp and if the protection light turn on the you have an interanl problem if not then you ohm is problably to low and causing the amp to go into protections.

-david

Nov 09, 2010 | AudioBahn A8000T Car Audio Amplifier

2 Answers

Audiobahn a8002t amplifier in protection mode


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. D .A thumbs up would be greatly appreciated if this answer is helpful to you. audiobahn-a8002t-amplifier-in-protection-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg

Dec 21, 2009 | AudioBahn A8002T Car Audio Amplifier

2 Answers

No sound protection light on.


Either blown subs, or bad amp.. Disconnect the subs, and try turning the amp on, if the amp is still in protect then your amp is bad, if the protect light goes off, then your subs are bad, or possibly wired at to low of an impedance, but I don't think that will trigger the protect on an Audiobahn amp.

Aug 21, 2009 | AudioBahn A2002T Car Audio Amplifier

1 Answer

I need a installation manual for audiobahn a8002t amp.


very simple run a ground from gnd on amp to a good ground spot on car run 12 volt power cable from back of fuse relay by battery to 12v+ on amp then splice blue wire on back of stereo splice in another wire about seven feet run that to remote on amp then hook up speakers its pretty simple to hook up an amp hope this helps

Apr 18, 2009 | AudioBahn A8002T Car Audio Amplifier

2 Answers

LIGHTS ON BUT NO BASS


Is the master/slave switch set to master? Have you tried feeding the signal into a different amp to make sure that there is signal reaching the amp?

Sep 18, 2007 | Car Audio & Video

1 Answer

Power & protect


my amp says Lo on the digital circle on top of the amp i have a mtx 9500 bridged to the amp and it cuts out at high volumes and suddenly please help



Dec 21, 2006 | AudioBahn A8000V 400W x 1 Car Amplifier...

Not finding what you are looking for?
MTX Thunder 8302 Car Audio Amplifier Logo

160 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

hoyzee1

Level 2 Expert

150 Answers

yadayada
yadayada

Level 3 Expert

78289 Answers

Mark Skinner

Level 2 Expert

77 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...