Question about Vacuums

1 Answer

Nothing inn the canister after using,suctione working,bottom roller working,no air leaks from hoses.Also when running awhile it shuts off by itself,have to wait awhile to use again

Nothing in the canister afer using suction working bottom roller working no air leaks from hoses. Also when running awhile it shuts of by itself.have to wait awhile to use again

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 33 Answers

I'm not sure what vacuum you have, but that sounds like a blockage to me. Thermal shut off kicks in, shutting the motor down, to prevent damage from overheating. After waiting like 1 hour it probably comes back on. Make sure hose, filters, bag (if any) is clean. All "airways" of vacuums need to be clear of any blockages, since airflow is what makes vacuums work.

Posted on May 10, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ihave a canister vac. Bought last april low suction


Have you cleared the vacuum hoses

Dec 01, 2016 | Vacuums

1 Answer

Nothing going into dirt canister


Is there suction at the hose? If not it is either blocked or the suction fan is broken. If there is, then there is a blockage in the pickup section, something is lodged across the channel after the brushes and before the place where the hose plugs in.

I think there is a safety switch to prevent it from running with the canister out so hard to check for suction at the top of the motor/suction fan. Make sure nothing is over that part under the canister too! If you can figure out how to bypass the safety switch (if there is one), you should have good suction where the canister sets on top of the motor base.

Oct 06, 2012 | Dirt Devil UD40270RM Quick Power Compact...

1 Answer

The performance indicator light is red and I have no suction.


If the motor runs, then the problem is usually plugged air passages near the bag/canister or the sweeper head/hose. Remove any hoses/bags/canisters so that you are dealing with only the vacuum producing parts. If it has a sweeper head, remove the bottom plate and clean any visible clogs in the air passages--the same with the area where the debris collects normally. Turn on the motor to see if you are getting air flow through the machine. If nothing, dig deeper into those air passages. Hope this helps!

Mar 17, 2010 | Vacuums

3 Answers

I have lost suction.....what do I do? -with the vacuum and the hose!


Its okay to unscrew where the hose is connect to the area close to the bottom, where the hose bends. That is where there is usually a ball of hair, dust, and whatever. Pull the hair ball out and also clean the roller.

Jan 12, 2010 | Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

No suction for use of crevice tools, running hot, then shut off


Obviously no suction in hose would indicate a blockage, over heating is a breaker that shuts off the machine when it over heats. There is no way to clean hose the on this model because the hose does not detach at either end, therefore I had to employ the use of the good old wire hangar. Job complete up and running, with good suction. It is amazing what a prayer to God can do.

Nov 17, 2008 | GE 106766 Bagged Canister Vacuum

1 Answer

I have a dyson that is picking up just fine when on vacuum mode, however when I try to use the suction tube there is no suction at all. It is not blocked and the canister is empty. Help!


Hi, I have an upright DC03, brilliant machine. Mine wouldn't **** and had the following symptoms;
- it sucked ok from the top hole where the canister joins the unit - with the canister the dust didn't spin aroun inside the canister like it normally does and there was no **** at the hose end or brush end. - with the top of the canister attached (the cyclone) but not the bottom it sucked through the cyclone - the small valve on top of the cyclone unit was sucking heaps
this indicated to me the machine was sucking through the cyclone unit but when the canister was put on it was blocked - hence the tremendous sucking through the valve on the top of the cyclone. As far as I could see the cyclone wasn't blocked so I poked some wire down the tube inside the machine that runs from the bottom of the unit (where the hose sits) up to the bottom hole where the canister joins. 
The DC03 has 2 holes where the canister attaches, it seems like it sucks air through the top hole, through the cyclone and through the lower hole sucks the dust up this inner tube into the canister. Check that tube, shine a torch from the top hole and you should be able to see the light at the bottom. Make sure you clear it completely. 
Mine was very very blocked. I kept poking and removing dust until I could see light at through the tube. Works fine now.
Hopefully this helps someone as it took me awhile to work it out. 
Good luck

Aug 12, 2008 | Vacuums

2 Answers

Dirt is not going into canister


I have been dealing with this exact same problem for a week and has been driving me crazy! I have done everything you just did and nothing worked. I just took the filter out that is underneath the canister and when I did it was clogged up real bad with tissue, styrofoam and hair. I reached in there and pulled as much out as I could then got needle nose pliers to reach in there to pull out the rest. Remember, it's behind the filter, not the filter itself. My vacuum works great now!!!

Apr 06, 2008 | Bissell 3594 CleanView PowerTrak Bagless...

4 Answers

Dyson Dc-17 Animal Doesn't ****


I had the same problem and today I finally called Dyson. They were very helpful. I disconnected the hose from the handle using the red release button. If you hold the handle up to the light and can't see light on the other side, there is a blockage. A wire coat hanger worked great to dislodge our blockage and it's working perfectly again!

Apr 02, 2008 | Dyson DC17 Animal Bagless Upright Cyclonic...

2 Answers

Hose has very little suction


ok dont know but if you havent already where the roller sits underneath it where the dirt sucks threw i had a problem a little like yours i did every thing you did same thing happened.but i had a clog in the vacuum i used a pressure with out the dirt canister on i blew out a real nice hairball.after that i tried it and what do you know it worked. hope that helps

Jan 05, 2008 | Bissell 6594 PowerForce Bagless Upright...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...