Question about Alpine CDA-7894 CD Player

1 Answer

Works sporadically Ive had this installed in my car for about four years. Recently, when i turn on the ignition, the player loads and the display will work showing that a disc is in and will show the track and time. No sound will come out and none of the controls will work..I cant change the volume, change the track, or eject the disc. Every once in a while i can hold the source button for a while and the unit will turn off, and when i turn it back on it will work fine until i turn my ignition off. When i turn it back on the unit will power up and everything but no sound again, and the controls wont work. It does the same thing if i have it on the tuner before i turn it off, only it shows the station and i cant change the tuner or anything else. Ive wondered if it was my faceplate not getting good contact or if something inside is maybe shorting out or something.

Posted by on

  • beavis8614 Apr 11, 2009

    yep same problem. Mine will actually turn on and work for a couple minutes and then go blank and nothing will work. It will still display everything but no buttons work. Currently the face is open in the eject position but froze there, can't close it.

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 150 Answers

Sounds like your head unit is on it's way out, you could try cleaning the contacts of the face plate plate with rubbing alchol and a q-tip. Make sure you get both sets of contacts, the face and radio.Because the display is working it's definatly not a power problem, clean those contacts and if still doesn't work invest in a new radio, sorry to bear bad news if it's not the contacts. L8R

Posted on Sep 18, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Why does 98 olds running sporadically then quits won't start


there are a number of reasons. Lets try a few specifics..
Engine Type?
Year?
Any work done recently?
Date of Last service?
Then please describe with the best detail, the actions of how it was acting before it quit...
I'll try to be very thorough, I just need more specifics

May 09, 2014 | 1998 Oldsmobile Aurora

1 Answer

Display not working after installation


If everything else seems to be working, the display may have failed.

Jan 23, 2018 | Sony XPLOD CDX-GT200 CD Player

1 Answer

My gas oven heats very slowly and sporadically. It often smells like burning plastic when heating. The oven is about 9 years old and did not have this problem until recently. What could be wrong? Might...


Good morning, your oven most likely has a weak igniter. That would keep the gas safety valve from opening properly. It will get close to the required amperage but valve will only flutter and not allow enough gas to ignite. Hope that helps.

Jan 29, 2018 | Maytag CWG3100A Gas Single Oven

1 Answer

2008 Chrysler 300 sporadic electrical problem at ignition


sounds like a short or loosening wire somewhere - have any "after- market" accessories been added ??? new stereo or amp ?? check these item and there wiring if so. It could also be the ignition switch itself......unfortunately - you may have to wait for a permanent failure to find the cause

Oct 24, 2009 | 2005 Chrysler 300

1 Answer

Ive had my RCA pearl 2gb mp3 player since November 2008. recently, it stopped loading the music. now all it does is turn on, show the "pearl" logo, and freeze. can u help me unfreeze it?


sounds like you may need to upgrade the firmware....her is the link to the file in case you dont have the software..
http://www.rcapearl.com/download.aspx


thank you . please let me know if it helped..

Jun 21, 2009 | RCA Pearl TH1102 MP3 Player

1 Answer

Random HDMI audio and video drop out & video noise


Hello, I am sorry about your issue. I suggest that your receiver be looked at by a service center. Thank you. Onkyo USA

Apr 03, 2017 | Onkyo TX-SR606 Receiver

2 Answers

'03 Honda Accord won't recognize CD player after battery replaced


I have a crv also. the audio system has an anti-theft mechanism, to deter thieves from stealing your cd player/radio. you need a code to turn your unit back on, usually a four or five digit code, that should have been provided when you bought the vehicle. If you don't have it, the unit will come back on after, and only after a full, uninterupted hour of driving.

Dec 22, 2008 | 2007 Honda CR-V

1 Answer

Navigation system disk error


you do need to clean sometimes. try using a cd cleaner found at most stores and clean disc with glass cleaner and lint free cloth

Sep 29, 2008 | 2006 Chrysler Pacifica

1 Answer

Pioneer system Query


usually red, black, yellow for the power.. the rest are for the accessories.. ie. speaker, optional amplifier power on trigger.

black goes to the ground or chassis.
red goes to ignition (so the head unit willl only power on when the ignition is in ACC or accessory)
yellow goes directly to the battery but fused.

Apr 10, 2008 | Pioneer DEH-P6800MP CD Player

3 Answers

Kd-s5050 wont stay ON


This is Common on Vauxhalls...

The Accessory position on the Ignition fails!

so the Ignition connection is temperamental... The unit has power and so certain functions using the constant 12v.

I normally connect the ignition to a different source.

Or a quick fix is to connect both red & yellow to the constant12v

Apr 27, 2007 | JVC KD-S5050 CD Player

Not finding what you are looking for?
Alpine CDA-7894 CD Player Logo

231 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4962 Answers

hoyzee1

Level 2 Expert

150 Answers

Jaime Hernandez

Level 3 Expert

2336 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...