Question about Lanzar VIBE266 Car Audio Amplifier

2 Answers

Lanzar amp 1000 watt stays on protect mode - Lanzar VIBE266 Car Audio Amplifier

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 655 Answers

Hello snow11879,

I haven't been able to locate any support information online about your product, other than the email contact for support questions:

support@lanzar.com

If the amp stays in protect mode all of the time, I would suspect a short in the speaker wiring or speaker(s) voice coil(s), or perhaps a faulty ground. If it plays for a short period of time and then goes into protect mode, it is most likely overheating. First check all of the wiring. Test your speakers on a known good amp and make sure there are no places in your wiring where the insulation may have been damaged, causing an intermittent problem.

Many owners have reported that this particular amp has a tendency to overheat. Also, when run in bridged mode, the speaker impedance needs to be at least 4 ohms. It will overheat if the impedance is below 4 ohms.

Hope this helps.

Posted on Apr 18, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Lanzar Master
  • 636 Answers

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty Time to fund an old school opti drive lanxar. A 59 will blow those subs apart .A thumbs up would be greatly appreciated if this answer is helpful to you.

Posted on Dec 18, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a lanzar vector VCT-2210 2000 watt amp hooked up to two menace 1300 watt subs. when i turn the volume up on the head unit the amp goes into protection mode. i checked all my wiring and it seems all...


Things to check: Is the wire between the amp and the subs heavy enough to pass 167 amps? 2000 * 12 = 166.66666 amps. Max volts on the subs are 10 volts....close enough. Are you sure you're using the line out on the head unit? You may be over driving the amp if it's anything else.If the head unit doesn't have line out connectors then you'll need to get an attenuator for each channel. Do you have caps on the 12 v power in wires? They'll keep the headlights from dimming and the alternator will last longer if you do.

Apr 09, 2014 | Lanzar VCT2210 Vector Series 2 Channel...

1 Answer

Lanzar vibe266 2000 watt stays in protect mode


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty .
.A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-vibe266-2000-watt-stays-in-zb4bomd1rt4qms0dqd12kkt2-3-0.jpg

Feb 05, 2013 | Lanzar VIBE266 Car Audio Amplifier

2 Answers

How do i reset my 4000 watt lanzar vibe 286 from being in protect mode


You can only reset it by disconnecting power to it. If it is in protect you may want to check your speakers and speaker wires for shorts and/or grounds. If they check out all right you may have internal problems in the amp.

Oct 28, 2011 | Lanzar VIBE286 Car Audio Amplifier

1 Answer

I have an old lanzar sl150 amp and everything is connected correctly but the amp stays in "protective" mode it will not turn on normally....I am confused on what size fuse to put in and if thays...


Check the ground. Also, you may have a dip in the volts that are powering the amp. If you have a multimeter, test the power wire, you should get between 12 to 14 volts. If it dips much lower than this, it will trip your protection.

Aug 30, 2011 | Lanzar Car Audio & Video

3 Answers

I have a Lanzar 4000 watt amplifier hooked up to 2 12inch MA Audio subs. When I crank my car the green power light on the amplifier comes on, but after a second or two it changes to protection mode. I have...


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to get an old school Opti Drive. .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-4000-watt-amplifier-hooked-up-2-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar

Jan 29, 2011 | Lanzar VIBE286 Car Audio Amplifier

1 Answer

I have a lanzar opti drive plus 500 old school,i have 2 12'' 1200 watt pyles,running in parallel at 2 ohm. when i bridge it at 2 ohm 1000 watts it blew my 40 amp in line fuse.


The 40 amp fuse is too small. 1000 watts = 12 volts @ 83 AMPS. Bigger power wire my friend. If you want to sell, let me know.

May 15, 2010 | Car Audio & Video

2 Answers

Lanzar 800 watt amp protect mode stays on


protect mode usaully means that something has disrupted the power of feed lines to the subwoofer/speakers possibly fuse is blown in amp or amp is blown in which we hope not. see if you have a warrenty if blown and send back or bring it to where you purchased it from.

Aug 01, 2009 | Lanzar VIBE266 Car Audio Amplifier

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Audio & Video

1 Answer

Audio bahn 1205n


sounds like your over working your amp 800 watt on a 2000 watt sub. might wanna upgrade your amp

Nov 28, 2007 | Lanzar 2H 1000W MOSFET AMP Car Audio...

6 Answers

Sub for lanzar mxa 282


2 X 18" Kicker CVR they will work really clean. 2000 watt max each and 1000 RMS just like your amp.

Nov 16, 2007 | Lanzar MXA282 Car Audio Amplifier

Not finding what you are looking for?
Lanzar VIBE266 Car Audio Amplifier Logo

Related Topics:

657 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lanzar Car Audio & Video Experts

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Joe Alexander
Joe Alexander

Level 2 Expert

65 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a Lanzar Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...