Question about Kenwood eXcelon KAC-X542 Car Audio Amplifier

1 Answer

Amp is on but wont work...please help!!

I just installed my kenwood excelon kac-x542 4/3/2channel power amplifier to 2 12" p3 "punch" subs to my 1993 pontiac sunbird that my cousin has just given me. I got it all hooked up, the amp is on but it wont get the subs to pound... my cousin told me that it was working for him and he let his friend use it on his 2 14" subs and he got it back cause his friend said it wasnt working...now i have them hooked up.. My cousin doesnt know much about this, either do i so im really hoping someone can help me to try and push some buttons on this amp to get it to work.. i got it for cheap from him so im not gonna give up on it unless its completely blown but im hoping its just something that his friend did that i can correct. SO PLEASE IF ANYONE KNOWS WHAT THE PROBLEM MAY BE OR HAS A SOLUTION I WOULD BE VERY HIGHLY APPRECIATIVE! Thank You p.s. anything helps

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 655 Answers

Hello lillj2323,

OK, you say that the amp won't get your RF Punch's to pound. You do not say if you get any output at all. So let's start from the beginning.

The KAC-X542 is a multichannel amp with 2 sets of stereo outputs, 1 set of stereo outputs and 1 bridged connection for sub(s), or 2 bridged connections for sub(s).

Make sure that both 30A fuses just to the left of the power connections are good.

Check that the "ID number" is set to "0". Make sure that you have RCA inputs to both channels A and B (leftmost pairs of jacks). Your subs should be connected to the 1st (+) and 3rd (-) of each set of output terminals.

Make sure that there are no broken off plugs or pins in the jack marked "H/U Terminal" or either of the 2 jacks marked "remote".

Check that the amp is set up for 2-channel bridged. The 6 switches below the filter controls and the filter pots should initially be set:
1 - Middle position (off)
2 - Up position (on)
3 - Down position (off)
4 - Up position (mono)
5 - Down position (off)
6 - Up position (mono)
The pots should be set approximately:
LPF - minimum
HPF - maximum
Input Sensitivity - match your head unit - probably between 1 - 3
HPF - maximum
Input Sensitivity - match your head unit - probably between 1 - 3
After you get the speakers working, the LPF, HPF and Input Sensitivity can be tweaked for best sound and lowest distortion.

Hope this helps.

Posted on Apr 18, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Best subs for the kenwood x812d


Try and match the rms output of the amp to the speaker , if the amp puts out 150 watts RMS make sure your speaker is at least 150 watts RMS.

Feb 03, 2014 | Kenwood eXcelon KAC-X812D Car Audio...

2 Answers

My subs/amp are not working


when you car is running, it charges the battery somewhat. So the voltage problem is not a problem. The red light means the amp is going into ''Protect Mode". This usually happens when something is wrong with the amp. Usually the amp is getting hot. Check all of you connectiong and check the final impedance of the subs. Make sure the amp can handle the impedance of the subs. If you need anymore help, message me.

Feb 12, 2010 | Kenwood Excelon KAC-X621 Car Audio...

1 Answer

Blinking E-03


somthing is fried on your motherboard

Apr 28, 2009 | Kenwood Excelon KAC-X811D Car Audio...

1 Answer

Wiring problem for my Kicker ZX450.2 amp


wireing an amp can be tough it starts from the e.q.the e.q. must have a sub out.

Mar 02, 2009 | Kenwood Excelon KAC-X521 Car Audio...

1 Answer

The amp is only putting out on 1 channel


I do believe this is caused by one of your amp fuses. Depending on which + on the amp is being used. That channel has a blown fuse. have you tried running + and -, + and - to both channels to see if both subs worked? If one sub doesn't then it's a blown fuse or scarred fuse and needs to be changed.

Feb 10, 2009 | Kenwood Excelon KAC-X521 Car Audio...

1 Answer

Amp light turning off and on


if you see that happen you might need to your i c sound chip or your trasistor change then and check

Dec 11, 2008 | Kenwood KAC-8103D Car Audio Amplifier

1 Answer

My kenwood amp


you need to check your wiring and check your rca wires to see if they are giving your amp a signal to put out

Mar 11, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Kenwood Excelon KAC-X521


According to page 7 of the radio's manual, E-02 means the amp has failed and DC is being applied to the speakers. It also says "Turn the POWER switch "OFF" and release the protection."

Feb 09, 2008 | Kenwood Excelon KAC-X521 Car Audio...

2 Answers

Kenwood kac-9152d


by jump do you mean all it does is thump and no sound besides thumping noise? if so put a better ground on your amp, double grounds work the best. please reply

Oct 06, 2006 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Kenwood eXcelon KAC-X542 Car Audio Amplifier Logo

197 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...