Question about Paradigm PDR 10 Speaker

1 Answer

Power Indicator Light on Front Doesn't Light

Bought a PDR-10 v.3, only a few months old, from the original owner. The sub seems to work fine except for the power indicator light (above the Paradigm logo on the front and under the grill mesh). I have another sub, and the light works just fine on it - small orange light when the sub is powered up. Any ideas?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers
Re: Power Indicator Light on Front Doesn't Light

The indicator light needs to be replaced, there is a loose or poorly soldered connection on one of the led's leads, or the circuit providing the signal (voltage) for the light isn't functioning.

Posted on Feb 10, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Paradigm pdr80 no sound

If it is a powered sub, the sub power supply may have failed. There might be an open fuse.

Dec 25, 2013 | Paradigm PDR 12 Speaker

2 Answers

I have a Mirage Prestige S8 subwoofer. 4 years old. Suddenly nothing....not functioning. No change in usage or location. Any ideas?

Check the status indicator - The LED found on the front panel should be illuminate in blue when the subwoofer is functioning. If the unit is in Auto mode and is not receiving a signal, the light will remain off. Try setting the power switch on the back to ON if in the Auto setting. Post back the status of your LED.

Aug 31, 2011 | Mirage Prestige S8 Subwoofer Speaker

1 Answer


Check your owners manual.You will probably have to activate the sub woofer outlet,using the remote.This outlet can usually be programmed to do more than one function.

Jun 18, 2011 | Onkyo Speakers & Subwoofers

1 Answer

Getting nothing out of this speaker. Was clicking for a while. Power light is on.Can I open it up and just hook up the speaker by itself to check that part It is a pdr 8 subwoofer

That would be one way to isolate the problem to either the woofer or its amp.

But do you know that it's getting an audio signal from your ?? unnamed source? Its setup could be at fault.

Or you could jack a CD player or any other audio source directly into the sub amp and see if THAT works. Start with something low as you won't have control of the volume.

Dec 22, 2010 | Paradigm PDR 8 Subwoofer

1 Answer

PDR-10 subwoofer has no output. 120vac to unit is

I have exactly the same situation with my PDR-10. Paradigm techs were of no help, don't me to take it to a service centre which i did. Of course when it was there they plugged it in and it stayed on for a day and a half so no problem right? Get it home, nothing, plugged and replugged, got it on once but not for long. Opened up back, everything including fuse looks solid and naked eye anyhow.

Dec 20, 2009 | Paradigm PDR 10 Speaker

1 Answer

Clestion S10 Sub not working

Instead of connecting it to the sub output, try it on the L or R output of your amp.
This will eliminate the Denon.
If this fails, you need to test the loudspeaker driver unit whilst disconnected from the sub amp. Use a 1.5v cell (AA or bigger) connect using croc leads to the speaker's terminals. If the speaker is OK, you should hear a click. If you hear nothing, the speaker unit is faulty.

Jan 25, 2009 | Celestion S10 Subwoofer

1 Answer

Inifinity Entra Sub not working

The hum can be from the power supply not properly filtering, and or the output stage also has a short.

There is the chance that the speaker driver coil is now burned, or the power supply is now dead. If ther output stage is shorted and was putting DC on to the speaker cone, this will burn it very easily.

You should sent the unit out and have it serviced, unless you are properly trained, have the service and engineering manuals, and the test equipment to follow up on a proper repair and calibration.

Jerry G.

Apr 27, 2008 | Infinity PS-10 Subwoofer

1 Answer

Power problem with Paradigm PDR 10 Subwoofer

Yes it can be.You can check it with ohmmeter the impedance should be 4 or 8 ohms.But if you can disassembly the sub its better then you can see and check everything.My guess is that one of the cables on the speakers connector is broken and its just touching the conntact.

Mar 08, 2008 | Paradigm PDR 10 Speaker

1 Answer

PS1200 Lost Volume/Pound

try reversing the polarity on one end.
hope it helps.

Feb 10, 2008 | Paradigm PS 1200 Speaker

1 Answer

Paradigm PDR-10 Sub Box

Since this is a sub I assume the sound is not coming from the speaker but is mechanical and coming from the amp in back. The tranformer can be the problem if it has delaminated or may be loose. Try removing the amp and tightening the screws. If there are rubber grommets to isolate the tranformer don't overtighten. for contact info and parts. They are very nice. If the noise is coming from the speaker then you are still under warrantee and they will replace it free.

Sep 28, 2006 | Paradigm PDR 10 Speaker

Not finding what you are looking for?
Speakers & Subwoofers Logo

Related Topics:

1,128 people viewed this question

Ask a Question

Usually answered in minutes!

Top Paradigm Speakers & Subwoofers Experts


Level 3 Expert

4518 Answers


Level 3 Expert

57192 Answers


Level 3 Expert

489 Answers

Are you a Paradigm Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides