Question about Paradigm PDR 10 Speaker

1 Answer

Power Indicator Light on Front Doesn't Light

Bought a PDR-10 v.3, only a few months old, from the original owner. The sub seems to work fine except for the power indicator light (above the Paradigm logo on the front and under the grill mesh). I have another sub, and the light works just fine on it - small orange light when the sub is powered up. Any ideas?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

The indicator light needs to be replaced, there is a loose or poorly soldered connection on one of the led's leads, or the circuit providing the signal (voltage) for the light isn't functioning.

Posted on Feb 10, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a Mirage Prestige S8 subwoofer. 4 years old. Suddenly nothing....not functioning. No change in usage or location. Any ideas?


Check the status indicator - The LED found on the front panel should be illuminate in blue when the subwoofer is functioning. If the unit is in Auto mode and is not receiving a signal, the light will remain off. Try setting the power switch on the back to ON if in the Auto setting. Post back the status of your LED.

Aug 31, 2011 | Mirage Prestige S8 Subwoofer Speaker

1 Answer

I have a Wolf gourmet 30" stove. it's about 10


Interesting, I'm looking for a solution to a similar issue. Our new (7 month old) 30'' Wolf Range has this issue. When both front burners are light, the back burner's electronic starter begins to click, but only when you put a pan on the front left burner. I believe the iron/steel in the pan is causing a magnetic field thats starting the rear burner to go off.. just don't know.. will report back after the repair person comes.

Jan 22, 2011 | Wolf Range 18 in. SPR-100 Gas Cooktop

1 Answer

Gateway M-6862 laptop will not turn on; battery light flashing re


Seems to be a problem of not enough power.

First check the voltage output of the charger(adapter) and match it with its specs.


Also try to reset the hardware using the following steps:

1 Disconnect battery and the charger
2 Let it sit for 1-2 minutes.
3 Press and hold down the power button for 30 seconds.
4 Reconnect battery and charger and try to start by pressing the power button.

Mar 07, 2010 | Gateway Computers & Internet

3 Answers

Advent 4211 battery light flashes orange mains power only


Yeah the same has happened to lenovo x61s, i contacted the supplier and they told me i need a new battery, unfortunatly laptop atterys arnt the cheapest things around

Jun 07, 2009 | Advent 4211c Notebook

2 Answers

Jvc th-c30


sharazanct I had the same problem and posted here many months ago without any success. Just today, believe it or not, I decided i would replace the screws in the top cover and try it one last time. I don't know why, but it now works fine.???? My original problem was my receiver would light up and appeared to be working but I would get no sound out of the sub or speakers. I noticed at the time when I would first turn the receiver on the green indicator light on the front of the sub would light for a couple of seconds and then go out and would get no sound. Today the sub light lit and stayed on and I'm therefore able to hear sound as if everything was normal. I wish I knew exactly what I did, unfortunately I don't. If you have everything back together you might try unplugging the receiver and sub for some amount of time and come back and try it again. Good Luck!

May 04, 2009 | JVC TH-C30 System

1 Answer

Makita 5" Random Orbit Sander


The armature windings have an overlay problem in the wiring causing this and there is no soluation except to replace the armature which is not cost efective unless you are still under Warrantee and get a free replacement, it will burn up at some point. If you bought it within the last month take it back and get a new one, over one month, pack it back up in the original box and send it to address in the owners manual for repair or replacement service addresses.

Feb 19, 2009 | Makita 5" Random Orbit Sander

1 Answer

Fujitsu AMILO Pro V2035 PC Notebook


If it's only 10 months old it is still within the manufacturers warranty, so do not touch or alter anything to do with the charger or battery, as even though the battery is seeming to be the fault, it is normally the motherboard charging point that is faulty or the motherboard not recognising the battery is connected.

May 02, 2007 | Fujitsu AMILO Pro V1000 Notebook

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

1,141 people viewed this question

Ask a Question

Usually answered in minutes!

Top Paradigm Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5484 Answers

woodzowl307

Level 3 Expert

667 Answers

Don Hart

Level 2 Expert

108 Answers

Are you a Paradigm Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...