Question about Metra Turbowire 70-5605

1 Answer

2000 mustang convertable amp problems

Hello i have a 2000 mustang and my factory amps are trashed they burned up so they dont work but now only my tweeters work no bass no backs and no lower door speakers or anything and i am going to install an aftermarket sony deck but i am having trouble figuring how the speakers are going to work (back and fronts) because the speaker wiring is with the amps that dont work and i have been looking at metra harnesses 70-5605 to by pass them but still if they dont work its not worth it so buy that need some help thanks mckenzie.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 82 Answers

Are you sure the amplifiers are trashed? Have you checked the fuses? A reputable car audio shop could help for a fee of course, but it may be worth the price. It's odd that (all) the amps would malfuntion simultaniously unless someone unqualified messed with the wiring or the radio has a defective trigger wire (turns the amps on). You'll be sadly disapointed with any new radio without the factory amps, especially with the convertable ... I strongly suggest getting the amps (the factory system) working again.

Posted on Apr 17, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my brake wire burn in half on my 2000 mustang?


Very strange. If circuit is pulling enough amps to burn up wire, one would expect fuse to blow. Is it possible something else is heating the wire, such as heater vent hose leaking, courtesy lamp bulb too close, other such? Could be that Hot Foot you are driving with,lol.

Jan 07, 2015 | 2000 Ford Mustang

1 Answer

What is a t0420 code in a 2000 ford mustang


I'm afraid your right side Bank1 Converter is shot

420 & 430's are failed converters

May 31, 2012 | 2000 Ford Mustang

1 Answer

I cant get sound out of my speakers. i put in a new stereo and hooked it up


Did you use a wire harness specific to your vehicle year and model? Make sure you get the right harness, depending on what factory system came with the car(base or mach460 sound systems), If your speakers were working prior to replacing the radio, then there's a possibility that the harness may not be compatible. also, the car may be equipped with a factory amp(mach460 systems). Here's a link that may help you figure it out. http://www.modifiedlife.com/2000-ford-mustang-car-stereo-wiring-instructions/

Sep 23, 2011 | 2000 Ford Mustang

1 Answer

I want to add fog lamps to my '01 Mustang convertible. I can get the lamps, brackets & dash switch from Ford at reasonable prices. My question: Does the existing wiring harness include wiring for the...


i dont think current wiring harness is set up for fog lights but fuse box should have a spot for relay and fuse (although it may or may not have metal leads installed) if your getting parts from ford i ask them if they have wiriring harness for it
if you decide to wire them in yourself i would HIGHLY recomend u put a relay in the system if you dont you will have to use bigger wire tho the whole sytem. with a relay u only have use the bigger wire from relay to lights. You will also have to use a heavy duty switch u will burn up factory switch if dont use a realy

Feb 17, 2010 | 2001 Ford Mustang

1 Answer

I have a 2000 watt hifonics brutus amp ...it worked fine but 1 day it just stopped working..the power light doest light up but the hifonics led lights are still on...whats the problem?


there is a step up converter inside the amp that likes to come loose from the board. This may be your problem. Otherwise Check all the chips for burns or disconnect

Nov 13, 2009 | Hifonics Brutus BX 2005D Car Audio...

1 Answer

Kdc-519 install in 93 mustang


if u have cut the factory harness, then u may have cut the power on wire for the factory amp

Jun 07, 2009 | Kenwood KDC-519 CD Player

2 Answers

Fai-3a installed, subs work speakers dont


did you cut them and splice into them. Because instead splice them all together and it should all work. or if you have a multichannel amp just hook ur factories into the amp as well.

Jun 05, 2009 | Scosche Industries Car Audio & Video

1 Answer

Trying to install into a 2002 Tahoe. Everything works except I get no sound. I looked up wiring diagrams but nothing shows a factory amp. Stereo works fine I installed it into mustang just to make sure.


Here is the wiring diagram. The factory amplifier is behind the glove compartment on the right. Just open the glove compartment, push in the right side so it swings down (take things out of it first), and the amp is right there.
2000 Suburban Wiring Diagram
(It's for the '00 Suburban/Tahoe, but the wiring did not change from '00-'03.)

Feb 19, 2009 | Clarion VRX745VD Car DVD Player

3 Answers

2000 Ford Mustang Convertible Slow Top Opening


My 2000 Mustang convertible has a noise and leaks fluid where could i go to fix it

Jul 09, 2008 | 2000 Ford Mustang

1 Answer

No sound


It's very likely that you have a factory amplifier in the vehicle that needs to be either turned on or (preferably) bypassed to get sound to the speakers. If your vehicle is a Mustang, it's almost certain that you have a factory amp. If the factory plug includes a long, 8-pin gray plug and a small, square 8-pin plug connected to a round cable, then the amp turn-on wire is at the opposite end of the gray plug from the constant power wire. This needs to be connected to the blue/white wire on the Sony head unit for the factory amp to turn on. Otherwise, if you dig into the radio cavity a little bit, you'll find a black 8-pin connector that looks very similar to the gray connector at the back of the radio. The black connector pins are connected directly to the speakers, bypassing the factory amp.

Mar 15, 2007 | Sony CDX-2250 CD Changer

Not finding what you are looking for?
Car Audio & Video Logo

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Metra Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

yadayada
yadayada

Level 3 Expert

75077 Answers

Jason

Level 2 Expert

211 Answers

Are you a Metra Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...