Question about Kenmore 85920 PowerSpin Upright Wet/Dry Vacuum

1 Answer

No suction in hose or base in Kenmore Powerspin. Shampooed whole living room and not one drop of water in dirty water container.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

No suction in hose or base in Kenmore Powerspin

Posted on Jul 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hose does not dispense cleaning solution, and the cleaner solution will immediately go down to the dirty water tank. It can suction, though. Any tips?


sounds to me as if you have calcium deposits from hard water.

Take your cleaner solution reservoir and fill it with Vinegar and Hot water. Place your machine in a dry bathtub and run it until the tank is empty. Do this a couple times. When it works properly run some clear water through.

Mar 19, 2013 | Kenmore 85930 PowerSpin Deluxe Upright...

1 Answer

Won't **** up the water


Check for clogged hose and remove the filter and run water thru it in reverse to flush out blockage.

Oct 19, 2010 | Kenmore 85920 PowerSpin Upright Wet/Dry...

1 Answer

No suction from base


Hi, if the recovery tank lid has a foam filter make sure that it has at least a 1/4 inch gap to the top. Also did the lid lock down al around the tank? One other thing is turn it over, and you see a red frame near where the brush block is, that is a filter, pull it out far enough to clean it off.

Take care

May 31, 2010 | Kenmore 85920 PowerSpin Upright Wet/Dry...

2 Answers

Loss of suction


You may have a colg in the power nozzle of hose. Disconnect the hose and drop a quarter through it.

Bob
http://evacuumstore.com/

Mar 27, 2010 | Kenmore Progressive 35922 Bagged Upright...

1 Answer

Rug cleaner is actually BLOWING out instead of sucking up!!!!


Clyde,make sure your hose is attached to suction side of vacuum. If over full or over full of bubbles in the waste section of vacuum this can happen or if the vacuum itself has become plugged possibly.

Oct 04, 2008 | Kenmore 85930 PowerSpin Deluxe Upright...

1 Answer

Hoover steam vac


I had the same problem just before the impeller broke. Lower the handle and check the hose connection at the bottom is not broken. Turn the unit on with the handle down, then check the suction on the accessory hose, leae it disconnected. Take off the bottom container, and check the suction on the round intake tube (lower one towards the front), with the handle up and with the handle down. If the suction increases dramatically when the handle is lowered, the impeller is probably in it's self-destruct stage. (same as mine). Soon the impeller will break off, and BINGO no suction at all.

Good luck!

Jun 25, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

2 Answers

Bissell lift off pet-no suction through base (hose is fine)


I had a similar problem with mine. When you take the collector container out, if you reach your hand up, you will fill a round, plastic piece. Gently turn it and the piece pulls out. On the outside of the piece is a foam filter that may be plugged. There is another filter underneath the collection container in a pull-out drawer. Both filters can be washed with cool water, allowed to dry totally, then replaced. I understand that both of these filters need to be washed "frequently". It worked for me, hope it works for you.

May 08, 2008 | Bissell 37604 Lift-Off Pet Bagless Upright...

1 Answer

Not sucking up dirty water


The F5914 has a lid that must be engaged with the tank in order for the suction to reach the floor. Gently lift the front of the lid on the tank and if it lifts up, you haven't engaged the two tabs on the tank into the lid. Remove the lid and make sure the tabs on the tank fit into the grooves on the lid and snap it closed. This should solve your problem. Also, make sure that the removable duct in the front of the tank is in place. It is removed when the hose is used, but must be replaced when the machine is used on the carpet.

Feb 01, 2008 | Hoover SteamVac F5914-900 SpinScrub...

2 Answers

It is not sucking up all the water


I've had this happen to my SteamVac V2 and usually find that it's because I don't have the dirty water tank locked down well or I haven't pushed the hand attachment flap in tight or its gotten clogged up down in the suction area. I have a black lab and that area accumulates dog hair quickly. I use a Zip-it available at Lowe's or on the web to clean that out.

Sep 18, 2007 | Hoover F7205900 SteamVac V2 Wet/Dry Vacuum

Not finding what you are looking for?
Kenmore 85920 PowerSpin Upright Wet/Dry Vacuum Logo

Related Topics:

528 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

75077 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...