Question about Jensen MP5720 CD Player

1 Answer

No sound through speakers

It appears that all the lights and workings on the face plate are working. No sound coming out of any of my speakers. I have removed head deck and all wires are still attached. Also no sound when using disc player.

Posted by on

  • Thirsty Merc Sep 22, 2007

    Thank you for your assistance, the problem is now solved.



1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    An expert who has answered 20 questions.

  • Expert
  • 41 Answers

What type of vehicle is it in? Is there a blue/white wire connected?

Posted on Sep 21, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Protect appear

There is a reset button on the front of the face plate buy the buttons for changeing your radio sations.It is right beside the last button on the right side of the face plate.Take a pin or something with a point on it, To push the reset button in with, Hold it for a couple of seconds,Then it will come back on.There is no code to unlock it, Only if you put a code into it .(But) before you do this (Check) That no speaker (Wires) Come off from the (Speakers) or from the deck some where. If a wire come off make shure to put it back on (Properly) Before you reset it. It can allso go into the protect mode if your car is hit in a (Accident)

Oct 19, 2012 | Kenwood Car Audio & Video

1 Answer

Radio/CD player has power -gets no sound

unplug the radio harness and check for ground on all the speaker lead's. if there is ground on a speaker wire then there is a problem on that particular speaker and if you disconnect all the other speaker should work if not then i would assume the actual unit is defective

Jun 06, 2010 | iLO XM-MP3-CD Car Stereo

1 Answer


If this unit worked in the past, and there have been no repairs done that would have disturbed the connections, then its quite possible that you accidentally engaged the mute feature. 
Good luck...


1 Answer

Light out on toyota Sienna radio

FIXED MINE! My 2000 Sienna XLE had the same problem with the lights not working. They would flicker on once in a while. I took off the face plate, cleaned the radio with a "can of air" to remove any dust, put electrical grease on the face plate contacts and the plugs on the back of the radio. Reassembled and the lights worked better, but dim and flickered off a bit. Knocked on it a few times on the side to get those contacts to work better and it is now working. My guess is the contacts on the faceplate were not making good contact. If I had to do it again, I would pull on and off the face plate a few times after installing the electrical grease to help loosen up any corrosion for a better connection. That would probably eliminate the need to beat on the side of the radio after reassembling. This fixed mine. Hope it works for you.

Dec 08, 2008 | 2000 Toyota 4Runner

2 Answers

Z2300 satellite disassemble

1. Remove the black face screen. 2. The 4 holes on the satellite that hold the face screen on have a rubber stopper in each.  Pop those out with a screw driver.  There are now 4 screws to take out. 3. The front silver face plate is now only held on by glue.  Take a hair drier around the edges to soften the glue, then carefully pry the front face plate off, being careful not to damage it (I pried it from the bottom so any damage wouldn't be noticed).
Note: the 3 screws on the bottom have nothing to do with removing the face plate.

Sep 28, 2008 | Logitech Z-2300 Computer Speakers

1 Answer

No sound

you simply have a speaker shorting in your car. Either an old speaker with a bad voice coil (short) or a speaker who's contact(s) are touching metal. This type of short or grounding will cause the internal audio amplifier to shut off to protect the radio's output circuit. To diagnose which speaker is the culprit, you'll need to disconnect all speaker leads from the radio and one by one re-connect them until the output shuts down again. The safe way to check is with a voltmeter. If you connect one side of your voltmeter to ground and test each speaker wire lead for continuity, you'll hear an audible "beep" whe you find the grounded wire/contact. A professional car audio shop can diagnose this for you if you're still having difficulty. Hope this information was helpful.

Sep 28, 2008 | Pioneer DEH-1800 CD Player

1 Answer

Radio and cd player stoped working suddenly

the security on the radio has been tripped you need to take it to a GM dealer and have them run a code to unlock it CAL means calibrate 

Jul 04, 2008 | 2001 Chevrolet Monte Carlo

1 Answer

No sound

It could be that the wires in the harness that go to speaker from stereo are not connecting to the leads on the stereo. If this is the case the wires to speakers are not connecting, but the wires from the power source are still good. Try taking the harness out of the back of the stereo that connects all the wires to the leads. Hopefully your wiring is labeled from the factory. If it is it might say "Left front speaker". Isolate this wire and wiggle it inside the harness back and forth. If it moves even a 1/16 of an inch it may be that the leads are not connecting. You can try jerryrigging it by shoving something in their in hopes that it will hold it in place. You may need to replace the harness.

Nov 07, 2007 | Jensen MP5720 CD Player

1 Answer

Same Prolbem as the other guy

Do you get sound when you use the radio? If so, the blue wire from the back of the radio needs to be disconnected and you need to use the blue/white wire instead.

If that doesn't work, try connecting either a test speaker or one speaker at a time. Your problem could be a short in the wiring - if the (+) wire to a speaker is touching the (-) wire, the deck will cut out all sound to keep itself from overheating. Let me know if you need more help.

Oct 12, 2007 | Jensen MP5720 CD Player

Not finding what you are looking for?
Jensen MP5720 CD Player Logo

Related Topics:

113 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jensen Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4905 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

The Knight
The Knight

Level 3 Expert

74999 Answers

Are you a Jensen Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides