Question about Alpine MRD-M501 Car Audio Amplifier

1 Answer

Alpine mrd-m501 mono power amplifier

I dont know what is wrong with this amp there is no power light even turning on i have power coming from my batt i put a new remote wire on and the groud is good there are no signs of any kind that would tell me that the amp is fried fuses are good actualy taking them of was hard and it was like there was a factory seal couse they sounded like they have never bin takin off if you could trie and figure out what my problem is that would be so apriciated thank you so much for your tome

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,139 Answers

OK, It looks like you may have an internal problem. I must say from the begining if you do not have a background in electronics take the unit to a qualified service center. Now it sounds like you could have a power supply problem if you have power coming in onpen the unit and with the use of a schematic find the main voltage rail and test from there each test point and make sure it matches the schematic value. Look for burnt circuit tarces nad if you find the remove them and jumper with re-trace wire.

Posted on Sep 16, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

WORKED ON MY 1997 CADILLAC DEVILLE LEFT DOORS OPEN NOW FLAT DEAD! EVEN AFTER CHARGING BATTERY


Power or grounding problem . Do you know how to use a power distribution diagram to test electrical flow in the vehicle . How to use a DVOM - digital volt ohm meter ? Free wiring diagrams here http://www.bbbind.com/free_tsb.html
Basic Electricity for Service Techs Ohm law Current Flow Opens Shorts
How to Use Multimeter to Troubleshoot Common Problems
check main powers , do you know were inside fuse boxes are ?right hand an left hand . You may have blown a main fuse or fusible link et..... If I had to guess you probably blew BATT 1 or BATT 2 fuse's in the right hand fuse box .

Apr 19, 2017 | Cadillac Cars & Trucks

1 Answer

My amp doesn't turn on but all wires are plugged in. I tested it right before I bought it, it's grounded to a bolt in the chasis. What could be wrong?


If you have a voltmeter or a 12V trouble light, check to see there is 12V at the remote terminal when everything is on. The remote wire coming out of the head unit cant supply a lot of current (usually around 1/2 amp). even a quick short to ground on the remote wire can render it useless.

Jan 30, 2013 | Rockford Fosgate Punch P5002 Car Audio...

3 Answers

I have this hooked up and works fine with the key on, but when i start the car, sub light, amp and sub dont come on.


You have connected it to the wrong power wire - one that is only active in service mode - first key position.
You should draw a wire directly from the battery (don't forget to add a 40 amps fuse on the wire) to the amps. If you don't want them constantly operational (you will have to manually shut them down) install a relay on the wire with the command coming from a wire from the instrument key position - second position of the key. Use a voltmeter to identify the wires.

Oct 15, 2010 | Rockford Fosgate Power 351M Car Audio...

1 Answer

I bought a amp lazar vibe225 when i hooked it up it works fine it when i turn my car of that the lights wont go off i got 2 12in dual spearker the blue light up kind bp1204 and i wired it from the amp...


In most vehicles, the speaker wires have 6v of DC on them. That could be part of the problem. You need to use an LOC (Line Output Converter). You should be able to get one from Wal-Mart, Radio Shack or any car stereo shop.

Nov 17, 2009 | Car Audio & Video

1 Answer

Older sony explod amp worked fine in car took out sat 4 monthes put in truck will no turn on ground power and remote ok indicator light does not come on


Put any bit of wire from the remote to the power of the amp. Then put a bit of wire to the + of your car batt and a bit of wire to the + terminal on your amp.....then put a bit of wire from the - of your car batt to the _ of your amp'....... The light should come on as you have bridged it, this showing it still works.....if not then its new amp time!!


Sometimes helps with 2 people doing this as one can hold the amp near the car batt' or if its just you place the amp on the engine, somewhere safe!!

Aug 28, 2009 | Sony XM-D400P5 Car Audio Amplifier

2 Answers

How do i turn on sub mode?


For one thing I hope you know you need an amp to even power subs at all.. The remote wire coming off the rca wiring that you hook your subs up with has to go on the prong 3-in on the top here is a rough diagram: the = signs are power and ground and the prongs are thicker the comma is you remote..
- - - - - - - , - =
- - - - - - - - - =

You need a wire coming out of that slot on the wiring harness.. it should be blue. and unless you have a power antenna(comes out when you turn your radio on) then you dont need the blue/blue&white power ant. wire you can just cut it and cap it. if your amp isn't coming on when you turn your ignition to acc then your remote wire isn't properly attached..

May 15, 2008 | Pioneer DEH-P4700MP CD Player

2 Answers

No audio-amp protect light come on then went


You need to check the DC voltage across the B+ and ground terminals. You also need to check the DC voltage across the remote and ground terminals. If the voltage is less than 11 volts, you need to check the B+ supply and remote wiring for breaks or open fuses. You should also check the ground connection to confirm that it's not loose.

 

If the voltage is OK, the output transistors are likely shorted.

Oct 21, 2007 | JBL GTO75.2 Car Audio Amplifier

2 Answers

Whats wrong??


you should check the remote wire bc you will get power to your amps if its not hooked up but you wont get any music!

Aug 22, 2007 | Bazooka ELA300.1 Car Audio Amplifier

1 Answer

Ok....well i dont exactly know why my equalizer isnt turning on......


if you have an amp in your truck,try and use the same remote wire that runs from your head unit to the amp.

Aug 05, 2007 | American Pro VS-1466 Car Equalizer

1 Answer

Blown amp


hi, try connecting the power b+ and gnd and remote turn on cables only (dont connect rca input or any spks), if amp doesnt turn on you will have to take in for repair. no need to buy new amp, coz problem could be a burnt pcb track or even a faulty remote or FET circuit.if amp turns on then connect other cables slowly and monitor the power lite as you do connections. you may have a faulty spk load that will cause amp to stay off or in protection mode. cheers

Jul 22, 2007 | Kenwood KAC-7202 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRD-M501 Car Audio Amplifier Logo

Related Topics:

115 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5013 Answers

Jaime Hernandez

Level 3 Expert

2337 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8841 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...