Question about Alpine MRV-1507 Car Audio Amplifier

1 Answer

I get no power light or any sign of life at all...checked the fuse, it is fine. This is an old used amp I just aquired and I was wondering if the problem might be something simple or is the amp most likely dead??

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 578 Answers

If you have all power check the signal to amp from rca if you do all that and stiil the same possibility am p done its days;lolo

Posted on Jun 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sanyo DP26640 has no power at all. It worked well for a little over a year and was plugged in with a playstation in the same outlet. No problems with the playstation. Wondering if buying a power boar


If there's no sign of life at all, the power supply is probably dead. It may be something as simple as a blown fuse but not all of those are replaceable. If you're comfortable around electronics, you could open it up, check the fuses (there are usually two or three), and replace the bad one (probably the main power fuse) if you find one. If you're not comfortable around electronics, or can't find a bad fuse, you should try to find a TV repair shop if they even exist anymore.

Hope this is helpful! Good Luck!

Nov 18, 2014 | Sanyo Televison & Video

1 Answer

When I plug the battery in for charging, the charge light does not come on. only the power light on the charger


There are several solutions to this problem which I have seen twice in my technical career.
You indicated that the power light on the charger comes on which indicates it is plugged into a working AC wall outlet. Check to make sure the power switch of the charger is turned on. Make sure that the round charger plug is plugged all the way into the battery charger receptacle on the battery box.
Next, check the on-board fuse AND the circuit breaker. I have had this little 5 Amp automotive style fuse burn out on several go go's and the charger does not work. Pull back the cover over the charger port and look for the fuse in its center slot. With a good set of fingernails it can be pulled straight out and inspected. Use fine needle nose pliers if necessary. I am assuming the go go runs and the push-button for the 15 Amp circuit breaker is pushed in. If it is out and the go go is not running reset the breaker by pushing the white button in. There is a clear rubber boot over the button. In my experience, the 5 amp auto fuse is your most likely problem. By holding it up to the light you can see if the fuse wire inside is burnt causing an open circuit. Most auto and hardware stores have this fuse in stock. Bring the old one to the store for comparison. It is a 5 Amp ATO fuse.
The question my clients often ask is what caused the charger circuit to overheat and the fuse to blow? The simple answer is that the two 12 Amp hour batteries in the go go are probably old and weak. This causes the charger to work too hard and the circuit to overheat and the fuse to blow. These small batteries have a short life span of between 6 months and 1 year depending on type. I recommend the AGM (advanced glass mat) batteries for longevity. Also make sure the charger being used on the chair is the 2 Amp small charger that came with the chair (There is a label on the charger to verify this). A larger charger will burn the batteries(shortening their life) and burn out the 5 Amp on-board fuse. Hope this helps.

Oct 31, 2010 | Pride Mobility Products Go Go Ultra X 3...

2 Answers

FUSE IS GOOD BATTERY HAS LIFE BRAKE LIGHT IS ON. YAMAHA BWS 2004


Yes instrument lights at least should come on.
Power goes from the battery to the ignition switch via the main fuse, & then splits to ignition & lights (via auxiliary fuses if present) which are separate circuits.
The problem could be an auxiliary fuse (if fitted) then contacts inside the ignition switch or wiring/connections from the ignition switch out to the ignition circuit
That is presuming the cluster light bulbs work!

Hope this helps ( if so please mark as very helpful)
Ride Safe
Bike-Doc

Apr 15, 2010 | 2005 Yamaha DT 125 X

1 Answer

Appears to have no power. Will not power up, with or without bat


Here's a list of things you can check:
1) Power Supply
2) Battery

I would definately check these things first. Are you still under Warranty? Either way, it's a good idea to contact the Toshiba Support Hotline. Here's the link:
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=SB&os=&category=&moid=1596141&rpn=PSAD6U&modelFilter=A135-S2276&selCategory=3&selFamily=1073768663
GOOD LUCK!! Lucky4lynn2 P.S. please rate me k?

Mar 14, 2010 | Toshiba Satellite A135-S2276 Notebook

1 Answer

No power but car cranks -2002 Oldsmobile Intrigue 250,000KM - Not sure if related but the car just sat for 10 days when I was on Vacation. It started firt time this morning no problem, I put on the heated...


The check engine light is interesting considering everything else is out. I would go to the fuse panels and trace power to the ignition switch. Other than the check engine light, this seems to be most likely.

Dec 02, 2009 | 2002 Oldsmobile Intrigue

1 Answer

Tv won't turn on


I assume you do not have any red light showing on the front of the TV to indicate it is receiving power? Again assuming the your mains electric supply is functioning & the fuse in the TV plug is ok, if there are no signs of life & then most likely a fuse in the power supply may have blown. If you have a multimeter you could remove the rear of the TV & check the fuses in the power supply, if these are ok then you will need to check any supply voltages coming from the power board. If one of the fuses are open circuit, check some of the doides or transistors for any short circuits. If you are not comfortable doing this, then it would be advisible to contact a repair service centre.

Jul 28, 2009 | Televison & Video

1 Answer

Nespresso aeroccino


if it was working fine before wiggle the power cord at the wall observe the machine for any sing of life lot of time is just the plug on the wall if not open the machine follow the power cord inside the wire inside check for power with a little tester fuses should be beside it cheers

Jan 27, 2008 | DeLonghi Caffe Parma Espresso Machine

2 Answers

Aiwa AV-D58 wont power on


this happened with mine two. all i did was press powert and enter at the same time and it clicked for like 2 hours or so and then it turned on. it was cool

Dec 09, 2007 | Aiwa AV-D58 Receiver

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

73 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Jaime Hernandez

Level 3 Expert

2315 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...