Question about Bissell 37604 Lift-Off Pet Bagless Upright / Canister Vacuum CleanerVacuum

1 Answer

No suction I have the 3760-4 and have no suction. Does it need an o-ring. Good suction in machine but none outside at hose

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 61 Answers

The simple solution would be a clog in or leading to the hose. Unless you here a air leak it does not need a new o ring. If there is no clog then you need to take it to your local vac shop for repair.

Posted on Apr 16, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is my henry vacuum cleaner not working motor running but no suction ?


Hi I will try to guide you though this problem.
When you switch it on do you get air blown out of the vent on the machine housing.if not there may be a blockage.
if you take the hose off, do you have suction on the main body.
if so pipe is blocked.
if no suction then, do you have a bag in it. If so remove the bag and reassemble and try again.
there should also be a sealing ring with a fabric on it between the motor head and the body, is this very dirty or missing.
if none of the above works then I would assume that the fan is adrift on the motor.
i would advise a qualified person investigates further as risk of electric shock if you dismantle the advice.
please let me know how you get on.

Sep 09, 2014 | Henry Numatic "" Canister Vacuum

1 Answer

No suction from canister on electrolux guardian model c154e. green light on switch is on


Have you remove the hose and checked the suction at the intake of the vacuum? If the motor is running there will be suction.
If there's suction here, attach the hose to the vacuum, turn it on, and check the end of the hose for suction. If there is none or very little, there's a clog or bad leak in the hose. The easiest way to check for a clog is to drop a coin in one end, lift that end up allowing the coin to drop through to the other end and out. If it drops through, the hose is clear. If not, the easiest way to clear it is to plug the hose in to the exhaust port of the vacuum, place the other end into a large garbage bag or point it outside, and turn on the vacuum. This will usually clear a blockage.
Leaks that are severe enough to result in no suction will be readily apparent as tears, cracks, or cuts in the hose. A crushed hose will also result in the loss of suction.
If suction is fine at the end of the hose, do a visual check of the wands. It's unusual for them to be blocked, but not impossible.
Check the power nozzle above and behind the brush and where it attaches to the wand. The elbow can catch long objects resulting in a blockage.
If there don't appear to be any problems with the above mentioned items, you need to take the vacuum, with attachments, to a repair shop to have it checked. It may need a new motor, but that would be due to worn out or broken fans, and that is unlikely with Electrolux vacuum motors years older than that.

Dec 01, 2013 | Electrolux Guardian Bagged Canister Vacuum

1 Answer

I need help finding out why there is no suction with my hoover. The brushes are spinning and the windtunnel looks active but no suction either on floor or hose.


What model ? If there is suction from the end of the hose there could still be none to the floor. You may have a clog between where the hose connects to the nozzle and the intake behind the brushroll.
Turn the machine on and listen for a change in pitch of the motor when you disconnect the hose, verses having it attched to the nozzle.

Oct 20, 2013 | Hoover Vacuums

1 Answer

My attachments tool has no suction. I made sure I have selected tools and I cleaned the lint filter. There is definitely suction in the machine, but it does not come through the attachments hose.


Check the attachment hose for any hindrances like clogged with dirt or object. Also a big hole cracks in hoses will cause suction to divert it outside. Clean the machine to make sure it will provide suction powerfully. Regularly clean it and you will assure it's will perform better.
Thanks for asking.

Jul 17, 2011 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

MY BISSELL SEEMS TO HAVE THE SAME PROBLEM AS EVERYONE ELSE - NONE WHICH TO MY KNOWLEDGE HAVE BEEN RESOLVED. MY MACHINE WILL DESPENSE BUT NOT SUCTION - WHAT GIVES WITH BISSELL -IT THIS AN ONGOING PROBLEM


Please check the following:


First check the motor duct gasket. The motor duct gasket is visible once the tank is removed. It is located underneath the handle on the top of the base of the machine. It has a black rubber coating around it. If there is no suction there please let us know. If your machine does have suction at the duct, continue to check the following:


- Ensure the Ready Tools Dial is set to the appropriate setting (Floor Cleaning or Hose Attachments).
- Remove the tank from the machine and ensure the tank lid is attached properly. The front window must first hook onto the lip of the bottom of the tank and then drape over the tank. Latch the bottom tank to the top tank lid. THIS LID CANNOT BE ATTACHED PROPERLY IF THE TANK IS NOT REMOVED FROM THE MACHINE.
- Make sure the Water Tank is not full on the outside of the bladder. If it is, empty the tank.
- Ensure the hose is firmly attached to the back of the machine. If not, re-insert as necessary by twisting into place.
- The machine must be in an upright, locked position and set to the Hose Attachment setting. If the handle is slightly tilted back while using, it will create a small gap at the suction inlet (where handle meets gasket, above the Bottom Tank) which will cause little or no suction.
- Check the red Tank Lint Screen for debris. If the Lint Screen is dirty, the unit will have poor suction. Clean the Lint Screen if necessary.
- If the float flap door in the tank lid is activating prematurely when you turn the machine on, this flap door should be replaced. This tank may need to be emptied.
- Check the Tank Lid and Tank for damage.


If you continue to experience low suction contact BISSELL Consumer Services at ...

1-800-237-7691
Mon-Fri: 8am to 10pm ET
Sat: 9am to 8pm ET

Aug 16, 2010 | Bissell 9200 Upright Vacuum

1 Answer

No suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Euro-Pro EP602 Bagless Stick Cyclonic...

2 Answers

My vacuum tools have very weak suction.


There is a foam ring filter in the bottom of the canister that collects the dirt. It screws off of the bottom on the canister. Take outside and shake it out. It fixed our suction problem.

Jan 31, 2010 | Bissell 3576 CleanView II Bagless Upright...

1 Answer

Loss of suction


There is a blockage . Check the small hose under the sole plate

Feb 01, 2009 | Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

No suction or very little


Make sure you have a good bag installed in the vacuum and the door is properly in place. Remove the attachment hose from the bag chamber and turn the machine on. You should have good suction coming from the hose inlet. If you don't you have a problem in the bag chamber. Bad bag, door is not on correct, door is defective, dirty secondary filter.

Connect the hose back to the machine and pull the other end out from the bottom, and turn the machine on. You should have good suction there. If you don't you have a clog or hole in the attachment hose and it needs to be unclogged or relplaced.

Reconnect the to the bottom. Flip the mahine upside down. Take the screws out of the bottom plate and remove. Remove the brushroller and belt. Turn the machine on and you should have suction at the inlet coming off the brushhousing. It you don't, then you have a clog in the nozzle hose and it needs to be removed. It will probably be more accessable from the bottom side since that is the way that it entered.

Sometimes a suction problem can be confused with an brush problem. The belts on that machine should be replaced every 6 to 8 months because they will strentch and wear. This is an inexpensive maitainance that will dramatically improve its function. Part Numbers are 38528-035 and 38528-034

Nov 21, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Hose Collapses When I Try to Use Wand


Hi Both.

Ok you have A blockage, Remove flexi hose completly from rear of machine & completly remove wand & handle from the hose.

Now check flexi hose for obstruction if none present move on to the wand & hanndle look down through tha wand for any obstruction look very carefully where the plastic handle meets alloy tube there is A slight bend here often A coin gets stuck here & flips accross to block oppening when you try to use wand.

If you cant see anything coin etc put hose back on machine & switch on there should be good suction from the flexi hose,
Now with machine still switched on push alloy pipe back on if the hose suddenly pulls back & there is poor or no suction you definately have A coin stuck at the bend.

You will need A broom handle or other long solid pole to hit it out.
http://dysonmanuals.llc.nu/

Aug 03, 2008 | Dyson DC17 Animal Bagless Upright Cyclonic...

Not finding what you are looking for?
Bissell 37604 Lift-Off Pet Bagless Upright / Canister Vacuum CleanerVacuum Logo

Related Topics:

171 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

Brad Brown

Level 3 Expert

16026 Answers

Jim Thurston

Level 3 Expert

670 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...