Question about Kenwood Excelon KAC-X521 Car Audio Amplifier

1 Answer

MY kenwood amp is reading E-03 any solution to that

My amp is flashing a red light the fan stop and then i unpluged everything and then wired everything back together and it jus flashes a red light and and sign called E-03

My amp is flashing e-03 messege i checked all the wires to see if they are grounded in any way. i rewired the whole system and it seems to go out whenever i turn up the volume. i dont know if its my speakers that are blown or my amp is messed up,

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 578 Answers

Check speaker and power source

Posted on Aug 07, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a fisher & paykel active smart fridge the fridge part freezes everything and wont stop beeping when door open


Your fridge is telling you there is a fault, i'd say one of the 2 fans are not working. If everything is freezing in the bottom of the food compartment then the upper fan is faulty. You have to remove the shelves & remove the rear panel, the fan is in the shute at the bottom, remove, repair the broken wire or replace. Make sure unit is unpluged.

Aug 10, 2014 | Fisher and Paykel Active Smart E522B...

1 Answer

When i turn my Kenwood excelon kac-x811d the red light flashes and it shows a error 03 code


This indicates a short somewhere in the speaker wires according to the manual. Check connections at the harness of the deck (if you are powering the speakers from the deck) for shorts, or if there are no connections ensure that the loose wires are taped off to prevent shorting (touching other wires, or metal). If you are using an external amplifier you can shut the internal amp off in the deck as well (This will improve the deck's performance).

Nov 01, 2013 | Car Audio & Video

2 Answers

Red Light


that means you probably have a shorted speaker wire, a bad speaker or the amp itself is bad, try disconnecting the speakers one at a time and see if it turns on or not. if the red light stays on with no speakers hooked up it means the amp is bad

May 30, 2009 | Kenwood KAC-7252 Car Audio Amplifier

1 Answer

Amp promblem


i have a Kenwood KAC-X812D amp and a alpine SWR- 1242D Subwoofer in a sealed box. What is the best setting i should do for this amp. HEADUNIT KDC- X592

Apr 21, 2009 | Car Audio & Video

1 Answer

Kenwood kac-x1r flashes code e-03


HI DUDE EVERY REMOTE WIRE THEY HAVE FUSE NEAR THE BACK OF PLAYER TRY TO CHANGE IT .... R...TRY UNPLUG UR AMP .. AND ..FIX IT BACK

Apr 16, 2009 | Kenwood KAC-X1R Car Audio Amplifier

1 Answer

Amp Problems


Unplug the stereo input signal from the amp. If the amp does not do it with the wires unplugged, you may have a problem with the radio sending too much voltage to the input of your amp causing it to go into protect mode. If it continues it is in your power source to the units. Let me know and I'll see what Ii can do. Hope this helps...

Jul 14, 2008 | Kenwood KAC-859 Car Audio Amplifier

2 Answers

Kenwood kac 859 amp


hi, note that if you are not using the proper gauge b+ and gnd cable with this amp then the current available at the amp wont be sufficint to keep amp on. also try using this amp while vehicle is idling. if this doesnt work then disconnect all spks from amp and check if red lite stops flashing. if it doesnt stop flashing then amp has internal fault. if lite stays on brite then proceed to check each spk load impedance, then reconnect each spk individually. the minute red lite starts flashing it will give you a clue that the channel or spk load is faulty. cheers

Jul 27, 2007 | Kenwood KAC-859 Car Audio Amplifier

Not finding what you are looking for?
Kenwood Excelon KAC-X521 Car Audio Amplifier Logo

311 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4861 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8269 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...