Question about Kenwood 1000W Class D Bridgeable Mono Amplifier with Variable Crossover - Black/Blue

1 Answer

Amp Turns off after 30 seconds of song play

Just got done hooking up my 1000 watt amp in my car and hooked up the sub. it played like 20-30 seconds through the fist song, then when i switched the song the amp went out. Continious problem. It would work again once i unhook the power cable and hook it back up for the 30 secs.

Solutions?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

Since the unit recovers once it has powered down. I suspect that the internal protection circuit is kicking in. Check the wiring and be sure that there are no crossed wires anywhere. These amps are designed to work with 2 ohm loads and can take a direct short for a short period of time. If the wires appear ok, measure the speakers with an ohm meter. If the speakers are 4 ohm rated, they should measure just under 3 ohms with the meter, If they measure less than 2 ohms, there is a problem with the speakers.

Also, does the amp shutdown regardless of the volume level or just when played loud?

Thanks,
Dan

Posted on Apr 15, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I was given a subwoofer and box but do not know where to go from here in terms of hooking it up in my car. It is a Rockford fosgate punch p112s4.


First youll need an amp. Depending on what size the sub is a 500 watt rms amp can hold up to about a 300 watt kicker. If your looking for something bigger u can get a 1000 watt amp and hook up two 300 watt kickers. To hook up the amp youll need a car amp power cable, power control cable, speaker wire, amd a car amp ground wire. They usually sell kits that run aboyt 40 bucks. The power cable goes to the batter as well as the ground cable. The power control cable goes to the back of the head unit. (You will kost likely need a more modern headunit if urs is stock). Once this is done put the sub in the box (i recomend super glue because metal nails take away from the bass). Put the speaker wire to the speaker positive on left negative on right. Same with the amp. And now ur bumpin ;)

May 06, 2013 | Car Audio & Video

1 Answer

My amp won't play bass everything is hooked up


I have a similar problem with my 2012 civic, I hooked up my 1800w kenwood mp to my 2 12" w6s and 1 song plays and sounds great, the rest of my songs have no bass from the subs, just the car speakers sound normal so I dont know what the hell thats all about. I thought it was a wiring issue but I can play the one song all day and it sounds perfect so any suggestions? thanks in advance

Jan 29, 2012 | Sony Car Audio & Video

1 Answer

Amp burned out but fuses still good?


this is caused by inproper wiring from the speakers/subs to the amplifier.. an amp will still put out power to subs and speakers when it's wired improperly but it won't last for very long doing it... 6 months is longer than usual....

Dec 05, 2009 | MA Audio M1900XE Car Amp

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Audio & Video

1 Answer

Amp Turns off after 30 seconds of song play.


Check your ground and make sure it is grounded to metal in your car with no paint. Also, make sure you are running 4 gauge power wire. Another possible cause could be that the ohm load is too low on the amp. Also, if your car battery drops below 10v it will send the amp into protection.

Apr 15, 2009 | Kenwood KAC-8103D Car Audio Amplifier

1 Answer

SUBS NOT PLAYING THROUGH AMP


There is an otion to turn sub output on/off in the "audio menu". Hit " in lower left to turn sub out put on.

Mar 17, 2009 | Xtreme Sound WMS336 CD Player

1 Answer

Crunch amplifier


there is a bad ground or some other wiring issue in your car you will have to re wire all new to find it unfortunately

Dec 12, 2008 | Kicker KX600.1 Car Audio Amplifier

1 Answer

High distortion


The head unit may be rated at 200 watts but it cannot produce more than ~20 watts of real power per channel. There's no way that it can drive the high end speakers to a level that will be needed to compete with the subs on a 1000 watt amplifier.

Apr 18, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

Not finding what you are looking for?
Kenwood 1000W Class D Bridgeable Mono Amplifier with Variable Crossover - Black/Blue Logo

Related Topics:

249 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5126 Answers

Eddie Dalton
Eddie Dalton

Level 2 Expert

53 Answers

Henry  Thomas
Henry Thomas

Level 3 Expert

1074 Answers

Are you a Kenwood Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...