Question about ECS C51GM-M Motherboard

3 Answers

C51gm m my machine beeps, slow and steady. and it will not boot, no screen.

Posted by on

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: c51gm m

I had this problem. It was a continuous series of slow beeps. It was a memory problem. I swapped the memory and the system booted.

Posted on Nov 10, 2007

Re: c51gm m - ECS C51GM-M Motherboard Motherboards

Problem now solved. Thanks all

Posted on Sep 16, 2007

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 150 Answers
Re: c51gm m

Those beeps indicate some tip of a hardware problem. You said it's new so did you properly set up the jumpers on your board for the hardware your are using? Check the manual that came with that board it will give you more details.

Posted on Sep 13, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Screen shows antenna with an X and beeps

what type of bios do you have and when you turn on the machine how many beeps are they and are they short beeps or long beeps mixed up beeps fast beeps or slow beeps need more information please.

Feb 23, 2015 | Motherboards

1 Answer

I have a c51gm-m Motherboard and it does not recognize my full ddr2 2x1 667mhz only half . i want to change them with 2x2gb 800mhz but i only get 2 beeps when i boot i already did a bios update and...

Hi, you can download a manual here:

Here is some more info:

I think one of the ram modules is defect.
Set the bios setting to auto for the ram and let it handle it itself.
It has to work together with the cpu. Maybe the cpu does not
supports 800 mhz.
Read all about that in the manual.

Sep 01, 2011 | EliteGroup C51GM-M Motherboard

1 Answer

K7SOM has a series of beeps that are steady..No display.

If it is a long steady beeps , then it could be a problem with the memory.
try reseating the memory,try swapping the memory slots.try to boot the system with individual memory by doing this we will come to know whether the memory slot or the memory itself is gone faulty or not.
most of the cases reseating the memory will fix the issue.

Jan 03, 2011 | EliteGroup K7SOM Motherboard

1 Answer

Hey who ever this is im having bad problems with my motherboard or my bios ive tried everything i got ECS C51GM motherboard with the 6100 nvidia video display. icant run any full screen programs cause it...

Its not a bios problem but on insertion of video card your ram got some tampered. Just reinsert the video card and your ram properly and now start your system. It might solve your problem.

May 20, 2010 | ECS C51GM-M Motherboard

1 Answer

Long beep and continues on power on when moved to

Make sure motherboard don't touch the cabinet.
Reattach the RAM memory.
Open processor fan and processor Then reattach both.
Reattach pci card or vga card if any installed.
Then check.
Let me know if you need further assistance.
Thanks for using FixYa.

Apr 03, 2010 | ECS C51GM-M Motherboard

1 Answer

Problem booting into Windows.

This could be a hard drive problem. The hard drive is looking for the boot sector on it, but the boot sector is broken. Computer shuts down and tries again but your hard drive can't find the boot sector so it shuts down tries again etc.


Sep 24, 2009 | ECS C51GM-M Motherboard

1 Answer

PC will not boot, monitor is blank, & PC makes (1) single beep every few seconds

If you have its motherboard manual, try to check its beep code. This will give you some clue on what is the fault.

Usually this could be dirty contact of RAM and video card. Try to clean its contact or you can try to reseat it first. If that not fix it clean it with clean soft eraser, its edge contact connector. But do this with your unit completely power off and unplugged from wall socket and UPS if you have.

Or some shorted component. Try to check it one by one to find the fault.

Post comment if this doesn't fix it.

Jul 07, 2009 | ECS C51GM-M Motherboard

1 Answer

Video controller drivers not found

That is the nvidia driver you need. 

However to get it to work right boot into safe mode, uninstall the Windows generic drivers, cancel the auto install and then run this driver's install program. 

Sep 17, 2008 | ECS C51GM-M Motherboard

1 Answer

Hot power supply possibly damaged motherboard

Welcome to FIXYA

As what i can tell sounds like the motherboard might of got damaged when you let the power supply over heat

sorry thats what i think

have a good day :)

Jul 15, 2008 | EliteGroup C51GM-M Motherboard

2 Answers

Presario SR1030AN Turning on but not booting or POST or no any beep at all.

Have you tried switching the power supply out with one that is known good?

Nov 26, 2007 | ASUS A7V8X Motherboard

Not finding what you are looking for?
ECS C51GM-M Motherboard Logo

Related Topics:

264 people viewed this question

Ask a Question

Usually answered in minutes!

Top ECS Motherboards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Richard Finch

Level 3 Expert

397 Answers


Level 3 Expert

5660 Answers

Are you an ECS Motherboard Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides