Question about Sony Xplod (P589) Car Subwoofer

1 Answer

1 subwoofer stopped working in a box for 2

I have 2 12'' sony explode subwoofers with a alpine amp. in my car. i checked all of the wiring and everything is conected corectly and only 1 of the subwoofers is working. any solutions?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 655 Answers

Hello mccanello55,

You need to remove the subs from the box in order to check the internal box wiring. First, make sure that the wire going from the nonworking sub terminals to the enclosure terminals is OK. Then check the "braided" leads on the back of the terminals going to the speaker cone. If the wiring all looks OK, remove the wires from the sub terminals, and use a multimeter set to the lowest ohm range and check the resistance across the subs terminals. You should read somewhere between 3-4 ohms. If the meter reads infinity (that is no reading at all), then the voice coil is open. If it "pegs" (reads "0"), the coil is shorted.

Either open or shorted means the voice coil is no longer working.

I could not find any replacement parts on Sony's support page, so it's most likely that they don't even repair these. They probably just replace the sub if it's under warranty, and if it's not under warranty, they probably recommend that you buy a new one.

Hope this helps.

Posted on Apr 13, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a mono block kenwood amp and a type r sub their is no sound to my sub but there is power to the amp just no sound


Check your subs impedance to establish speaker is working ,Check crutch field advisors website for sub box construction and detailed wiring instructions.

Aug 06, 2014 | Alpine Type-R SWR-1242D Car Subwoofer

1 Answer

8" compact subwoofer not working it was installed


post more information about your amp. its likely the vibrations moved something in the amps, or buttons.

Oct 10, 2013 | Alpine Swe-1000 8" Compact Subwoofer...

1 Answer

I just picked up a 12" type r in a box with a alpine m 350 how do I know what kind of type R I have without taking it out of the box?? and how do i hook it up to this amp??


Not to insult you in any way but u need to know how to wire into car's electrical system at the battery then to a fuse then to the amp and then output the signal from the deck to the amp.. finally to the subwoofer. you need to hook up 12V constant battery power , then remote from the deck ,ground wire from amp to chasis for power.. then wire to sub.

Sep 10, 2009 | Alpine SWR-1222D 12" Type-R Series...

1 Answer

Sub cutting out


Check the 12v wire running from the battery to the amplifier. Also the sony explode is a garbage subwoofer compared to the Alpine.. sony (they say 1200w max but its more like 100w to power the thing) Amp could be going. Is the amplifier hot when running. If there is a burnt smell comming from the amp, its the amplifier

Mar 27, 2009 | Alpine Type-R SWR-1222D Car Subwoofer

1 Answer

How to wire 2 ohm 2 12ich alpine type r's to box terminals?


Dual 4 ohm subwoofers can only be wired @ 1 ohm, 4 ohm or 8 ohm.
2 ohm mono load is not possible.
You will need to use (1) subwoofer to get the 1000W out of the amp.
Wire both positives on one sub to + on amplifier and both - on the same sub to - on amplifier to give the amplifier a 2 Ohm load.
Add a second amplifier, or buy an amplifier that is 1 ohm mono stable.
You can wire both to the amplifier at 4 ohms 600W, but they will share the power and only see 300W ea.

Jan 12, 2009 | Alpine Type-R SWR-1242D Car Subwoofer

1 Answer

My subwoofer stops when volume is increased


have u check the radio out do u have an eq

May 19, 2008 | Kicker CVR12 Car Subwoofer

Not finding what you are looking for?
Sony Xplod (P589) Car Subwoofer Logo

551 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Philip Rowney
Philip Rowney

Level 2 Expert

94 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...